Subject: [Gen-art] draft-ietf-sip-eku-05.txt

From: Francis Dupont <[email-masked]>
Date: Mon, 08 Jun 2009 15:28:11 +0200

I have been selected as the General Area Review Team (Gen-ART) 
reviewer for this draft (for background on Gen-ART, please see 
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html). 

Please resolve these comments along with any other Last Call comments 
you may receive. 

Document: draft-ietf-sip-eku-05.txt
Reviewer: Francis Dupont
Review Date: 2009-06-02
IETF LC End Date: 2009-06-05
IESG Telechat date: unknown

Summary: Ready

Major issues: None

Minor issues: None

Nits/editorial comments: 
(I apologize to have been late to send this review)
 - 1.2 page 3: X.680 [5],X.690 [6]. -> X.680 [5], X.690 [6].

 - 3 page 4:
   the application need not recognize -> needs???
   (BTW the spelling error, if it is an error, is in RFC 5280)

 - 9.1 page 7: IMHO (and shown by experience) numbering of references
  can lead to problems... I suggest to go to named references for next
  documents, in particular if they are longer.

Regards

[email-masked]

PS: I don't comment about the EKU idea, I've seen some PKI experts in
Acknowledgments so I expect you do the right thing.

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 09 Jun 2009 10:36:22 -0500

> Please resolve these comments along with any other Last Call comments 

Francis: Thank you for your review of the draft.  More inline.

>  - 1.2 page 3: X.680 [5],X.690 [6]. -> X.680 [5], X.690 [6].

Thanks, will fix with any other comments from IETF LC.

>    (BTW the spelling error, if it is an error, is in RFC 5280)

I believe that in this context, "need" is grammatically
correct -- "needs not recognize..." does not seem to read very
well.

> Acknowledgments so I expect you do the right thing.

Yes; the draft was socialized extensively with PKIX WG.  We
even had a WG meeting slot to present the work and solicit
face-to-face comments from PKIX during the formation of the
work.  The LC in SIP also was CC'd to the PKIX WG and
comments solicited from that as well.

Thank you.

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Francis Dupont <[email-masked]>
Date: Wed, 10 Jun 2009 17:53:58 +0200

=> there are in fact two questions:
 - is need the verb and the application the subject, in this case
  this seems to be a spelling error
 - in a quote should a spelling error be fixed? IMHO it should not.
So I put some '?' to mark I have no strong opinion about this.

   
=> I missed most of last PKIX WG meetings (I can't be at two places
at the same time :-) but I know who are the leaders in this WG
(and the mixed opinion about EKUs in the community). BTW it is
a typical LC item (it should be hard to find a more typical thing :-).

Thanks