Subject: Re: [Gen-art] Gen-ART review of draft-ietf-netconf-partial-lock-08.txt

From: Balazs Lengyel <[email-masked]>
Date: Wed, 01 Jul 2009 16:28:21 +0200

Hello Suresh,
First my mail system messed up your mail, so if I am missing something please forgive me.
See answers below!
Balazs

Suresh Krishnan wrote:

On 09-06-25 06:16 AM, Balazs Lengyel wrote:
<snip>
> The case mentioned in the paragraph is if the XPath is <select>
>    /usr:top/usr:user
> </select>
>
> The above expression will select every individual user at the time of
> locking (Paul, Suresh). However if we use
>
> <edit-config>
>   <config>
>     <top>
>       <user>
>         <name>Joe</name>
>       </user>
>     </top>
>   </config>
> </edit-config>
>
> A new user Joe is added. Joe is not locked in this case.

My question is that since I locked the top level user node, how can a new user be added while I
am holding a lock?

BALAZS: sticking to the model in the previous mail, you did not lock the top level node. Why 
would you think that? The select XPath expression (/usr:top/usr:user) will give you back the 
individual user nodes, but not the the top level node "top".
Section 2.4.1 does not use the same data model as Appendix C.

>
> The text mentions the "list of 'user' nodes". A node called "userS" is
> not mentioned.

I got this <users> straight from Section 7-Appendix C. If you say this is not correct, then
appendix C needs to be fixed :-).

BALAZS: Section 2.4.1 does not use the same data model as Appendix C. I believe both are 
correct, but use different data models as examples.
If I would change the paragraph in 2.4.1 to a list of interfaces instead of a list of users, 
would that improve the situation?

---------------------------------------------------------
BALAZS Lengyel EARLIER wrote:

BALAZS:
(Examples without namespaces and with some simplifications)
Lets assume we have the following model

container top {
   list user {
     key name;
     // data about individual user
   }
}

with  management data like

<top>
   <user>
     <name>Paul</name>
   </user>
   <user>
     <name>Suresh</name>
   </user>
</top>

The case mentioned in the paragraph is if the XPath is
<select>
    /usr:top/usr:user
</select>

The above expression will select every individual user at the time of locking (Paul, Suresh). 
However if we use

<edit-config>
   <config>
     <top>
       <user>
         <name>Joe</name>
       </user>
     </top>
   </config>
</edit-config>

A new user Joe is added. Joe is not locked in this case.

The text mentions the "list of 'user' nodes". A node called "userS" is not mentioned.

---

From: Suresh Krishnan <[email-masked]>
Date: Fri, 03 Jul 2009 00:48:44 -0400

Hi Balazs,

On 09-07-01 10:28 AM, Balazs Lengyel wrote:
> BALAZS: Section 2.4.1 does not use the same data model as Appendix C. I 
> believe both are correct, but use different data models as examples.
> If I would change the paragraph in 2.4.1 to a list of interfaces instead 
> of a list of users, would that improve the situation?

That clarifies it for me. If you can make the change, it would be great.

Thanks
Suresh