Subject: [Gen-art] Gen Art review of draft-ietf-softwire-lb-03

From: Avshalom Houri <[email-masked]>
Date: Thu, 2 Jul 2009 16:00:25 +0300

I have been selected as the General Area Review Team (Gen-ART) 
reviewer for this draft (for background on Gen-ART, please see 
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html). 

Please resolve these comments along with any other Last Call comments 
you may receive. 

Document: draft-ietf-softwire-lb-03
Reviewer: Avshalom Houri
Review Date: 2009-07-02
IETF LC End Date: 2009-07-03
IESG Telechat date: (if known) --

Summary: The document needs to update the security section in order to be 
ready for publication as a Proposed Standard.

Major issues: 

Line 269:
   There are no additional security risks introduced by this design.

- The above is the while text in the security considerations section. 
Please specify where the basic security discussion for this was done. 
Please also say in few words why do you think that no security issues are 
introduced in this document.

Minor issues: None

Nits/editorial comments: None

Thanks
--Avshalom

---

From: Carlos Pignataro <[email-masked]>
Date: Mon, 06 Jul 2009 10:41:47 -0400

Avshalom,

Thank you for your review. As you identified, it would be useful to cite
the applicable security considerations that are documented and
inherited. I think that the following change would address your
concerns. This document defines a very incremental addition of a
sub-TLV, it would seem that further elaboration would be redundant:

 4.  Security Considerations

+   This document defines a new sub-TLV for the BGP Tunnel Encapsulation
+   Attribute.  Security considerations for the BGP Encapsulation SAFI
+   and the BGP Tunnel Encapsulation Attribute are covered in [RFC5512].
    There are no additional security risks introduced by this design.

Please let us know if this addresses your concerns.

Thanks,

-- Carlos.

On 7/2/2009 9:00 AM, Avshalom Houri wrote:
> Summary: The document needs to update the security section in order to
> be ready for publication as a Proposed Standard.
> 
> Major issues:
> 
> Line 269:
> Please also say in few words why do you think that no security issues
> are introduced in this document.
> 
> Minor issues: None
>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 6 Jul 2009 11:07:28 -0400

Hi Avshalom,

I think that the phrase you added (copied from the email body) is well
understood form the first new sentence for someone implementing this. I
mean, the text:

"Since this document defines a very incremental addition of a sub-TLV, "

Is implied (and sounds repetitive) from:

"This document defines a new sub-TLV for the BGP Tunnel Encapsulation
Attribute."

So instead of us qualifying the addition with "very incremental", it is
less ambiguous to quantify it with "a new sub-TLV for the BGP Tunnel
Encapsulation Attribute". IOH, the first sentence re-summarizes the
extent of the change for the context of the Security paragraph. 

Does this make sense?

Thanks,

-- Carlos.

From: Avshalom Houri [mailto:[email-masked]] 
Sent: Monday, July 06, 2009 10:58 AM
To: Carlos Pignataro (cpignata)
Cc: Clarence Filsfils (cfilsfil); General Area Review Team; Pradosh
Mohapatra (pmohapat); Ralph Droms (rdroms)
Subject: Re: Gen Art review of draft-ietf-softwire-lb-03

Maybe like this? 

+   This document defines a new sub-TLV for the BGP Tunnel Encapsulation
+   Attribute.  Security considerations for the BGP Encapsulation SAFI
+   and the BGP Tunnel Encapsulation Attribute are covered in [RFC5512].
+   Since this document defines a very incremental addition of a
+   sub-TLV, there are no additional security risks introduced by this
design. 

Thanks
--Avshalom

From: 

Carlos Pignataro <[email-masked]> 

To: 

Avshalom Houri/Haifa/IBM@IBMIL 

Cc: 

[email-masked], [email-masked], General Area Review Team
<[email-masked]>, [email-masked] 

Date: 

06/07/2009 05:43 PM 

Subject: 

Re: Gen Art review of draft-ietf-softwire-lb-03

________________________________

Avshalom,

Thanks,

-- Carlos.

On 7/2/2009 9:00 AM, Avshalom Houri wrote:
> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html
<http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html> ).

---

From: Avshalom Houri <[email-masked]>
Date: Mon, 6 Jul 2009 18:14:38 +0300

Hi Carlos,

OK with me as long as everyone that is familiar with the field understand 
why this change does not introduce new security risks.

Thanks
--Avshalom

From:
"Carlos Pignataro (cpignata)" <[email-masked]>
To:
Avshalom Houri/Haifa/IBM@IBMIL
Cc:
"Clarence Filsfils (cfilsfil)" <[email-masked]>, "General Area Review 
Team" <[email-masked]>, "Pradosh Mohapatra (pmohapat)" 
<[email-masked]>, "Ralph Droms (rdroms)" <[email-masked]>
Date:
06/07/2009 06:07 PM
Subject:
RE: Gen Art review of draft-ietf-softwire-lb-03

Hi Avshalom,
 
I think that the phrase you added (copied from the email body) is well 
understood form the first new sentence for someone implementing this. I 
mean, the text:
?Since this document defines a very incremental addition of a sub-TLV, ?
Is implied (and sounds repetitive) from:
?This document defines a new sub-TLV for the BGP Tunnel Encapsulation 
Attribute.?
 
So instead of us qualifying the addition with ?very incremental?, it is 
less ambiguous to quantify it with ?a new sub-TLV for the BGP Tunnel 
Encapsulation Attribute?. IOH, the first sentence re-summarizes the extent 
of the change for the context of the Security paragraph. 
 
Does this make sense?
 
Thanks,
 
-- Carlos.

Maybe like this? 

Thanks
--Avshalom

From: 

Avshalom,

Thanks,

-- Carlos.

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 6 Jul 2009 11:48:26 -0400

Thanks again, Avshalom, for the comments (that improve the document)  
and for taking the time to review!

--
Thumb typed by Carlos Pignataro.

On Jul 6, 2009, at 11:18 AM, "Avshalom Houri" <[email-masked]>  
wrote:

> Hi Carlos,
>
> OK with me as long as everyone that is familiar with the field  
> understand why this change does not introduce new security risks.
>
> Thanks
> --Avshalom
>
>
>
>
> From:	"Carlos Pignataro (cpignata)" <[email-masked]>
> To:	Avshalom Houri/Haifa/IBM@IBMIL
> Cc:	"Clarence Filsfils (cfilsfil)" <[email-masked]>, "General  
> Area Review Team" <[email-masked]>, "Pradosh Mohapatra (pmohapat)"  
> Date:	06/07/2009 06:07 PM
> Subject: 	RE: Gen Art review of draft-ietf-softwire-lb-03
>
>
>
>
> Hi Avshalom,
>
> I think that the phrase you added (copied from the email body) is  
> well understood form the first new sentence for someone implementing  
> this. I mean, the text:
> “Since this document defines a very incremental addition of a sub-TL 
> V, ”
> “This document defines a new sub-TLV for the BGP Tunnel Encapsulatio 
> n Attribute.”
>
> So instead of us qualifying the addition with “very incremental”,  
> it is less ambiguous to quantify it with “a new sub-TLV for the BGP  
> Tunnel Encapsulation Attribute”. IOH, the first sentence re-summariz 
> es the extent of the change for the context of the Security paragraph.
>
> Does this make sense?
>
> Thanks,
>
> -- Carlos. 
>
> +   sub-TLV, there are no additional security risks introduced by  
> this design.
>
> Thanks
> --Avshalom
>
> From:	Carlos Pignataro <[email-masked]>
> To:	Avshalom Houri/Haifa/IBM@IBMIL
> Cc:	[email-masked], [email-masked], General Area Review Team  
> Date:	06/07/2009 05:43 PM

---

From: Avshalom Houri <[email-masked]>
Date: Mon, 6 Jul 2009 17:58:20 +0300

Maybe like this?

Thanks
--Avshalom

From:

Avshalom,

Thanks,

-- Carlos.