Subject: [Gen-art] Gen-ART review of draft-ietf-sipcore-presence-scaling-requirements-02

From: Christian Vogt <[email-masked]>
Date: Tue, 22 Sep 2009 17:01:32 -0400

I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document..........:  draft-ietf-sipcore-presence-scaling-requirements-02
Reviewer..........:  Christian Vogt
Review date.......:  September 22, 2009
IESG Telechat date:  September 24, 2009

Summary:  This draft is basically ready for publication, but has nits
           that should be fixed before publication.

This document describes requirements for SIP/SIMPLE optimizations,
primarily to address scalability issues that have been observed for
SIP/SIMPLE deployments.

The document is well-written and concise, and it is basically ready for
publication.  Two comments, though, which the authors may want to
consider:

- It would be worth mentioning in the introduction of the document what
   the expected result of this document should be.  Obviously, we are
   expecting (or hoping for) an improvement in the scalability of
   SIP/SIMPLE, but this should be made explicit.  Also, do we have
   estimates of how much SIP/SIMPLE will improve?

- The document only talks about "optimizations" to which the defined
   requirement should apply.  How about other types of protocol
   enhancements, such as functional extensions?  Wouldn't the defined
   requirements apply to those just as well?

Good luck with the publication!

- Christian

---

From: Avshalom Houri <[email-masked]>
Date: Wed, 23 Sep 2009 16:50:25 +0300

Thanks for your review. Comments inline.

--Avshalom

[email-masked] wrote on 23/09/2009 12:01:32 AM:

> From:
> 
> Christian Vogt <[email-masked]>
> 
> To:
> 
> Gen-ART Mailing List <[email-masked]>, "[email-masked]" 
<[email-masked]>
> 
> Cc:
> 
> "[email-masked]" <[email-masked]>, "[email-masked]" 
> <[email-masked]>, Avshalom Houri/Haifa/IBM@IBMIL, 
> "[email-masked]" <[email-masked]>, "[email-masked]" <hgs
> [email-masked]>, "[email-masked]" 
> <[email-masked]>
> 
> Date:
> 
> 23/09/2009 12:02 AM
> 
> Subject:
> 
> [Gen-art] Gen-ART review of draft-ietf-sipcore-presence-scaling-
> requirements-02
> 
> Sent by:
> 
> [email-masked]
> 

These are defined by the requirements themselves specifically in 3.3.
It is not possible to know how much the protocol will improve until we
will have actual requirements that we will be able to analyze.

>    requirements apply to those just as well?

No. Functional requirements are not in the scope of this document.

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art