Subject: [Gen-art] Gen-ART review of draft-nottingham-site-meta-03

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 16 Oct 2009 10:54:37 -0500

I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-nottingham-site-meta-03
Reviewer: Vijay K. Gurbani
Review Date: Oct 16, 2009
IETF LC End Date: Nov 6, 2009
IESG Telechat date: unknown

Summary: This draft is ready for publication as a UNKNOWN document.

Note that I am not sure what the intended status of this
document is (hence the "UNKNOWN" above.)  The draft itself appears
to think it is headed for "Informational", but the IETF Tracker
appears to think otherwise -- it thinks that the intended
status is "Proposed Standard" (please see
https://datatracker.ietf.org/idtracker/draft-nottingham-site-meta/).

Other than that, the draft has:

Major issues: 0.
Minor issues: 1.
Nits/editorial comments: 0.

Minor issue:

1) In the past when we have established some of these registries
  (c.f., rfc5341, rfc3969) we have populated these registries
  with "initial values" --- essentially grand-fathering existing
  usages.

  Given that, I am merely curious on whether it makes sense to
  grand-father in the "robots.txt" usage in this draft?  Of
  course, implementations would still search for "robots.txt"
  in the normal location.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 16 Oct 2009 11:13:45 -0500

Eran Hammer-Lahav wrote:
> The draft was initially proposed as informational but with the
> support of the area director, the last call was made to promote it to
> a proposed standard. Assuming there is no objection, we would like it
> changed to standards track.

Eran: That is for the AD and/or the WG to decide.

> What we can do is include an appendix with the list of all known 
> well-known locations outside the new prefix to help in documenting 
> existing practices. However, that is not likely to be complete and 
> might cause a long delay in publication.

Nah, don't worry.  I was mostly curious to see if grand-fathering
made sense here, and it appears from your arguments that it may
hurt more than help.

I don't have any further comments on the document.

Thanks,

- vijay

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Fri, 16 Oct 2009 09:07:20 -0700

Thanks for the feedback. Comments inline.

> -----Original Message-----
> From: Vijay K. Gurbani [mailto:[email-masked]]
> Sent: Friday, October 16, 2009 8:55 AM
> To: [email-masked]; Eran Hammer-Lahav
> Cc: [email-masked]; Lisa Dusseault
> Subject: Gen-ART review of draft-nottingham-site-meta-03
> 

The draft was initially proposed as informational but with the support of the area director, the last call was made to promote it to a proposed standard. Assuming there is no objection, we would like it changed to standards track.

>   course, implementations would still search for "robots.txt"

The problem is that the registry is only for well-known location documents located within the /.well-known/ prefix. Since robots.txt and other such document (p3 and cross domain for example) are located in the root, adding them to the registry will cause confusion since it will change their expected location:

http://example.com/.well-known/robots.txt

Proposing such a migration is not likely to make any actual deployment difference (the millions of sites using it already are not likely to move it or copy it), but is likely to confuse new developers.

I think what is more likely is for future versions of these files and new files to use the registry and avoid collision.

What we can do is include an appendix with the list of all known well-known locations outside the new prefix to help in documenting existing practices. However, that is not likely to be complete and might cause a long delay in publication.

EHL