Subject: [Gen-art] Gen-ART LC Review of draft-ietf-idnabis-rationale-13

From: Ben Campbell <[email-masked]>
Date: Tue, 13 Oct 2009 16:36:19 -0500

I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-idnabis-rationale-13
Reviewer: Ben Campbell
Review Date: 2009-Oct-13
IETF LC End Date: 2009-Oct-13
IESG Telechat date: (if known)

Summary:

This draft is ready for publication as an informational RFC.

Note: This draft is tightly intertwined with other IDNABIS drafts that  
I assume to be progressing together. I reviewed this draft on it's  
own, and only referenced the others when needed to understand this  
one. I explicitly did _not_ verify that the information in this draft  
is consistent with the others.

Major issues:

None

Minor issues:

None

Nits/editorial comments:

-- Section 3.1.2.2, 2nd paragraph:

This paragraph seems redundant with the preceding one.

-- Section 3.1.3, first bullet in list:

Please expand NFKC on first use.

-- section 7.1.1, first paragraph: "...defined in the "Protocol" and  
"Tables" documents"

Reference forms inconsistent with other references to these same docs  
elsewhere in the draft.

---

From: Vint Cerf <[email-masked]>
Date: Tue, 13 Oct 2009 23:23:29 -0400

thanks Ben, input much appreciated - minor comments can be addressed  
by the document editor.

v

On Oct 13, 2009, at 5:36 PM, Ben Campbell wrote:

> Note: This draft is tightly intertwined with other IDNABIS drafts  
> that I assume to be progressing together. I reviewed this draft on  
> it's own, and only referenced the others when needed to understand  
> this one. I explicitly did _not_ verify that the information in this  
> draft is consistent with the others.
>
> Major issues:
>
> None
>
> Minor issues:
>
> None
>
> Nits/editorial comments:
>
> Reference forms inconsistent with other references to these same  
> docs elsewhere in the draft.
>
>

---

From: John C Klensin <[email-masked]>
Date: Sun, 25 Oct 2009 23:25:59 -0400

--On Tuesday, October 13, 2009 16:36 -0500 Ben Campbell
<[email-masked]> wrote:

>...
>...

Stupid copy-and-paste error.  Fixed.

> Please expand NFKC on first use.

I've done that, but the result is not satisfying (i.e., "NFKC"
expands to "Normalization Method KC".  This is a Unicode issue,
not an IETF one.

> -- section 7.1.1, first paragraph: "...defined in the
> "Protocol" and "Tables" documents"
> 
> Reference forms inconsistent with other references to these
> same docs elsewhere in the draft.

Sigh.  I could try to explain why I did that, but I fixed it
instead :-(.

    john