Subject: [Gen-art] review of draft-ietf-hokey-preauth-ps-09.txt

From: Francis Dupont <[email-masked]>
Date: Mon, 02 Nov 2009 16:14:03 +0100

I have been selected as the General Area Review Team (Gen-ART) 
reviewer for this draft (for background on Gen-ART, please see 
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html). 

Please resolve these comments along with any other Last Call comments 
you may receive. 

Document: draft-ietf-hokey-preauth-ps-09.txt
Reviewer: Francis Dupont
Review Date: 2009/10/29
IETF LC End Date: 2009/10/21
IESG Telechat date: unknown

Summary: Ready

Major issues: None

Minor issues: None

Nits/editorial comments: 
 - Abstract page 2: Extensible Authentication Protocol -> ... (EAP)

 - Introduction page 4: authentication and authorization -> plural
  (this -> these, requires -> require)

 - 3.3.1 page 8: two forms:. ... -> two forms: horizontal and vertical.
  (or: Horizontal and Vertical.)

 - 5 page 10: portion -> part?

 - 5 page 10: there is no b in 2: 2(b) -> 2?

 - 6 page 11: L2 -> layer 2 (or IMHO better link layer).
  I suggest to keep L2 and co to figure and to expend them in the text.

 - 6.1 page 13 and 6.2 page 14: the same

 - 13.1 RFC 4962 is a BCP and is in the normative references?
  (just a question, I believe you've checked it is allowed).

 - 13.2 pages 19 and 20: some spurious spaces before commas.

 - 13.2 page 19: bad cut in URLs (<\nhttp or <htt\np...)

 - Authors' Addresses page 20:
  * +1 (732) 699-5365 -> +1 732 699-5365
  * US -> USA
  I expected China in place of PRC but you should know the official name
  of your own country far better than me (:-).

Regards

[email-masked]

---

From: Qin Wu <[email-masked]>
Date: Tue, 03 Nov 2009 10:59:00 +0800

Hi,
Thank for your taking time review. We will take care of your precious comments soon!

Regards!
-Qin

---

From: Qin Wu <[email-masked]>
Date: Wed, 25 Nov 2009 16:36:29 +0800

Hi,Francis:
Sorry for my late reply, please see my answer below.
If your comments are really addressed, please let us know.

Regards!
-Qin
----- Original Message ----- 
From: "Francis Dupont" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Monday, November 02, 2009 11:14 PM
Subject: review of draft-ietf-hokey-preauth-ps-09.txt

> - Abstract page 2: Extensible Authentication Protocol -> ... (EAP)

[Qin]: Accepted. 

>  (this -> these, requires -> require)

[Qin]: Okay.

>  (or: Horizontal and Vertical.)

[Qin]: Thank for your correcting this typo.

> - 5 page 10: portion -> part?

[Qin]: I am okay with this change.

> - 5 page 10: there is no b in 2: 2(b) -> 2?

[Qin]: Sorry for this typo. the 2(b) and 3 should be 1(b) and 2.

>  I suggest to keep L2 and co to figure and to expend them in the text.

[Qin]: Okay, maybe the proper way to fix this would be
spell out the first occurence of L2 as "Layer 2" and then 
use the abbrevations "L2" instead when it occurs again.

> - 6.1 page 13 and 6.2 page 14: the same

[Qin]: Same as above.
 
>  (just a question, I believe you've checked it is allowed).

[Qin]:Yes, it's allowed as normative references.

> - 13.2 pages 19 and 20: some spurious spaces before commas.

[Qin]: Okay These additional spaces will be removed in the next version.

> - 13.2 page 19: bad cut in URLs (<\nhttp or <htt\np...)

[Qin]: Accepted.

> - Authors' Addresses page 20:

[Qin]: Okay, Thank for your correction. Also this should be consistent with the rest of the section "author's addresses".

>  of your own country far better than me (:-).

[Qin]: I believe China is the offical name. It is not necessary to emphasize whether it is PRC or Republic of China.
Thank for your reminding,:-).