Subject: [Gen-art] Gen-ART review of draft-ietf-tls-renegotiation-01

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 18 Dec 2009 10:59:34 -0600

I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-tls-renegotiation-01.txt
Reviewer: Vijay K. Gurbani
Review Date: Dec. 18, 2009
IETF LC End Date: Dec. 17, 2009
IESG Telechat date: Unknown

Summary: This draft is ready for publication as a Proposed Standard.

The draft has 0 major issues, 0 minor issues, and 3 nits.

Nits:

1) S1: The second sentence may read better if
  s/no cryptographic connection between/no cryptographic relationship
  between/

  "Connection" is an overused term in the context of TLS anyway.

2) S1: Last paragraph:
  s/same as, the date used/same as, the data used/

3) In reference [Ray09], no specific publication of record
  is provided.  I do not know whether or not this discovery
  has been officially published as part of any security-related
  conference proceedings, but if not, then maybe a link to the
  website of interest (http://extendedsubset.com/) may of
  appropriate?  More technical details are available at a
  resource from that website using the URL 
http://extendedsubset.com/wp-uploads/2009/11/renegotiating_tls_20091104_pub.zip.

  I realize that personal websites are not authoritative references,
  but assuming that the above website remains stable for some
  duration after this draft becomes an RFC, the above link may help
  people familiarize themselves with the attack in more detail
  than the draft goes into (and in any case, [Ray09] is an
  informative reference, not a normative one.)

  Alternatively, in the zip file above is a PDF document called
  "Renegotiating TLS.pdf".  Maybe that document, or maybe the
  entire zip file (uuencoded) could be provided as an appendix
  to this draft?   Just a thought.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 18 Dec 2009 11:24:59 -0600

Marsh Ray wrote:
> Any of that would be fine with me, I would just like to know where to
> upload, what links to maintain, how to cite, etc.

 From a self-containment point of view, a uuencoded zip file as
appendix is probably the best.  You can simply mention the
zip file in the appendix somewhere in your text.

That said, I will leave it to ekr (who's a long time IETF
contributor) and other co-authors to decide whether that is
the option you want to take.  Certainly, any extra pointers
that can be imparted to the casual reader to better understand
the attack will be worthwhile.

Thanks,

- vijay

---

From: Marsh Ray <[email-masked]>
Date: Fri, 18 Dec 2009 11:16:04 -0600

Vijay K. Gurbani wrote:
>  conference proceedings,

Steve Dispensa and I have submitted to a few, and are confirmed speakers
for two at this point. Both are early 2010.
http://troopers.de/content/e2/index_eng.html
http://www.shmoocon.org/presentations-all.html

We expect to have more and better material for the conferences.

> but if not, then maybe a link to the

I will attempt to keep whatever links are published alive indefinitely.
However, at the end of the day it is a personal site. On the other hand,
I have been maintaining stuff on the net in one capacity or other over
several generations of corporations. I don't see anything inherent about
a corporate site that would make it a better reference, they break links
all the time.

- Marsh

---

From: Nasko Oskov <[email-masked]>
Date: Fri, 18 Dec 2009 22:07:04 +0000

I agree that having a permanent copy of the zip file is very useful. I do not believe we should be attaching it as uuencoded appendix:

~/tmp[6]$ uuenview -u renegotiating_tls_20091104_pub.zip  | wc -l
  14001

Compared to the length of the actual draft, this is huge and if printed without paying too much attention, it can waste a lot of paper.
I'm not very well versed in IETF practices, but can we "attach" it as separate uuencoded file?

Thanks,
Nasko

-----Original Message-----
From: Vijay K. Gurbani [mailto:[email-masked]] 
Sent: Friday, December 18, 2009 9:25 AM
To: Marsh Ray
Cc: [email-masked]; [email-masked]; Nasko Oskov; Pasi Eronen; General Area Review Team; [email-masked]
Subject: Re: Gen-ART review of draft-ietf-tls-renegotiation-01

Marsh Ray wrote:
>> "Renegotiating TLS.pdf".  Maybe that document, or maybe the  entire 
>> zip file (uuencoded) could be provided as an appendix

 From a self-containment point of view, a uuencoded zip file as appendix is probably the best.  You can simply mention the zip file in the appendix somewhere in your text.

That said, I will leave it to ekr (who's a long time IETF
contributor) and other co-authors to decide whether that is the option you want to take.  Certainly, any extra pointers that can be imparted to the casual reader to better understand the attack will be worthwhile.

Thanks,

- vijay

---

From: "Steve Dispensa" <[email-masked]>
Date: Fri, 18 Dec 2009 17:54:24 -0500

PhoneFactor would be glad to provide a permanent link.

  -Steve

On Dec 18, 2009, at 5:06 PM, "Nasko Oskov" <[email-masked]> wrote:

> I agree that having a permanent copy of the zip file is very useful.  
> I do not believe we should be attaching it as uuencoded appendix:
>
> Compared to the length of the actual draft, this is huge and if  
> printed without paying too much attention, it can waste a lot of  
> paper.
> Cc: [email-masked]; [email-masked]; Nasko Oskov; Pasi  
> Eronen; General Area Review Team; [email-masked]
> appendix is probably the best.  You can simply mention the zip file  
> in the appendix somewhere in your text.
>
> contributor) and other co-authors to decide whether that is the  
> option you want to take.  Certainly, any extra pointers that can be  
> imparted to the casual reader to better understand the attack will  
> be worthwhile.
>
> Thanks,
>
> - vijay
> --

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 21 Dec 2009 11:21:45 -0600

> printed without paying too much attention, it can waste a lot of

True -- I failed to take the size of the zip file in account.  Even
uuencoding "Renegotiating TLS.pdf" takes up almost 4,000 lines.

In the end, please do what is expeditious.  This was an advisory
comment from Gen-ART anyway, not a critical one.  If a reference to
a publication is possible, that would be the best choice.  Barring
that, hosting the ZIP file on some permanent website and putting
the URL in an Informative Reference section is agreeable as well.
My aim was to help the casual reader find out more about this
topic without jumping too many hoops.

Thanks,

- vijay

---

From: "Steve Dispensa" <[email-masked]>
Date: Mon, 21 Dec 2009 11:33:51 -0600

I tried to send this the other day bit it doesn't look like it went  
through. I was just going to say that PhoneFactor would be glad to  
provide a permanent home for the document.

  -Steve

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 21 Dec 2009 11:36:09 -0600

> provide a permanent home for the document.

Steve: I did see that email.  That sounds good.

Thanks,

- vijay

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 21 Dec 2009 16:39:56 -0800

Steve,

can you send me a link to a permanent home?

-Ekr

On Mon, Dec 21, 2009 at 9:36 AM, Vijay K. Gurbani
<[email-masked]> wrote:
>> through. I was just going to say that PhoneFactor would be glad to provide a
>> permanent home for the document.
>

---

From: "Steve Dispensa" <[email-masked]>
Date: Mon, 21 Dec 2009 19:08:12 -0600

Will do. Stand by...

  -Steve

---

From: "Steve Dispensa" <[email-masked]>
Date: Tue, 22 Dec 2009 16:24:49 -0600

This will be a stable link:

http://www.phonefactor.com/Renegotiating_TLS.pdf

  -Steve

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 22 Dec 2009 15:07:20 -0800

Thanks!

Now I just need to figure out how to get xml2rfc to spit out the URL.

-Ekr