Subject: [Gen-art] Gen-art review of draft-ietf-capwap-802dot11-mib-05.txt

From: Elwyn Davies <[email-masked]>
Date: Sat, 12 Dec 2009 22:57:20 +0000

I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
_http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html_).

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-capwap-802dot11-mib-05.txt
Reviewer: Elwyn Davies
Review Date: 12 December 2009
IETF LC End Date: 7 December 2009
IESG Telechat date: (if known)=

Summary: Ready for the IESG.  There are a few editorial nits noted below 
(the example IP addresses need to be fixed).

Major issues: -

Minor issues: -

Nits/editorial comments:

s3: WLAN is defined but no expansion of the acronym is given.
s5.1: Possibly define/expand PHY.
s5.2, next to last bullet: s/manage/management/
s5.3, last sentence; expand BSS acronym
s7.2: The paragraph
>    Also, the AC MUST have a mechanism that preserves the value of the
>    WLAN Profile Interfaces' ifIndexes in the ifTable at AC reboot.
>   
is duplicated (last and last but 2).
s8:  The IP addresses should be taken from the 'example' ranges (see 
http://tools.ietf.org/html/draft-iana-ipv4-examples-01).  I don't know 
that there is an example MAC address - the RFC Editor should know.
s9: Maybe WLAN and BSS should be expanded here in the descriptions as well.

---

From: young <[email-masked]>
Date: Mon, 14 Dec 2009 19:09:58 +0800

Hi, Elwyn:

Thanks. Please check my comments.

s3: WLAN is defined but no expansion of the acronym is given.
[Editors]
It (WLAN) is got from the RFC5416 and the RFC5416 does not give any
expansion
of the acronym.
The issue here is: If we give an expansion to the WLAN (in the RFC5416),
readers would be confused with the WLAN (wireless local area networks) in
the IEEE 802.11.
You know: The RFC5416 talks about WLAN as a logic service, while the IEEE
802.11
talks about it as certain network.
Dan or CAPWAP chairs, please give some guidance here. Thanks.

s5.1: Possibly define/expand PHY.
[Editors]
How about: would use “physical layer (PHY)”in the place where it (PHY)
first appear. During the review of draft-ietf-capwap-base-mib-06.txt, a same
issues
Ever be raised. In the end, it was suggested to use the above way to modify.
Suggest to keep same.

s5.2, next to last bullet: s/manage/management/
[Editors] Yes, should be management

s5.3, last sentence; expand BSS acronym
[Editors] Yes, should be "basic service set (BSS)".

s7.2: The paragraph
>   is duplicated (last and last but 2).
[Editors] Although both sentences talk about the persistence mechanism of
the interface, the first one is for WLAN Profile Interface, and other one is
for WLAN BSS Interfaces. 
So it is not duplicated. Please check it again. Thanks.

[Editors] Ok, I never knew it before. The Ip would use the blocks
192.0.2.0/24 (TEST-NET-1). I have not found any block (RFC document rules)
for MAC address, so I suppose RFC Editor should know it.
For Ip address, draft-ietf-capwap-base-mib-06.txt has a same issue and
should be modified too.

s9: Maybe WLAN and BSS should be expanded here in the descriptions as well.
[Editors] Yes, BSS is ok. According to my comments to the s3, it requires
more
discussion.

Regards

Richard

-----邮件原件-----
发件人: Elwyn Davies [mailto:[email-masked]] 
发送时间: 2009年12月13日 6:57
收件人: General Area Reviwing Team
抄送: Mary Barnes; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]
主题: Gen-art review of draft-ietf-capwap-802dot11-mib-05.txt

Major issues: -

Minor issues: -

Nits/editorial comments:

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 14 Dec 2009 12:46:37 +0100

> -----Original Message-----
> From: young [mailto:[email-masked]] 
> Sent: Monday, December 14, 2009 1:10 PM
> To: 'Elwyn Davies'; 'General Area Reviwing Team'; Romascanu, Dan (Dan)
> Cc: 'Mary Barnes'; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Richard's comments to the Gen-art review of 
> draft-ietf-capwap-802dot11-mib-05.txt
> 
> Hi, Elwyn:
> 
> It (WLAN) is got from the RFC5416 and the RFC5416 does not 
> give any expansion of the acronym.
> The issue here is: If we give an expansion to the WLAN (in 
> the RFC5416), readers would be confused with the WLAN 
> (wireless local area networks) in the IEEE 802.11.

I believe that the comment is valid, especially if more than one meaning
(or nuances of the same meaning) may hide behind the acronym. My
proposal is to expand and to clarify how the term is used in this
document. 

Dan

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 14 Dec 2009 19:44:08 +0000

Hi.

Thanks for the responses.
There only seem to be a couple of discussion points.

The WLAN issue has been done to death elsewhere. I will be happy with
whatever expansion you agree on.

On s7.2. Yes, my mistake. They aren't duplicates.

I'll await the revised draft.

Regards,
Elwyn

---

From: young <[email-masked]>
Date: Tue, 15 Dec 2009 09:05:07 +0800

Hi, Elwyn:

Thanks your review comments.
On s7.2: Although the text is correct, I guess the text is still not good
enough which leads to your misunderstanding. Certain changes should be
better. 
Do you have any ideal how to modify it to avoid misunderstanding? 
If there is no better way, then let's keep current text.

Regards
Richard

-----邮件原件-----
发件人: Elwyn Davies [mailto:[email-masked]] 
发送时间: 2009年12月15日 3:44
收件人: young
抄送: 'General Area Reviwing Team'; [email-masked]; 'Mary Barnes';
[email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]
主题: Re: Richard's comments to the Gen-art review of
draft-ietf-capwap-802dot11-mib-05.txt

Hi.

Regards,
Elwyn

---

From: Elwyn Davies <[email-masked]>
Date: Tue, 15 Dec 2009 10:35:49 +0000

> enough which leads to your misunderstanding. Certain changes should be
The problem was just not attending to details.

> If there is no better way, then let's keep current text.
One possible way would be to combine the two paragraphs since the
requirements are the same:

Remove the first paragraph and replace the second with:
Also, the AC MUST have a mechanism that preserves the value of both the
WLAN Profile Interfaces' and the WLAN BSS Interfaces' ifIndexes in the
ifTable
at AC reboot.

Does that work? If not leave them as they are.

Regards,
Elwyn

>> first appear. During the review of draft-ietf-capwap-base-mib-06.txt, a
>>     
> same
>   
>> issues
>> Ever be raised. In the end, it was suggested to use the above way to
>>     
> modify.
>   
>> Suggest to keep same.
>>
>> the interface, the first one is for WLAN Profile Interface, and other one
>>     
> is
>   
>> for WLAN BSS Interfaces. 
>> s9: Maybe WLAN and BSS should be expanded here in the descriptions as
>>     
> well.
>   
>> 抄送: Mary Barnes; [email-masked];
>>     
> [email-masked];
>   
>> s9: Maybe WLAN and BSS should be expanded here in the descriptions as
>>     
> well.
>   
>>
>>
>>   
>>     
>
>
>