Subject: Re: [Gen-art] Gen-ART telechat review of draft-ietf-geopriv-geo-uri-04.txt

From: "Alexander Mayrhofer" <[email-masked]>
Date: Tue, 16 Feb 2010 09:40:51 +0100

FYI, my responses to that Gen-ART review from December are attached. 

Alex 

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]] 
> Sent: Tuesday, February 16, 2010 12:49 AM
> To: [email-masked]; General 
> Area Review Team
> Subject: Gen-ART telechat review of draft-ietf-geopriv-geo-uri-04.txt

Subject: RE: Gen-ART LC review of draft-ietf-geopriv-geo-uri-04.txt
From: "Alexander Mayrhofer" <[email-masked]>
To: "Brian E Carpenter" <[email-masked]>, <[email-masked]>, "General Area Review Team" <[email-masked]>
Cc: <[email-masked]>, "Cullen Jennings" <[email-masked]>
Date: Fri, 18 Dec 2009 13:56:56 +0100

Brian,

Thanks for the review - comments inline:

> Document: draft-ietf-geopriv-geo-uri-04.txt
> Reviewer: Brian Carpenter
> Review Date: 2009-12-09
> IETF LC End Date: 2009-12-18
> IESG Telechat date: 
>
> Summary: Ready
> --------
>
>
> Comment:
> --------
> 
> I'm sure this has been discussed and thought about, but it does strike
me that
> having a specific 20th century coordinate system as the default may
seem a bit
> odd in the future, if something like geo:13.4125,103.8667;crs=wgs2106
> becomes the norm. However, I have no changes to suggest. I might be
inclined
> to recommend including ;crs=wgs84 as best practice whenever such a URI
is
> included in a document or a database.

We have discussed that issue several times on the list, as well as in
person. Carl Reed voiced his opinion here:

http://www.ietf.org/mail-archive/web/geopriv/current/msg07784.html

What he also said in a different message (i couldn't find it, though)
was that "84" doesn't mean WGS-84 is an "old school, soon to be
obsoleted CRS" - if i understood it correctly, it was refined last in
2006 (for continental drift affecting the gravity model, if i got it
right), and all differences will be in the centimeter range for the
(geodetically) foreseeable future. 

The reference systems for GLONASS and GALILEO (russian and european
satellite navigation systems) will also differ only in the millimeter
range from WGS-84.

I sort of got the impression "changing the default CRS to something else
than WGS-84 is about as likely as changing the DNS to a new root..."
(however, it's of course a completely different issue).

We also decided it would be better to put the burden on reprojection on
the author of a geo URI instance, rather than the consumer, because
consumers should have less effort than authors (and very likely, there
would be much more consumers than authors..) - choosing a reasonable
default CRS helps tremendously.

Alex

Subject: RE: Gen-ART LC review of draft-ietf-geopriv-geo-uri-04.txt
From: "Alexander Mayrhofer" <[email-masked]>
To: "Brian E Carpenter" <[email-masked]>, <[email-masked]>, "General Area Review Team" <[email-masked]>
Cc: <[email-masked]>, "Cullen Jennings" <[email-masked]>
Date: Fri, 18 Dec 2009 14:07:50 +0100

I found the message regarding WGS-84 being updated:

http://www.ietf.org/mail-archive/web/geopriv/current/msg07302.html

I understand that if you'd want sub-inch precision, most reference
systems would require you to also add the time of the actual measurement
to the measurement itself.

I do, however, also note that this is also only relevant for
"professional" geology and geodesy, and likely not really relevant for
the use cases that we intend to cover.

If an application requires to use the full range of options available,
there would be always PIDF-LO.

Alex

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 17 Feb 2010 08:37:42 +1300

Alex,

Thanks. Indeed, as I said, I'm not suggesting any change to the
draft.

Regards
   Brian Carpenter

On 2010-02-16 21:40, Alexander Mayrhofer wrote:
>> ------------------------------------------------------------------------
>>
>> Subject:
>> RE: Gen-ART LC review of draft-ietf-geopriv-geo-uri-04.txt
>> From:
>> "Alexander Mayrhofer" <[email-masked]>
>> Date:
>> To:
>> "Brian E Carpenter" <[email-masked]>,
>> <[email-masked]>, "General Area Review
>> Team" <[email-masked]>
>>
>> To:
>> "Brian E Carpenter" <[email-masked]>,
>> <[email-masked]>, "General Area Review
>> Team" <[email-masked]>
>> CC:
>> <[email-masked]>, "Cullen Jennings" <[email-masked]>
>>
>>
>>  
>> Brian,
>>
>> ------------------------------------------------------------------------
>>
>> Subject:
>> RE: Gen-ART LC review of draft-ietf-geopriv-geo-uri-04.txt
>> From:
>> "Alexander Mayrhofer" <[email-masked]>
>> Date:
>> To:
>> "Brian E Carpenter" <[email-masked]>,
>> <[email-masked]>, "General Area Review
>> Team" <[email-masked]>
>>
>> To:
>> "Brian E Carpenter" <[email-masked]>,
>> <[email-masked]>, "General Area Review
>> Team" <[email-masked]>
>> CC:
>> <[email-masked]>, "Cullen Jennings" <[email-masked]>
>>
>>