Subject: Re: [Gen-art] Fwd: [Gen-ART] review of draft-ietf-tcpm-tcp-auth-opt-10.txt

From: Joe Touch <[email-masked]>
Date: Wed, 10 Mar 2010 13:35:33 -0800

Hi, all,

Including both TSV ADs, the WG chairs, and the authors in this response.
See below.

PS - it would be useful to include the document authors in Gen-ART
posts; we received this message indirectly by the IESG.

Joe

> -------- Original Message --------
> Subject: [Gen-art] [Gen-ART] review of draft-ietf-tcpm-tcp-auth-opt-10.txt
> Date: Tue, 9 Mar 2010 17:15:31 -0700
> From: Wassim Haddad <[email-masked]>
> To: Gen-art <[email-masked]>, Lars Eggert <[email-masked]>
> CC: Wassim Haddad <[email-masked]>
> 
> I have been selected as the General Area Review Team (Gen-ART) reviewer
> for this draft (for background on Gen-ART, please see
> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
> 
> Please resolve these comments along with any other Last Call comments
> you may receive.
> 
> Document: draft-ietf-tcpm-tcp-auth-opt-10
> Reviewer: Wassim Haddad
> Review Date: 2010-03-09
> LC End Date: 2010-03-11 IESG Telechat date: 2010-03-11
> 
> Summary: Ready
> 
> Major issues: None
> 
> Minor issues:
> 
> - Page 13, Figure 3: traffic keys derived show two "Send_Other_key" in
> all 3 boxes.
> Shouldn't be Rcv_Other_key?

Yes. To be fixed.

> - Page 37: sub-section 2: a) Privacy: "TCP exposes "only" the MKT IDs,
> MAC, and overall option.
> Question: is "only" really needed?

In this context, I believe so. The previous paragraph discusses other
information that could have been included, and this sentence underscores
that such information is not.

> Editorial/nits:
> 
> - section 2.1: TCP-AO "is" not intended to replace the use of IPsec...

To be fixed.

> - section 2.2: IMHO, the following sentence is not clear:
> 
> "This document differs from an IPsec/IKE solution in that TCP-AO as
> follows:"

To be fixed.

> - section 3: In this document, the characters ">>" proceeding...
> Is it proceeding or preceding?

The latter. To be fixed.

> - section 4.2: "The TCP-AO option fields do not indicate the MAC
> algorithm either implicitly (as with TCP MD5) or explicitly.
> 
> either/or -> neither/nor

The negative is already in the front of the sentence, so this should not
be updated as suggested.

> - section 5.2:
> 
> remove "Figure" (repeated twice)

To be fixed.

---

---

From: Wassim Haddad <[email-masked]>
Date: Wed, 10 Mar 2010 14:48:43 -0700

Hi Joe,

It is my mistake for not cc'ing the draft authors in my email to Gen-ART and I apologize for that.
Thanks for the clarification about "only" (it appeared to me first that the presence of the keyID "alone" may lead to breaking the unlinkability).

Regards,

Wassim H.