Subject: Re: [Gen-art] Gen-ART LC review of draft-ietf-ippm-twamp-session-cntrl-04.txt

From: Al Morton <[email-masked]>
Date: Tue, 16 Mar 2010 10:16:02 -0400

At 05:13 PM 3/11/2010, Brian E Carpenter wrote:
>Document: draft-ietf-ippm-twamp-session-cntrl-04.txt
>Reviewer: Brian Carpenter
>Review Date: 2010-03-12
>IETF LC End Date: 2010-03-15
>IESG Telechat date:
>
>Summary: Ready, except for normative reference issue.
>--------
>
>Major issue:
>------------
>
>    Implementers of this feature MAY also wish to implement the "Reflect
>    Octets" feature, described in [I-D.ietf-ippm-twamp-reflect-octets],
>    once it has been published as an RFC.
>
>I think this is a normative reference, even though it's optional, since
>it uses a normative keyword. That could be fixed by s/MAY/may/, but
>the later reference to the same draft is clearly normative:
>
>    If the Control-Client has selected the Reflect Octets feature
>    [I-D.ietf-ippm-twamp-reflect-octets] in combination with the
>    Individual Session Control feature (after the Server identified its
>    capability), AND utilizes the feature to insert a locally-specified
>    request number in the Request-TW-Session command, THEN the Control
>    Client MAY send more than one Request-TW-Session command to a given
>    Server without waiting for the corresponding Accept-Session message.
>    In such a case the Access-Session response reflects the locally-
>    specified request number.  Note that when the Reflect Octets feature
>    is being used all Request-TW-Session command and Accept-Session
>    responses MUST include the locally-specified request number.

Brian,

Thanks for your comments.

I think we could move the paragraph above
(the last paragraph in section 3.1) to the
ietf-ippm-twamp-reflect-octets draft, provide a
reference to the session-control draft (as an RFC when approved)
and resolve that particular normative reference issue.

Since TWAMP-Control session requests and ACKs always precede the
messages to start and stop sessions (the focus of this draft),
they are separable topics, to me at least. Perhaps the fact that
we could move this paragraph so easily means that the text should
not use normative "MAY" terms - it's just an observation on how
two features might be used together.

The scenario these features have in common is
"create and control many simultaneous test sessions".
But any system using "reflect-octets" in the way described
can launch simultaneous Request-TW-Session commands.

So, for the purposes of resolving your comments, we would
delete the last paragraph of section 3.1, and s /MAY/may/
as you suggested in the introduction.

Al

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 17 Mar 2010 12:12:34 +1300

That would be fine, and much less annoying than delaying
publication for a bureacratic issue.

(Sorry to act as a bureaucrat, but it's better to clear
such issues before someone in the IESG slaps a DISCUSS on it.)

   Brian

On 2010-03-17 09:46, Murtaza Chiba (mchiba) wrote:
> Works for me as well.
> 
> -murtaza
> 
> -----Original Message-----
> From: Al Morton [mailto:[email-masked]] 
> Sent: Tuesday, March 16, 2010 7:16 AM
> To: Brian E Carpenter;
> [email-masked]; General Area
> Review Team
> Subject: Re: Gen-ART LC review of
> draft-ietf-ippm-twamp-session-cntrl-04.txt
>

---

From: "Murtaza Chiba (mchiba)" <[email-masked]>
Date: Tue, 16 Mar 2010 13:46:05 -0700

Works for me as well.

-murtaza

-----Original Message-----
From: Al Morton [mailto:[email-masked]] 
Sent: Tuesday, March 16, 2010 7:16 AM
To: Brian E Carpenter;

Brian,

Al

---

From: Al Morton <[email-masked]>
Date: Wed, 17 Mar 2010 08:01:11 -0400

>such issues before someone in the IESG slaps a DISCUSS on it.)

Not at all, thanks for your careful review,
Al