Subject: [Gen-art] Gen-ART LC review of draft-ietf-yam-5321bis-smtp-pre-evaluation-05

From: "Roni Even" <[email-masked]>
Date: Mon, 17 May 2010 22:07:18 +0300

I have been selected as the General Area Review Team (Gen-ART) reviewer for
this draft

 (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please wait for direction from your document shepherd or AD before posting a
new version of the draft.

Document: draft-ietf-yam-5321bis-smtp-pre-evaluation-05

Reviewer: Roni Even

Review Date: 2010-05-17

IETF LC End Date: 

IESG Telechat date: (if known): 2010-05-20

Summary: This draft is not meant to be published. 

This memo is a Preliminary Evaluation of RFC5321, Simple Mail Transfer
Protocol (SMTP), for advancement from Draft Standard to Full Standard that
was written in order to facilitate discussion with the IESG.

In general it looks good, what I did not see is a summary of an analysis
that evaluate if all commands and tags are used in interoperable products

Roni Even

---

From: S Moonesamy <[email-masked]>
Date: Mon, 17 May 2010 12:53:18 -0700

Hi Roni,

Thank you for the review.

>Summary: This draft is not meant to be published.

All I-Ds from the YAM WG with a "pre-evaluation" tag are not meant 
for publication as a RFC.  It would be helpful to the YAM WG if 
future Gen-ART reviews also consider the Draft Standard that is being 
evaluated as part of the review.

>In general it looks good, what I did not see is a summary of an 
>analysis that evaluate if all commands and tags are used in 
>interoperable products

As an implementation report was previously filed for RFC 2821, there 
is no need for a summary of an analysis of the interoperability of 
the commands and tags.

Regards,
S. Moonesamy
YAM WG Secretary

---

From: John C Klensin <[email-masked]>
Date: Mon, 17 May 2010 16:53:24 -0400

--On Monday, May 17, 2010 22:07 +0300 Roni Even
<[email-masked]> wrote:

> I have been selected as the General Area Review Team (Gen-ART)
> reviewer for this draft
>...
 
>...

> This memo is a Preliminary Evaluation of RFC5321, Simple Mail
> Transfer Protocol (SMTP), for advancement from Draft Standard
> to Full Standard that was written in order to facilitate
> discussion with the IESG.
> 
> In general it looks good, what I did not see is a summary of
> an analysis that evaluate if all commands and tags are used in
> interoperable products

Roni,

I suggest a review of RFC 2026 (and perhaps the YAM WG Charter).
The analysis you are suggesting is a requirement for Draft
Standard.  Advancement to Draft Standard (the current level for
RFC 5321) constitutes community agreement that interoperability
requirements have been met.   There is no requirement to repeat
that review for a document proposed for Full Standard.

best,
   john

---

From: Dave CROCKER <[email-masked]>
Date: Mon, 17 May 2010 14:47:10 -0700

> that evaluate if all commands and tags are used in interoperable products

That's correct.  The working group has been diligent in restricting its work to 
the chartered scope, namely satisfying only requirements for full Internet Standard.

I believe your comment is, instead, applicable for Draft.  RFC 5321 satisifed 
that quite a long time ago, since it is already at Draft status.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: "Roni Even" <[email-masked]>
Date: Tue, 18 May 2010 09:37:18 +0300

Hi,
I am not the expert on the requirements and it will be up to the IESG. I
think that when you go to full standard you need to take out any commands
and tags that are not used by interoperable products. If that was done
previously than it is OK but I suggest that you mention it to the IESG.
Roni Even

> -----Original Message-----
> From: Dave CROCKER [mailto:[email-masked]]
> Sent: Tuesday, May 18, 2010 12:47 AM
> To: Roni Even
> Cc: 'General Area Review Team'; draft-ietf-yam-5321bis-smtp-pre-
> [email-masked]; [email-masked]
> Subject: Re: Gen-ART LC review of draft-ietf-yam-5321bis-smtp-pre-
> evaluation-05
> 
> 
> 
> analysis

---

From: Tony Hansen <[email-masked]>
Date: Tue, 18 May 2010 08:28:41 -0400

The IESG members I know are quite familiar with the requirements of 2026 
and are expecting a deployment analysis for going to full standard, but 
not a repeat of the interoperability analysis that was already done 
years ago.

     Tony Hansen
     YAM WG co-chair

On 5/18/2010 2:37 AM, Roni Even wrote:
>>> that evaluate if all commands and tags are used in interoperable
>>>        
>> products
>>
>>

---

From: "Roni Even" <[email-masked]>
Date: Tue, 18 May 2010 17:23:21 +0300

OK 
Thanks
Roni

> From: Tony Hansen [mailto:[email-masked]]
> Sent: Tuesday, May 18, 2010 3:29 PM
> To: Roni Even
> Cc: [email-masked]; 'General Area Review Team'; draft-ietf-yam-
> [email-masked]; [email-masked]
> >> That's correct.  The working group has been diligent in restricting
> its
> >> work to