Subject: [Gen-art] Gen-ART LC review of draft-ietf-opsec-protect-control-plane-04

From: "Roni Even" <[email-masked]>
Date: Sun, 28 Nov 2010 17:39:31 +0200

Hi,

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you
may receive.

Document: draft-ietf-opsec-protect-control-plane-04

Reviewer: Roni Even

Review Date: 2010-11-28

IETF LC End Date: 2010-12-3

IESG Telechat date: (if known)

Summary: This draft is ready for publication as an Informational RFC. There
are some nits and minor issue.

Major issues:

Minor issues: The example in appendix A are using syntax with no reference.
The text says that this is non normative text but I think that it will be
good to have a reference to the document where the correct syntax is
specified

Nits/editorial comments:

1.      The first sentence of section 1 "Modern router architecture design
maintains a strict separation of forwarding and routing control plane
hardware and software." Talks about routing control plane while the next
sentence and the rest of the document calls it "router control plane"

2.      In section 2 third paragraph "Additionally, there may be other
vendor or implementation specific protection mechanisms that are on by
default or always on. ". I suggest changing the text "are on" and "always
on" maybe to "active" or "turned on".

Thanks

Roni Even

---

From: Joel Jaeggli <[email-masked]>
Date: Sun, 28 Nov 2010 08:05:04 -0800

Active is fine, turned on And always on have different meanings however. 

I think we can fix appendix a with the appropriate informative reference as specified.

Joel's widget number 2

On Nov 28, 2010, at 7:39, "Roni Even" <[email-masked]> wrote:

> Hi,
> 
>  
> 
> I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> 
>  
> 
> Please resolve these comments along with any other Last Call comments you may receive.
> 
>  
> 
> Summary: This draft is ready for publication as an Informational RFC. There are some nits and minor issue.
> 
>  
> 
> Major issues:
> 
>  
> 
> Minor issues: The example in appendix A are using syntax with no reference. The text says that this is non normative text but I think that it will be good to have a reference to the document where the correct syntax is specified
> 
>  
> 
> Nits/editorial comments:
> 
>  
> 
> 1.      The first sentence of section 1 "Modern router architecture design maintains a strict separation of forwarding and routing control plane hardware and software." Talks about routing control plane while the next sentence and the rest of the document calls it "router control plane"
> 
> 2.      In section 2 third paragraph "Additionally, there may be other vendor or implementation specific protection mechanisms that are on by default or always on. ". I suggest changing the text "are on" and "always on" maybe to "active" or "turned on".
> 
>  
> 
> Thanks
> 
> Roni Even
> 
>  
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: "Roni Even" <[email-masked]>
Date: Sun, 28 Nov 2010 18:43:57 +0200

Rodney,
What I meant and I think Joel got it right is to add informative reference to the manuals/documents where you can see how to write policy similar to the ones in the appendix.
BTW: You can make all changes after the IETF LC is finished (December 3rd)

Roni

> -----Original Message-----
> From: Rodney Dunn [mailto:[email-masked]]
> Sent: Sunday, November 28, 2010 6:09 PM
> To: Joel Jaeggli
> Cc: Roni Even; General Area Review Team; IETF-Discussion list; draft-
> [email-masked]
> Subject: Re: Gen-ART LC review of draft-ietf-opsec-protect-control-
> plane-04
> 
> Joel,
> 
> I had responded offline to Roni to get clarification on the reference
> part. I wasn't clear as to what what the informative reference should
> be.
> 
> Here was my response:
> 
> "rd> The idea was that the text in the draft is normative but the
> configuration examples are not as they are many different ways for the
> configurations to be constructed to accomplish the same output. While
> some are more optimized from a number of lines perspective they didn't
> map clearly enough between the two examples or as clearly illustrate
> the
> example logic.
> 
> I'm not sure what you meant by "where the correct syntax is specified".
> The syntax used is correct just there are various ways it can be
> configured. Some actually come down to personal preference so there is
> no "correct" in the sense of implementation uniqueness."
> 
> Can you clarify it for me?
> 
> I updated the other two points and went with "active" on the second.
> 
> Thanks,
> Rodney
> 
> 
> 
> 
> On 11/28/10 11:05 AM, Joel Jaeggli wrote:
> > I think we can fix appendix a with the appropriate informative
> reference
> > as specified.
> >
> > Joel's widget number 2
> >
> > On Nov 28, 2010, at 7:39, "Roni Even" <[email-masked]
> > <mailto:[email-masked]>> wrote:
> >
> >> Hi,
> >>
> <<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>http://wiki.t
> ools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> >>
> >> Please resolve these comments along with any other Last Call
> comments
> >> you may receive.
> >>
> >> Summary: This draft is ready for publication as an Informational
> RFC.
> >> There are some nits and minor issue.
> >>
> >> Major issues:
> >>
> >> Minor issues: The example in appendix A are using syntax with no
> >> reference. The text says that this is non normative text but I think
> >> that it will be good to have a reference to the document where the
> >> correct syntax is specified
> >>
> >> Nits/editorial comments:
> >>
> >> 1.The first sentence of section 1 "Modern router architecture design
> >> hardware and software." Talks about routing control plane while the
> >> next sentence and the rest of the document calls it "router control
> plane"
> >>
> >> 2.In section 2 third paragraph "Additionally, there may be other
> >> default or always on. ". I suggest changing the text "are on" and
> >> "always on" maybe to "active" or "turned on".
> >>
> >> Thanks
> >>
> >> Roni Even
> >>
> >> [email-masked] <mailto:[email-masked]>

---

From: Rodney Dunn <[email-masked]>
Date: Sun, 28 Nov 2010 11:09:14 -0500

Joel,

I had responded offline to Roni to get clarification on the reference 
part. I wasn't clear as to what what the informative reference should be.

Here was my response:

map clearly enough between the two examples or as clearly illustrate the 
example logic.

Thanks,
Rodney

On 11/28/10 11:05 AM, Joel Jaeggli wrote:
>> <<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
>>
>> next sentence and the rest of the document calls it "router control plane"
>>

---

From: Rodney Dunn <[email-masked]>
Date: Sun, 28 Nov 2010 11:50:02 -0500

Got it. Thanks.

We (the authors) will talk it over and figure out the best location to 
reference to cover that and how.

Again, thanks for the review. Point noted on the LC date.

Rodney

On 11/28/10 11:43 AM, Roni Even wrote:
>>> On Nov 28, 2010, at 7:39, "Roni Even"<[email-masked]
>>>> [email-masked]<mailto:[email-masked]>