Subject: [Gen-art] Gen-ART review of draft-cdmi-mediatypes-02

From: <[email-masked]>
Date: Sun, 5 Dec 2010 22:42:08 -0500

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-cdmi-mediatypes-02
Reviewer: Kathleen Moriarty
Review Date: 5 December 2010
IETF LC End Date: 2010-12-09
IESG Telechat date: (if known)

Summary:  The document looks pretty good overall, but there are some edits that are recommended below.  The Acknowledgements section should get moved to a later section in the document.

Major issues:

Minor issues:
Section 5:
Recommend moving the Acknowledgements section to the end of the document.  The current placement makes it feel like the document is complete when sections like security are still later in the document.

Nits/editorial comments:

Section 1, sentence two:
Recommend adding a comma:
From:   As part of this interface the
To:     As part of this interface, the

Section 2, first sentence:
I don't think the word definitely is necessary as you are defining the storage cloud as being across a network.
From:   A storage cloud is a storage service hosted either on-premise or off-
   premise, definitely across a network.
To:     A storage cloud is a storage service hosted either on-premise or off-
   premise across a network.

Section 2, Second sentence:
Change "is" to "are" - referring to resources which are plural.
From:   An important part of the cloud
   model, in general, is the concept of a pool of resources that is
   drawn from, on demand, in small increments (smaller than what one
   would typically purchase by buying equipment).
To:     An important part of the cloud
   model, in general, is the concept of a pool of resources that are
   drawn from, on demand, in small increments (smaller than what one
   would typically purchase by buying equipment).

Section 2, third paragraph, second sentence:
Consider rewording this sentence, I am not sure what the second part of it is trying to convey.
" In addition, data system metadata can be set on containers and their
   contained data elements through this interface."

Section 3, first sentence:
Recommend changing From:
In this section we summarize the processing of each media type.
To: This section summarizes the processing of each media type.

second sentence:
From: In this document we provide only the essential information.
To: This document provides only the essential information.

Section 3.3
Add a period at the end of the last sentence.

Section 3.5
Add a period at the end of the last sentence.

Section 7
Add a period at the end of the last sentence.

Section 7.1
Add a period at the end of the last sentence.

Section 7.2
Add a period at the end of the last sentence.

Change the last sentence From:
These are described fully i section 16.1 of the CDMI specification
To: These are described fully in section 16.1 of the CDMI specification.

---

From: <[email-masked]>
Date: Mon, 6 Dec 2010 09:27:12 -0500

The document reads better now.  Thank you for the quick turn-around.  I would wait to post the new version until you receive some additional feedback.  It may come in over the next couple of days.  I did find one more nit:

Section 6.1 - Please add a space between the first and second sentence.

Best regards,
Kathleen

-----Original Message-----
From: Krishna Sankar (ksankar) [mailto:[email-masked]] 
Sent: Sunday, December 05, 2010 11:35 PM
To: Moriarty, Kathleen; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: Gen-ART review of draft-cdmi-mediatypes-02

Kathleen,
   Thanks for the thorough review. We haven't received any other Last
Call comments. Edited version attached. Let me know if this is OK and
then I will submit the RFC revision.

Cheers
<k/> 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Sunday, December 05, 2010 7:42 PM
To: [email-masked]; Krishna Sankar (ksankar); [email-masked]
Cc: [email-masked]
Subject: Gen-ART review of draft-cdmi-mediatypes-02

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Summary:  The document looks pretty good overall, but there are some
edits that are recommended below.  The Acknowledgements section should
get moved to a later section in the document.

Major issues:

Minor issues:
Section 5:
Recommend moving the Acknowledgements section to the end of the
document.  The current placement makes it feel like the document is
complete when sections like security are still later in the document.

Nits/editorial comments:

Section 1, sentence two:

Section 2, first sentence:
I don't think the word definitely is necessary as you are defining the
storage cloud as being across a network.
From:   A storage cloud is a storage service hosted either on-premise or
off-
   premise, definitely across a network.
To:     A storage cloud is a storage service hosted either on-premise or
off-
   premise across a network.

Section 2, third paragraph, second sentence:
Consider rewording this sentence, I am not sure what the second part of
it is trying to convey.
" In addition, data system metadata can be set on containers and their
   contained data elements through this interface."

second sentence:

Section 3.3

Section 3.5

Section 7

Section 7.1

Section 7.2

---

From: "Krishna Sankar (ksankar)" <[email-masked]>
Date: Sun, 5 Dec 2010 20:35:24 -0800

Kathleen,

Cheers
<k/> 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Sunday, December 05, 2010 7:42 PM
To: [email-masked]; Krishna Sankar (ksankar); [email-masked]
Cc: [email-masked]
Subject: Gen-ART review of draft-cdmi-mediatypes-02

Major issues:

Minor issues:
Section 5:

Nits/editorial comments:

Section 1, sentence two:

second sentence:

Section 3.3

Section 3.5

Section 7

Section 7.1

Section 7.2

---

From: "Krishna Sankar (ksankar)" <[email-masked]>
Date: Thu, 9 Dec 2010 16:10:49 -0800

Have made the changes and posted the new version
http://www.ietf.org/id/draft-cdmi-mediatypes-03.txt

Cheers
<k/>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, December 06, 2010 6:27 AM
To: Krishna Sankar (ksankar); [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: Gen-ART review of draft-cdmi-mediatypes-02

The document reads better now.  Thank you for the quick turn-around.  I
would wait to post the new version until you receive some additional
feedback.  It may come in over the next couple of days.  I did find one
more nit:

Best regards,
Kathleen

-----Original Message-----
From: Krishna Sankar (ksankar) [mailto:[email-masked]] 
Sent: Sunday, December 05, 2010 11:35 PM
To: Moriarty, Kathleen; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: Gen-ART review of draft-cdmi-mediatypes-02

Kathleen,

Cheers
<k/> 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Sunday, December 05, 2010 7:42 PM
To: [email-masked]; Krishna Sankar (ksankar); [email-masked]
Cc: [email-masked]
Subject: Gen-ART review of draft-cdmi-mediatypes-02

Major issues:

Minor issues:
Section 5:

Nits/editorial comments:

Section 1, sentence two:

second sentence:

Section 3.3

Section 3.5

Section 7

Section 7.1

Section 7.2