Subject: [Gen-art] GEN-Art review of draft-ietf-isis-layer2-09

From: <[email-masked]>
Date: Wed, 19 Jan 2011 12:24:12 -0500

I am the assigned Gen-ART reviewer for this draft. For background on

Gen-ART, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-ietf-isis-layer2-09

Reviewer: Kathleen Moriarty

Review Date: 19 January 2011

IETF LC End Date:

IESG Telechat date: (if known)

Summary:  The document looks pretty good overall, but there are some edits that are recommended below.

Major issues:

Minor issues:

Nits/editorial comments:

Abstract:

Include name for acronym TLV and IS-IS, both are used before being defined.

Include commas in the following sentence:

Change from: “in this document are generic layer 2 additions and specific ones as needed are”

To: “in this document are generic layer 2 additions and specific ones, as needed, are”

Section 1:

Paragraph 1, Line 5:

Change From: Layer

To: layer

Paragraph 2, Line 2:

Include acronym for PDU

Paragraph 2, Line 3:

Change from: “generic layer 2 additions and specific ones as needed are defined in”

To: “generic layer 2 additions and specific ones, as needed, are defined in”

Section 2:

Line 1:

Change from: “In this section we specify the enhancements”

To either: “This section specifies the enhancements”

Or: “In this section, we specify the enhancements”

Line 2:

Change from: “Layer-2”

To: “layer 2”

OR make the use of this consistent in the document.

Section 2.1:

Bullet 4:

Make use of “Layer-2-IS-IS” consistent in the document.

Paragraph 2:

Note use of Level 1 and Layer 2 in this paragraph to make consistent (dash/no dash, upper or lower case “L”)

Define acronym LSP in first line

Section 2.2:

Line 1:

Change from: “Multi Topology aware”

To: “Multi-Topology Aware”

Bullet 5 (acronym already defined, it can be completely spelled out or use the defined acronym):

Change From: “sub-TLVs: The MT aware Port Capabilities TLV”

To: “sub-TLVs: The MT-PORT_CAP TLV”

Last sentence: Include acronym for IIH.

---

From: Ayan Banerjee <[email-masked]>
Date: Thu, 27 Jan 2011 00:24:12 -0800

Kathleen,

Thanks much for your comments. I have incorporated them in the next revision
of the document. 

Thanks,
Ayan

On 1/19/11 9:24 AM, "[email-masked]" <[email-masked]>
wrote:

> Change from: ³in this document are generic layer 2 additions and specific ones
> as needed are²
> 
> To: ³in this document are generic layer 2 additions and specific ones, as
> needed, are²
> 
> 
> 
> Section 1:
> 
> Paragraph 1, Line 5:
> 
> Change From: Layer
> 
> To: layer
> 
> 
> 
> Paragraph 2, Line 2:
> 
> Include acronym for PDU
> 
> 
> 
> Paragraph 2, Line 3:
> 
> Change from: ³generic layer 2 additions and specific ones as needed are
> defined in²
> 
> To: ³generic layer 2 additions and specific ones, as needed, are defined in²
> 
> 
> 
> Section 2:
> 
> Line 1:
> 
> Change from: ³In this section we specify the enhancements²
> 
> To either: ³This section specifies the enhancements²
> 
> Or: ³In this section, we specify the enhancements²
> 
> 
> 
> Line 2:
> 
> Change from: ³Layer-2²
> 
> To: ³layer 2²
> 
> Make use of ³Layer-2-IS-IS² consistent in the document.
> 
> 
> 
> Paragraph 2:
> 
> Note use of Level 1 and Layer 2 in this paragraph to make consistent (dash/no
> dash, upper or lower case ³L²)
> 
> 
> 
> Change from: ³Multi Topology aware²
> 
> To: ³Multi-Topology Aware²
> 
> 
> 
> Change From: ³sub-TLVs: The MT aware Port Capabilities TLV²
> 
> To: ³sub-TLVs: The MT-PORT_CAP TLV²
> 
> 
>