Subject: Re: [Gen-art] Gen-ART LC review of draft-ietf-sipcore-keep-10

From: Christer Holmberg <[email-masked]>
Date: Sat, 1 Jan 2011 11:19:36 +0100

Hi Roni,

>Summary: This draft is almost ready for publication as a Standard track RFC.
>
>Major issues:
>
>
>Minor issues:
>
>1.  In the document you mention that the keep alive can be negotiated in each direction. I understand the dialog case, is this true 
>for the case of registration, if yes how is it done from the registrar. If not true maybe add some text in 4.2.2.

Good point. It is NOT true for the case of registration, when sending of keep-alives can only be negotiated from the registering party to the registrar.

I suggest adding the following text to the end of section 4.2.2:

"NOTE: Sending of keep-alives associated with a registration can only be negotiated in the direction from the registering SIP entity towards the registrar."

-----

>Nits/editorial comments:
>
>1.  In section 4.1 in the first note “If a SIP entity has indicated willingness to receive keep-alives from an adjacent SIP entity, 
>sending of keep-alives towards the same SIP entity needs to be separately negotiated”. 
>
>Who is the same SIP entity mentioned in the end of the sentence. I assume you meant “towards the adjacent SIP entity”.

(I assume you mean "Why" instead of "Who")

You are correct. I propose to change to:

"towards that adjacent SIP entity", to make sure that the text is referring to the entity that indicated willingness to send keep-alives, and not some other adjacent SIP entity.

----

>2.  In the first paragraph of 4.3 and 4.4 you use “must” should it be “MUST”

As far as I know it shall be "must" when referring to something defined in another specifiction.

----

>3.  In 4.3 in the third paragraph “it MUST start to send keep-alives” change to “it MUST start sending keep-alives”

I'll change as suggested.

----

>4.  In figure 2 in the 200 OK response to Alice the VIA is missing.

Correct.

I'll change "Alice: UAC;keep=30" to "Via: Alice;keep=30".

----

>5.  In section 7.4 third paragraph “ When Alice receives the response, she determines from her Via header 
>field that P1 is willing to receive keep-alives associated with the dialog.” Should be Bob and not P1.

Correct. 

I'll change as suggested.

----

Thanks for your comments!

Regards,

Christer

---

From: "Roni Even" <[email-masked]>
Date: Sun, 2 Jan 2011 00:30:58 +0200

Hi Christer,
I am OK with all your responses
regards
Roni

> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Saturday, January 01, 2011 12:20 PM
> To: Roni Even; [email-masked]; draft-ietf-sipcore-
> [email-masked]
> Cc: 'IETF-Discussion list'
> Subject: RE: Gen-ART LC review of draft-ietf-sipcore-keep-10
> 
> Hi Roni,
> 
> >1.  In the document you mention that the keep alive can be negotiated
> in each direction. I understand the dialog case, is this true
> >for the case of registration, if yes how is it done from the
> registrar. If not true maybe add some text in 4.2.2.
> 
> Good point. It is NOT true for the case of registration, when sending
> of keep-alives can only be negotiated from the registering party to the
> registrar.
> 
> "NOTE: Sending of keep-alives associated with a registration can only
> be negotiated in the direction from the registering SIP entity towards
> the registrar."
> 
> -----
> 
> >Nits/editorial comments:
> >
> >1.  In section 4.1 in the first note "If a SIP entity has indicated
> willingness to receive keep-alives from an adjacent SIP entity,
> >sending of keep-alives towards the same SIP entity needs to be
> separately negotiated".
> >
> >Who is the same SIP entity mentioned in the end of the sentence. I
> assume you meant "towards the adjacent SIP entity".
> 
> "towards that adjacent SIP entity", to make sure that the text is
> referring to the entity that indicated willingness to send keep-alives,
> and not some other adjacent SIP entity.
> 
> ----
> 
> >2.  In the first paragraph of 4.3 and 4.4 you use "must" should it be
> "MUST"
> 
> >3.  In 4.3 in the third paragraph "it MUST start to send keep-alives"
> change to "it MUST start sending keep-alives"
> 
> >5.  In section 7.4 third paragraph " When Alice receives the response,
> she determines from her Via header
> >field that P1 is willing to receive keep-alives associated with the
> dialog." Should be Bob and not P1.
> 
> Correct.
> 
> Christer=