Subject: [Gen-art] Gen-ART LC review of draft-herzog-static-ecdh-04.txt

From: Brian E Carpenter <[email-masked]>
Date: Mon, 07 Feb 2011 13:35:22 +1300

Please see attached review.

---

From: "Herzog, Jonathan - 0668 - MITLL" <[email-masked]>
Date: Thu, 17 Feb 2011 13:29:42 -0500

Before I incorporate these comments into the document, I thought I'd describe our proposed changes:

> Minor issues
> ------------
> 
>    [SEC1]     Brown, D., "Standards for Efficient Cryptography 1 (SEC
>               1)", Standards for Efficient Cryptography 1, May 2009.
> 
> This may be a well known reference for practitioners, but it doesn't seem
> to be a sufficient citation for a normative reference. Google can't even find
> it. If it is meant to be the same thing as reference [SEC1] in RFC 5480,
> please cite it in the same way; Google can find that one and the IESG has
> already accepted it as a normative reference.

Good call. I will change the reference to match that in RFC 5480:

 [SEC1]       Standards for Efficient Cryptography Group (SECG), "SEC
                     1: Elliptic Curve Cryptography", Version 2.0, May 2009.

> Nit
> ---
> 
>   == You're using the IETF Trust Provisions' Section 6.b License Notice from
>      12 Sep 2009 rather than the newer Notice from 28 Dec 2009.  (See
>      http://trustee.ietf.org/license-info/)
> 

I was advised to leave this alone, as the RFC editor would update the notice when it gets published.

Would these edits address your concerns?

Thanks.

--
Jonathan Herzog							voice:  (781) 981-2356
Technical Staff							fax:    (781) 981-7687
Cyber Systems and Technology Group		email:  [email-masked]
MIT Lincoln Laboratory               			www:    http://www.ll.mit.edu/CST/
244 Wood Street    
Lexington, MA 02420-9185

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 18 Feb 2011 08:41:56 +1300

Jonathan,

That looks fine. The boilerplate will certainly be updated during editing;
those of us who use the xml2rfc tool to generate drafts are accustomed
to the tool producing correct boilerplate automatically.

Regards
   Brian Carpenter

---

From: "Herzog, Jonathan - 0668 - MITLL" <[email-masked]>
Date: Wed, 23 Feb 2011 14:16:49 -0500

Okay, I have submitted an updated (corrected) version: draft-herzog-static-ecdh-05.txt

It requires manual posting, and so will appear on the IETF site in a day or two. In the meantime, I attach it to this email.

Yours are the only Last-Call comments I received on this draft (I think), and so I now believe all comments have been addressed.

Thanks.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 24 Feb 2011 09:14:56 +1300

Thanks Jonathan, so it is back in the hands of the document shepherd and AD.

Regards
   Brian