Subject: [Gen-art] Gen Art LC review of: draft-ietf-speermint-architecture-17

From: Avshalom Houri <[email-masked]>
Date: Wed, 2 Feb 2011 15:47:33 +0200

I have been selected as the General Area Review Team (Gen-ART) 
reviewer for this draft (for background on Gen-ART, please see 
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html). 

Please wait for direction from your document shepherd 
or AD before posting a new version of the draft. 

Document: draft-ietf-speermint-architecture-17
Reviewer: Avshalom Houri
Review Date: 2011-02-02
IESG last call date: 2011-02-03

Summary: The document is ready as an informational RFC

Major issues: None.

Minor issues: None.

Nits/editorial comments: 

Line 357:
   o  An SBE can contain a SF function.
->    o  An SBE can contain an SF function.

Line 421:
   Function (LUF) to determine a target address, and then is resolves
->    Function (LUF) to determine a target address, and then it resolves

Line 466:
   resolving these URIs to URIs for specific protocols such a SIP or
->    resolving these URIs to URIs for specific protocols such as SIP or

Line 485:
   particular order and, importantly, not all of them may be used.
->    particular order and, importantly, not all of them have to be used.

Line 537:
   SIP proxy.  Optionally, a SF may perform additional functions such as
->    SIP proxy.  Optionally, an SF may perform additional functions such 
as

Line 540:
   encryption.  The SF of a SBE can also process SDP payloads for media
->    encryption.  The SF of an SBE can also process SDP payloads for 
media

Line 582:
   The section defines uses of TLS between two SSPs [RFC5246] [RFC5746]
->    The section defines the usage of TLS between two SSPs [RFC5246] 
[RFC5746]

Thanks
Avshalom

---

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 3 Feb 2011 15:48:09 +0000

Avshalom - Thanks for performing a review of this document. All of the changes you have suggested will be made in a -18 update when I'm cleared to do so by my AD (Gonzalo). Please see my responses inline below to each specific item for the details, FYI.

Regards
Jason

On 2/2/11 8:47 AM, "Avshalom Houri" <[email-masked]<mailto:[email-masked]>> wrote:

Major issues: None.

Minor issues: None.

Nits/editorial comments:

Line 357:

[JL] Correction made exactly as you requested.

Line 421:

[JL] Correction made

Line 466:

[JL] Correction made

Line 485:

[JL] Change made

Line 537:
   SIP proxy.  Optionally, a SF may perform additional functions such as
->    SIP proxy.  Optionally, an SF may perform additional functions such as

[JL] Correction made

Line 540:
   encryption.  The SF of a SBE can also process SDP payloads for media
->    encryption.  The SF of an SBE can also process SDP payloads for media

[JL] Correction made

Line 582:
   The section defines uses of TLS between two SSPs [RFC5246] [RFC5746]
->    The section defines the usage of TLS between two SSPs [RFC5246] [RFC5746]

[JL] Correction made

Thanks
Avshalom