Subject: [Gen-art] Gen-ART Telechat Review of draft-bryan-metalinkhttp-21

From: Ben Campbell <[email-masked]>
Date: Tue, 1 Mar 2011 16:11:22 -0600

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document: draft-bryan-metalinkhttp-21
Reviewer: Ben Campbell
Review Date:  2011-03-01
IETF LC End Date:
IESG Telechat date: 2011-03-03

Summary: This draft is essentially ready for publication as a proposed standard. I have a couple of remaining comments that may be worth considering, but probably should not block the draft's progress.

Major issues:

None.

Minor issues:

-- I note that the draft still suggests that servers SHOULD share an eTag generation policy, but does not offer a baseline policy that servers either SHOULD or MUST implement. I still have a mild concern that implementations might have non-intersecting sets of policy options. On the other hand, I realize that coming up with (i.e. agreeing to) a baseline policy is not a trivial effort in itself, so I don't think this should block publication. I mention it merely for the sake of completeness.

Nits/editorial comments:

-- section 2, last paragraph "Metalink clients use the mirrors provided by a Metalink server in Link header fields [ RFC5988 ] but it is restricted to the initial Metalink server they contacted. "

s /"... it is restricted..." / "... this is restricted ..."

Also, is there a risk the initial server could cause a loop by pointing to _itself_?

---

From: Ben Campbell <[email-masked]>
Date: Tue, 15 Mar 2011 14:46:04 -0500

Document: draft-bryan-metalinkhttp-22
Reviewer: Ben Campbell
Review Date: 2011-03-15
IESG Telechat date: 2011-03-17

Summary: This draft is essentially ready for publication as a proposed standard. I have a couple of remaining minor comments that may be worth considering, but probably should not block the draft's progress

Note: This is a followup from my Telechat review of version 21 (see below), which mostly applies to version 22 except for on editorial fix, which I have ellided.

> s /"... it is restricted..." / "... this is restricted ..."

[...]

---

From: Anthony Bryan <[email-masked]>
Date: Tue, 15 Mar 2011 18:10:06 -0400

>> -- I note that the draft still suggests that servers SHOULD share an eTag generation policy, but does not offer a baseline policy that servers either SHOULD or MUST implement. I still have a mild…

thanks for mentioning it.

>> s /"... it is restricted..." / "... this is restricted ..."

fixed.

thanks, Ben!

-- 
(( Anthony Bryan ... Metalink [ http://www.metalinker.org ]
  )) Easier, More Reliable, Self Healing Downloads