Subject: [Gen-art] Gen-ART review of draft-ietf-adslmib-gbond-tdim-mib-07.txt

From: Suresh Krishnan <[email-masked]>
Date: Sun, 11 Mar 2012 17:31:21 -0400

I am the assigned Gen-ART reviewer for
draft-ietf-adslmib-gbond-tdim-mib-07.txt

For background on Gen-ART, please see the FAQ at
<http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html>.

Please resolve these comments along with any other Last Call comments
you may receive.

Summary: This draft is almost ready for publication as a Proposed
Standard. I do have a potential concern that you may like to address.

Minor
=====

* Section 6: MIB definition

The index field 'gBondTdimOperSvcPosition' of 'gBondTdimOperSvcEntry' is
defined to have a MAX-ACCESS of 'read-only'. I believe that it should
instead be defined with a MAX-ACCESS of 'not-accessible' since it is an
index field.

Thanks
Suresh

---

From: Moti Morgenstern <[email-masked]>
Date: Mon, 12 Mar 2012 08:32:07 +0000

Hi Suresh,

We use the 'gBondTdimOperSvcPosition' not only as an index into a table but also report that field as part of a notification message. I believe that having MAX-ACCESS of 'not-accessible' would be problematic.
Just as a reminder, the only index into the famous interfaces table (RFC 2863) is ifIndex and its MAX-ACCESS is also 'read-only'.  Again, it might be because ifIndex appears also in notification messages (such as linkup and linkDown)

Best Regards,
Moti
-----Original Message-----
From: Suresh Krishnan [mailto:[email-masked]] 
Sent: Sunday, March 11, 2012 11:31 PM
To: General Area Review Team; [email-masked]
Subject: Gen-ART review of draft-ietf-adslmib-gbond-tdim-mib-07.txt

For background on Gen-ART, please see the FAQ at <http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html>.

Please resolve these comments along with any other Last Call comments you may receive.

Summary: This draft is almost ready for publication as a Proposed Standard. I do have a potential concern that you may like to address.

Minor
=====

The index field 'gBondTdimOperSvcPosition' of 'gBondTdimOperSvcEntry' is defined to have a MAX-ACCESS of 'read-only'. I believe that it should instead be defined with a MAX-ACCESS of 'not-accessible' since it is an index field.

Thanks
Suresh

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.