Subject: [Gen-art] Gen-ART LC Review of draft-ietf-krb-wg-des-die-die-die-04

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Apr 2012 21:11:00 +0200

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you may receive.

Document:                draft-ietf-krb-wg-des-die-die-die-04.txt

Reviewer:                 Christer Holmberg

Review Date:            2012-04-03

IETF LC End Date:    2012-04-08

IESG Telechat date: (if known) -

Summary:           The draft is ready for publication, with an editorial issue.

Major issues:     -

Minor issues:     -

Nits/editorial comments:

- Section 5, which updates the affected RFCs, is named 'Recommendations'. Would it be better to use 'Updates to RFC XXXX' naming instead, and have a separate section for each RFC updated?

Regards,

Christer

---

From: Tom Yu <[email-masked]>
Date: Thu, 05 Apr 2012 10:46:08 -0400

> - Section 5, which updates the affected RFCs, is named 'Recommendations'. Would it be better to use 'Updates to RFC XXXX' naming instead, and have a separate section for each RFC updated?

The paragraphs in Section 5 are roughly grouped by the type of
algorithm they refer to, which seems logical to me.  Do you believe
that other readers would prefer that the updates be grouped by the
affected RFC?

I should be able to rearrange the contents of Section 5 with
subsection headings of "Updates to RFC XXXX" with minimal textual
changes.  Section 5 might also be better titled "Actions" or "Updates
to specifications".  What do you think?

---

From: Sam Hartman <[email-masked]>
Date: Thu, 05 Apr 2012 11:01:21 -0400

My peresonal preference is to retain Recommendations as the title to
section 5.
I have no opinion on whether adding subsections would be a good idea or
not.
It's probably not worth spinning a new draft for that but if people
believe it desirable it's fine to fold in with other changes in my
opinion.
Obviously, wait for direction from our AD.

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 6 Apr 2012 00:17:14 +0200

Hi,

I think it's good to have separate (sub-)sections per RFC. Also, if some specific section of an RFC is updated, it is sometimes good to mention, depending on how difficult it will be for a reader to "map" the updates into the RFCs.

Things may be obvious to people who have worked with the RFCs, and know them by heart, but we have to think about the first-time readers/implementors :)

Also, I think "Recommendations" sounds confusing. The "recommend" wording normally has another meaning in RFCs. And, you are not recommending anything - you are specifying.

Regards,

Christer

________________________________________
From: Sam Hartman [[email-masked]]
Sent: Thursday, April 05, 2012 6:01 PM
To: Tom Yu
Cc: Christer Holmberg; [email-masked]; [email-masked]
Subject: Re: Gen-ART LC Review of draft-ietf-krb-wg-des-die-die-die-04