Subject: [Gen-art] Gen-Art review of draft-ietf-appsawg-greylisting

From: <[email-masked]>
Date: Mon, 23 Apr 2012 12:59:10 -0400

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document: draft-ietf-appsawg-greylisting
Reviewer: Kathleen Moriarty
Review Date: 23 April
IETF LC End Date:
IESG Telechat date: (if known)

Summary:  Ready with nits.
This memo describes the art of email greylisting, the practice of
   providing temporarily degraded service to unknown email clients as an
   anti-abuse mechanism.

Major issues:

Minor issues:

Nits/editorial comments:
Introduction: First sentence:  The word 'differential' should be 'different' unless you change the sentence structure.  It could be that there is a differential between services.
Second sentence:  Change provider to providing
Change from: "In some cases an actor does not have a known reputation; this can justify providing degraded service, until there is a basis for provider better service."
To: "In some cases an actor does not have a known reputation;
   this can justify providing degraded service, until there is a basis
   for providing better service."

Section 2.1: The double dashes should be parentheses instead -- -- replaced by ()
Section 3, third paragraph, last sentence: add a comma:
From: To the greylisting
   implementation such clients are once again unknown, and they will
   once again be subjected to the delay.
To: To the greylisting
   Implementation, such clients are once again unknown, and they will
   once again be subjected to the delay.

Section 3, fourth paragraph, second sentence: remove the comma:
From: It has to be
   large enough to keep the necessary history, and fast enough to avoid
   excessive inefficiencies in the server's operations.
To: It has to be
   large enough to keep the necessary history and fast enough to avoid
   excessive inefficiencies in the server's operations.

Section 3, fifth paragraph, second to last sentence: remove "the," and "such"
From: Experience suggests that
   the, the vast majority of mail comes from places on such a developed
   exception list, so after a training period, only a small proportion
   of mail is actually affected.
To: Experience suggests that
   the vast majority of mail comes from places on a developed
   exception list, so after a training period, only a small proportion
   of mail is actually affected.

Section 4.1: second to last paragraph: remove unnecessary comma:
From: Other side effects include out-of-order delivery of related,
   sequenced messages.
To: Other side effects include out-of-order delivery of related
   sequenced messages.

Section 4.2: Second paragraph:  The commas can be removed as only two items are joined in the list.  When you have three or more, a comma is used.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 24 Apr 2012 22:27:58 +0000

Hi Kathleen, thanks for the review.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, April 23, 2012 9:59 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: Murray S. Kucherawy; [email-masked]
> Subject: Gen-Art review of draft-ietf-appsawg-greylisting
> 
> Gen-ART, please see the FAQ at <
> http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> 
> Please wait for direction from your document shepherd or AD before
> posting a new version of the draft.
> [...]
> Nits/editorial comments:
> Introduction: First sentence:  The word 'differential' should be
> 'different' unless you change the sentence structure.  It could be that
> there is a differential between services.

"different qualities of service" is more like what we want here, because it's the same service really.

> Second sentence:  Change provider to providing

Fixed.

> Section 2.1: The double dashes should be parentheses instead -- --

Done.

>    once again be subjected to the delay.

Done.

>    excessive inefficiencies in the server's operations.

Done.

>    of mail is actually affected.

Done.

> To: Other side effects include out-of-order delivery of related

OK.

> Section 4.2: Second paragraph:  The commas can be removed as only two
> items are joined in the list.  When you have three or more, a comma is
> used.

Done.

-MSK