Subject: [Gen-art] Gen-Art review of draft-ietf-netext-access-network-option-10.txt

From: Alexey Melnikov <[email-masked]>
Date: Sat, 5 May 2012 18:58:51 +0100

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-netext-access-network-option-10.txt
Reviewer: Alexey Melnikov
Review Date: 5 May 2012
IETF LC End Date: 9 May 2012
IESG Telechat date: Unknown

Summary: This draft is ready as a Proposed Standard

Major issues: none

Minor issues:

Minor: [ANI] and [TS23003] seem to be Normative (as per their use in 3.1.1)

Nits/editorials:

1.  Introduction

   This document defines a new mobility option, the Access Network
   Identifier (ANI) option and its sub-options for Proxy Mobile IPv6,
   that can be used by the mobile access gateway to signal the access
   network information to the local mobility anchor.  The specific
   details on how the local mobility anchor uses this information are
   out-of-scope for this document.  These mobility options are optional
   and are not mandatory for the Proxy Mobile IPv6 protocol.

Nit: Last sentence: "optional" and "not mandatory" are the same thing on my book.

Strictly speaking PEN numbers are not limited to 4 bytes. However you have a registry for types of identifiers, so a new value can be allocated for bigger-than-4-bytes PENs.

---

From: jouni korhonen <[email-masked]>
Date: Sun, 6 May 2012 22:58:52 +0300

Alexey,

Thanks for the review. See some initial comments inline.

> Minor: [ANI] and [TS23003] seem to be Normative (as per their use in 3.1.1)

If it is OK from the RFC process point of view, we can put these
non-IETF references into the normative section.

> Nit: Last sentence: "optional" and "not mandatory" are the same thing on my book.

Proposal for new text:

   "These mobility options are optional for the Proxy Mobile IPv6 protocol."

> Strictly speaking PEN numbers are not limited to 4 bytes. However you have a registry for types of identifiers, so a new value can be allocated for bigger-than-4-bytes PENs.

Right. So we could just remove the 4 octet length requirement and use a 
"natural" length indicated octet coding for the PENs. For example

ANI Length = 1 -> PENs 0-255
ANI Length = 2 -> PENs 0-65535
ANI Length = 3 -> PENs 0-16777216
...

That would be ok?

- Jouni

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 07 May 2012 10:41:12 +0100

> Alexey,
Hi Jouni,
> non-IETF references into the normative section.
I think that is fine in general. You should double check with the 
responsible AD whether the references are stable (as otherwise they 
might not be suitable for referencing normatively).
>     "These mobility options are optional for the Proxy Mobile IPv6 protocol."
Perfect :-).
> ANI Length = 3 ->  PENs 0-16777216
That would work, as long as the extra complexity (which is marginal in 
this case) is Ok with the WG.