Subject: [Gen-art] Gen-art review of draft-gont-intarea-obsolete-eid-option-01

From: "Moriarty, Kathleen" <[email-masked]>
Date: Thu, 25 Oct 2012 16:36:01 -0400

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document:  draft-gont-intarea-obsolete-eid-option-01
Reviewer: Kathleen Moriarty
Review Date: 10/25/12
IETF LC End Date: 11/1/12
IESG Telechat date: (if known)

Summary:  The document needs a few small revisions.
This document formally deprecates the IPv6 Endpoint Identification (EID) option (hex value 0x8a).

Major issues:

Minor issues:
RFC2119 is referenced, but not used.  I don't see the use of any RFC2119 language in the document, so it may be safe to remove this reference.

I don't think the reference for EID option is valid.  I also looked at the reference in the IANA page and that no longer contains a link.  From a google search, it looks like this was an internet draft that was never published as an RFC and expired, http://ana-3.lcs.mit.edu/~jnc/nimrod/eidoption.txt
Listing it as "A work in progress" when it is an expired draft s not appropriate.

Nits/editorial comments:

I recommend changing the following portion of the abstract to state what is accomplished in this draft as the language is a little confusing:
"possibly serving as a basis for providing advice"
Since this draft doesn't actually provide the advice, just says it may provide a basis for providing the advice, I would recommend leaving this out of the abstract.

Recommend removing "e.g." fromt he last sentence int he Security Considerations section as it is not needed.
Change from:
"However, formally deprecating this option
   may serve as a basis for e.g. providing advice about filtering
   packets containing such option (in a similar way to
   [I-D.ietf-opsec-ip-options-filtering] for the IPv4 case)."
TO:
"However, formally deprecating this option
   may serve as a basis for providing advice about filtering
   packets containing such option (in a similar way to
   [I-D.ietf-opsec-ip-options-filtering] for the IPv4 case)."

Thank you,
Kathleen

---

From: Ronald Bonica <[email-masked]>
Date: Fri, 26 Oct 2012 13:46:27 +0000

Thanks for these comments. They have all been addressed by means of an RFC editor note.

                                             Ron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Moriarty, Kathleen
> Sent: Thursday, October 25, 2012 4:36 PM
> To: [email-masked]; draft-gont-intarea-obsolete-eid-
> [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Gen-art review of draft-gont-intarea-obsolete-eid-option-01
> 
> Gen-ART, please see the FAQ at <
> http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> 
> Please wait for direction from your document shepherd or AD before
> posting a new version of the draft.
> 
> RFC2119 is referenced, but not used.  I don't see the use of any
> RFC2119 language in the document, so it may be safe to remove this
> reference.
> 
> I don't think the reference for EID option is valid.  I also looked at
> the reference in the IANA page and that no longer contains a link.
> From a google search, it looks like this was an internet draft that was
> never published as an RFC and expired, http://ana-
> 3.lcs.mit.edu/~jnc/nimrod/eidoption.txt
> I recommend changing the following portion of the abstract to state
> what is accomplished in this draft as the language is a little
> confusing:
> Since this draft doesn't actually provide the advice, just says it may
> provide a basis for providing the advice, I would recommend leaving
> this out of the abstract.
> 
> Recommend removing "e.g." fromt he last sentence int he Security
> Considerations section as it is not needed.
> Change from: