Subject: [Gen-art] Gen-ART Telechat Review of draft-ietf-mptcp-api-06

From: Ben Campbell <[email-masked]>
Date: Mon, 12 Nov 2012 15:48:11 -0600

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document: draft-ietf-mptcp-api-06
Reviewer: Ben Campbell	
Review Date: 2012-11-12
IESG Telechat date: 2012-11-15

Summary: This draft is basically ready for publication as an informational RFC. All of the comments from my Gen-ART review of version 05 at IETF last call have been dealt with to my satisfaction in the draft or in email, save the one minor issue below.

Major issues:

Minor issues:

I made the following comment at last call. It's not a show stopper, but I think it should be considered:

> -- It seems like at least passing knowledge of the sockets API is needed to understand this document. I'm curious why the POSIX reference is informational rather than normative?

The authors indicated they believed the reference at the end of paragraph 3 of section 1 to be truly informational. However, I called out an mention at the beginning of the same paragraph that should have included a citation, and that I thought that citation would justify a normative reference. The authors added the citation in version 06, but the reference is still informational.

Nits/editorial comments:

IDNits reports that "A later version (-12) exists of
     draft-ietf-mptcp-multiaddressed-09"

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Sun, 25 Nov 2012 22:04:04 +0100

Ben,

That minor issue can easily be fixed. Actually, I don't have a strong opinion on the status on that reference. In fact, I understood from your last e-mail that informational status for that reference would be OK. After re-reading that e-mail, I realize that I just misunderstood your statement therein. We'll change that.

Thanks

Michael

________________________________________
Von: [email-masked] [[email-masked]] im Auftrag von Ben Campbell [[email-masked]]
Gesendet: Montag, 12. November 2012 22:48
An: <[email-masked]>
Cc: [email-masked] Review Team; [email-masked] List
Betreff: Gen-ART Telechat Review of draft-ietf-mptcp-api-06

Major issues:

Minor issues:

Nits/editorial comments: