Subject: [Gen-art] GenART review of draft-schaad-pkix-rfc2875-bis-03

From: Martin Thomson <[email-masked]>
Date: Thu, 6 Dec 2012 17:02:50 -0800

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: raft-schaad-pkix-rfc2875-bis-03
Reviewer: Martin Thomson
Review Date: 2012-12-06
IETF LC End Date: Aaaages
IESG Telechat date: (if known)

Summary: Looks good to me.  Ship it.

Nits/editorial comments:

Section 3 does not establish a notation convention for multiplication.
 I didn't find a specific place that this was a problem, but it seemed
appropriate since multiplications was, in some places denoted 'n*b'
and others as 'xy', even though multi-character identifiers are used
in many places.  This does imply that a precedence override is
necessary.  I suggest parentheses, since they are already used
extensively.

Section 3: s/MAC funtion/MAC functions/

Section 5: could use a more rigorous list construction, the
definitions all run together

Needs more ASN.1

--Martin

---

From: "Jim Schaad" <[email-masked]>
Date: Fri, 7 Dec 2012 00:25:57 -0800

> -----Original Message-----
> From: Martin Thomson [mailto:[email-masked]]
> Sent: Thursday, December 06, 2012 5:03 PM
> To: [email-masked]; [email-masked]
> Subject: GenART review of draft-schaad-pkix-rfc2875-bis-03
> 
> I am the assigned Gen-ART reviewer for this draft. For background on Gen-
> ART, please see the FAQ at
> 
> Please resolve these comments along with any other Last Call comments you
> may receive.
> 
> and others as 'xy', even though multi-character identifiers are used in many
> places.  This does imply that a precedence override is necessary.  I suggest
> parentheses, since they are already used extensively.

Yes - this one hit me after I published the last version.

> Section 5: could use a more rigorous list construction, the definitions all run
> together

This is harder to do with the tools, but will be address with the RFC Editor

> Needs more ASN.1

I'm lost with this, what do you believe needs to be added?  The ASN.1 as it stands is complete.

Jim

---

From: Martin Thomson <[email-masked]>
Date: Fri, 7 Dec 2012 10:28:25 -0800

> I'm lost with this, what do you believe needs to be added?  The ASN.1 as it stands is complete.

'twas in jest.  Don't worry about it.  I didn't see any errors, but
I'm not a very good ASN.1 parser.