Subject: [Gen-art] Gen-art review of draft-ietf-bliss-call-completion-18

From: "Moriarty, Kathleen" <[email-masked]>
Date: Fri, 4 Jan 2013 18:53:21 -0500

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document: draft-ietf-bliss-call-completion-18
Reviewer: Kathleen Moriarty
Review Date: 1/4/13
IETF LC End Date: a while ago
IESG Telechat date: 1/10/13

Summary: The draft is very well written and ready for publication.  I listed a couple of nits and a possible consideration to add to the security section on privacy/safety.

Major issues:

Minor issues:

Nits/editorial comments:

Section 3, the definition for CCE is the only one that does not end with a period, consider adding one.

Security Section, start of second paragraph on page 30 (DoD should be DoS):
Change from: "In order to prevent DoD attacks"
To: "In order to prevent DoS attacks"

In the Security Section, there is mention of privacy issues only in relation to violations of the expected behavior listed in that section.  I think it would be helpful to describe some of the possible privacy issues and why you may or may not want to put in protections in place as safety could be affected.  For instance, if the options in RFC3261 were used to prevent a subscription (white list of allowed callers), you may not receive a robo call with emergency messages from your town, school, etc.  On the other hand, you may want to prevent others from being subscribers to know when you are at home (too hard to do with a black list and a white list could block other important calls).  Or this is just plain tricky...

---

From: <[email-masked]>
Date: Fri, 11 Jan 2013 11:59:00 +0100

Hi Kathleen,

thanks for checking.

Privacy issues are indeed a littlebit tricky with call completion, if you offer this service you have to take into account some privacy restrictions. People will notice you are at your phone, when they have information of the location of your phone they might be able to locate you. White- and blacklists would be an appropriate mean to not spread this information too widely. We will try to give some more example use cases in the draft.

Thanks.

Regards, Martin

________________________________
Von: Moriarty, Kathleen [mailto:[email-masked]]
Gesendet: Samstag, 5. Januar 2013 00:53
An: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: Hülsemann, Martin; [email-masked]
Betreff: Gen-art review of draft-ietf-bliss-call-completion-18

Major issues:

Minor issues:

Nits/editorial comments: