Subject: Re: [Gen-art] Gen-ART review of draft-ietf-6man-udpchecksums-06

From: Magnus Westerlund <[email-masked]>
Date: Thu, 17 Jan 2013 11:59:09 +0100

Hi Peter,

Thanks for your detailed review. An updated version has just been
submitted the includes fixes to your comments.

Thanks

Magnus

On 2012-12-26 12:05, Peter Yee wrote:
> I am the assigned Gen-ART reviewer for this draft. For background on
> Gen-ART, please see the FAQ at
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>
> 
> Please wait for direction from your document shepherd or AD before posting a
> new version of the draft.
> 
> Document: draft-ietf-6man-udpchecksums-06
> Reviewer: Peter Yee
> Review Date: Dec-25-2012
> IETF LC End Date: Dec-25-2012
> IESG Telechat date: Unknown
> 
> Summary: This draft is basically ready for publication, but has nits that
> should be fixed before publication. [Ready with nits.]
> 
> This document provides an update to 2460 to allow the use of zero checksum
> UDP packets over IPv6 in certain
> cases involving protocols tunneled inside of UDP packets.
> 
> Nits:
> 
> General: a comma after "i.e." is preferred in American English.
> 
> General: it is not necessary to hyphenate "misdelivered" or "misdelivery".
> 
> General: put quotes around "Applicability Statement for the use of IPv6 UDP
> Datagrams with Zero  Checksums"
> 
> Abstract, first sentence: "when" -> "where"
> 
> Abstract, second sentence: "protocol" -> "protocols"
> 
> Section 1, second paragraph, first sentence: delete the comma after
> "packet".
> 
> Section 1, fourth paragraph, first sentence: move the comma in "AMT," to
> after the reference.
> 
> Section 1, fourth paragraph, last sentence: insert "the" after "applicable
> in".
> 
> Section 3, second sentence: delete the first occurrence of "where".
> Consider revising the sentence for clarity.
> 
> Section 4, second sentence: "Section" -> "Sections"
> 
> Section 4.1, it would be nice, but not necessary to have an enumeration of
> the corruption modes.  
> 
> Section 4.1, third bullet item, first sentence: a verb is missing here
> making the sentence difficult to parse.
> 
> Section 4.1, third bullet item, first sentence: "packets" -> "packet"
> 
> Section 4.1, third bullet item, third sub-bullet: put commas around "for
> example".
> 
> Section 4.2, first bullet item, last sentence: this sentence is hard to
> understand; consider revising.  (See next comment)
> 
> Section 4.2, first bullet item, last sentence: "an" -> "a" and "are" ->
> "is"; also not general comment about "misdelivered".
> 
> Section 4.2, third bullet item, third sentence: "effect" -> "affect"
> 
> Section 4.2, first paragraph after bullet items, first sentence: delete
> "this".
> 
> Section 4.2, first paragraph after bullet items, third sentence:
> "mis-delievery" -> "misdelivery".
> 
> Section 4.2, first paragraph after bullet items, third sentence: delete
> "that".
> 
> Section 4.3, first sentence: "middlebox devices" -> "middleboxes" unless
> this a specific usage from I-D.ietf-6man-udpzero.
> 
> Section 4.3, second sentence: "needs" -> "need"
> 
> Section 5, first paragraph, second sentence: insert "in" after "node
> requirements".
> 
> Section 5, first paragraph of replacement text, second sentence: delete
> "usage for", replace "some" with "certain", and replace second "protocols"
> with "those".
> 
> Section 5, last paragraph: delete first instance of "the".
> 
> Section 6, first bullet item, first sentence: "corruptions" -> "corruption"
> 
> Section 6, second bullet item, last sentence: change "This" to "UDP-Lite".
> 
> Section 8, first sentence: delete redundant "required".
> 
> 

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Peter Yee" <[email-masked]>
Date: Tue, 22 Jan 2013 23:10:23 -0800

Magnus,

	Looks good to me.  My summary is now "Ready for publication".

		Kind regards,
		-Peter

-----Original Message-----
From: Magnus Westerlund [mailto:[email-masked]] 
Sent: Thursday, January 17, 2013 2:59 AM
To: Peter Yee
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: Re: Gen-ART review of draft-ietf-6man-udpchecksums-06

Hi Peter,

Thanks for your detailed review. An updated version has just been submitted
the includes fixes to your comments.

Thanks

Magnus

On 2012-12-26 12:05, Peter Yee wrote:
> Please wait for direction from your document shepherd or AD before 
> posting a new version of the draft.
> 
> Summary: This draft is basically ready for publication, but has nits 
> that should be fixed before publication. [Ready with nits.]
> 
> This document provides an update to 2460 to allow the use of zero 
> checksum UDP packets over IPv6 in certain cases involving protocols 
> tunneled inside of UDP packets.
> 
> Nits:
> 
> General: put quotes around "Applicability Statement for the use of 
> IPv6 UDP Datagrams with Zero  Checksums"
> 
> Section 1, fourth paragraph, first sentence: move the comma in "AMT," 
> to after the reference.
> 
> Section 1, fourth paragraph, last sentence: insert "the" after 
> "applicable in".
> 
> Section 4.1, it would be nice, but not necessary to have an 
> enumeration of the corruption modes.
> 
> Section 4.1, third bullet item, third sub-bullet: put commas around 
> "for example".
> 
> Section 4.2, first bullet item, last sentence: this sentence is hard 
> to understand; consider revising.  (See next comment)
> 
> Section 4.2, first bullet item, last sentence: "an" -> "a" and "are" 
> -> "is"; also not general comment about "misdelivered".
> 
> Section 4.2, first paragraph after bullet items, first sentence: 
> delete "this".
> 
> delete "that".
> Section 4.3, first sentence: "middlebox devices" -> "middleboxes" 
> unless this a specific usage from I-D.ietf-6man-udpzero.
> 
> Section 5, first paragraph of replacement text, second sentence: 
> delete "usage for", replace "some" with "certain", and replace second
"protocols"

-- 

Magnus Westerlund