Subject: [Gen-art] Gen-ART Telechat Review of draft-ietf-roll-p2p-measurement-09

From: Pete McCann <[email-masked]>
Date: Tue, 5 Feb 2013 21:03:49 -0500

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document:  draft-ietf-roll-p2p-measurement-09
Reviewer:    Pete McCann
Review Date:  2012-02-05
IETF LC End Date:
IESG Telechat date: 2012-02-07

Summary:  Ready with nits

Major issues: None

Minor issues:

Section 5:
   An Intermediate Point MUST discard the packet with no further
   processing if the received MO is not a Measurement Request (i.e., T =
   0).
It wasn't clear to me at first why the Intermediate Points are not supposed
to see the Measurement Replies.  I gather this is because the RPL control
message used to send the reply uses a global or unique-local address
instead of a link-local address.  It may be worthwhile calling this
out explicitly
in Section 2 when you describe the two new RPL Control Messages.

Really, the Replies do pass through Intermediate Points but they are not
processed because they are not addressed to the Intermediate Point.  Right?

Nits/editorial comments:

Section 1:
   situations, where
SHOULD BE:
   situations where

Section 5.3:
   and the route accumulation in on
SHOULD BE:
  and the route accumulation is on

---

From: Mukul Goyal <[email-masked]>
Date: Tue, 5 Feb 2013 21:32:58 -0600 (CST)

Hi Pete

Please see my response inline.

[PM]

Summary:  Ready with nits

Major issues: None

Minor issues:

Section 5:

[MG]
So there are two different questions really:

Q1: Why the Intermediate Points are not supposed to see the Measurement Replies?
Ans to Q1:
The Measurement Reply is _unicast_ to the Start Point. So, the routers on the Measurement Reply's path treat it just as another data packet. The RPL code running on these routers never sees the Measurement Reply. So, if the RPL code on a router does see a Measurement Reply and this router is not listed as the Start Point inside the message, the router MUST discard the received message.

Q2: Would the Measurement Reply pass through the Intermediate Points (at any layer)?
Ans to Q2:
Let's first be clear about what an Intermediate Point is. The Intermediate Points are the routers on the route being measured excluding the Start Point and the End Point. Now, Section 6.1 clearly identifies the situations where the Measurement Reply _may_ travel back to the Start Point using the reverse of the measured route. So, it is possible that the Measurement Reply travels along the reverse of the measured path and, in this case, the Measurement Reply does pass through all the Intermediate Points. However, the End Point may decide to send the Measurement Reply along a different route (different than the measured route). In that case, the Measurement Reply may not pass through the Intermediate Points.

Hopefully this clarifies things. If you still think that the text needs to change, please let me know.

[PM]
Nits/editorial comments:

Section 1:
   situations, where
SHOULD BE:
   situations where

Section 5.3:

[MG]
Thanks. I will make these changes in the final document.

Thanks
Mukul