Subject: Re: [Gen-art] GenART LC review of draft-merkle-ikev2-ke-brainpool-03

From: Johannes Merkle <[email-masked]>
Date: Tue, 02 Apr 2013 15:22:17 +0200

Hi,

> 1.       In table 1 the Transform ID are specified as TBD1 to TBD4. I noticed that IANA have already assigned values
> 27-30. So they should be specified. If not it will be good to ask the RFC editor before publication to update the table.
> I saw that you only asked IANA to allocate values.

I'll do so in the next version if it is not done by the RFC editor.

> 
> 2.       In the IANA section I did not understand to which table you are referring to “For the new entries in the table
> of the Transform Type 4 repository, a reference to Section 2.3 of [IKE_DH_Req] shall be included in the column named
> "Recipient Tests” indicating the required checks for the other peer's Diffie-Hellman public keys.”
> 
This refers to the Table Transform Type 4 - Diffie-Hellman Group Transform IDs, see
http://www.iana.org/assignments/ikev2-parameters/ikev2-parameters.xml#ikev2-parameters-8

[IKE_DH_Req] requests from IANA to add a new column (named "Recipient Tests") to that Table. We request IANA to add in
that new column a a reference to Section 2.3 of [IKE_DH_Req].

This request has been correctly understood by IANA, see email below.

Best regards,
Johannes

Subject: [IANA #662036] Last Call: <draft-merkle-ikev2-ke-brainpool-03.txt> (Using the ECC Brainpool Curves for IKEv2 Key Exchange) to Informational RFC
From: "Pearl Liang via RT" <[email-masked]>
Cc: [email-masked], [email-masked], [email-masked]
Date: Tue, 26 Mar 2013 15:24:33 +0000
List-Id: <[email-masked]>

(BEGIN IANA LAST CALL COMMENTS)

IESG/Authors/WG Chairs:

IANA has reviewed draft-merkle-ikev2-ke-brainpool-03.  Authors should review the comments and/or questions below.  Please report any inaccuracies and respond to any questions as soon as possible.

We understand that there is a single action required to be completed 
upon approval of this document.  

We understand that the following four new Transform IDs have been 
added to the "Transform Type 4 - Diffie-Hellman Group Transform IDs" 
subregistry upon the completion of ticket 666056:

URL: www.iana.org/assignments/ikev2-parameters

Note (from the designed expert done earlier):

Note, that this draft also requires that the actions from the
draft-ietf-ipsecme-dh-checks is also done.  The
draft-ietf-ipsecme-dh-checks adds the Recipient Tests column to
"Transform Type 4 - Diffie-Hellman Group Transform IDs" registry, and
this draft-merkle-ikev2-ke-brainpool also fills that column.

IANA understands that these are the only actions requested by this 
document.

Thanks,

Pearl Liang
ICANN/IANA

(END IANA LAST CALL COMMENTS)

On Tue Feb 26 16:06:45 2013, [email-masked] wrote:
> 
> The IESG has received a request from an individual submitter to consider
> the following document:
> - 'Using the ECC Brainpool Curves for IKEv2 Key Exchange'
>   <draft-merkle-ikev2-ke-brainpool-03.txt> as Informational RFC
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2013-03-26. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>    This document specifies the use of ECC Brainpool elliptic curve
>    groups for key exchange in the Internet Key Exchange version 2
>    (IKEv2) protocol.
> 
> 
> 
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-merkle-ikev2-ke-brainpool/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-merkle-ikev2-ke-brainpool/ballot/
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> 
>

---

From: "Roni Even" <[email-masked]>
Date: Thu, 4 Apr 2013 21:28:08 +0300

Hi Johannes,
Thanks for your clarifications.
I was not aware of the request to add a new column in
draft-ietf-ipsecme-dh-checks and since I did not see the column yet I could
not understand.
So everything look OK for me now.
Roni Even

-----Original Message-----
From: Johannes Merkle [mailto:[email-masked]] 
Sent: 02 April, 2013 4:22 PM
To: Roni Even
Cc: [email-masked]; [email-masked];
Dan Harkins
Subject: Re: GenART LC review of draft-merkle-ikev2-ke-brainpool-03

Hi,

> 1.       In table 1 the Transform ID are specified as TBD1 to TBD4. I
noticed that IANA have already assigned values
> 27-30. So they should be specified. If not it will be good to ask the RFC
editor before publication to update the table.

> 
> 2.       In the IANA section I did not understand to which table you are
referring to "For the new entries in the table
> of the Transform Type 4 repository, a reference to Section 2.3 of 
> [IKE_DH_Req] shall be included in the column named "Recipient Tests"
indicating the required checks for the other peer's Diffie-Hellman public
keys."
This refers to the Table Transform Type 4 - Diffie-Hellman Group Transform
IDs, see
http://www.iana.org/assignments/ikev2-parameters/ikev2-parameters.xml#ikev2-
parameters-8

[IKE_DH_Req] requests from IANA to add a new column (named "Recipient
Tests") to that Table. We request IANA to add in that new column a a
reference to Section 2.3 of [IKE_DH_Req].

Best regards,
Johannes

---

From: Jari Arkko <[email-masked]>
Date: Wed, 10 Apr 2013 14:34:03 +0300

Roni,

Thanks for your review! It will help me post my vote (no-objection) on the document in the IESG call tomorrow.

Jari

On Apr 4, 2013, at 9:28 PM, Roni Even <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art