Subject: [Gen-art] Gen-ART review of draft-ietf-xrblock-rtcp-xr-burst-gap-discard-13

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 19 Apr 2013 10:12:42 -0500

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-xrblock-rtcp-xr-burst-gap-discard-13
Reviewer: Vijay K. Gurbani
Review Date: Apr-19-2013
IETF LC End Date: Mar-15-2013
IESG Telechat date: Apr-25-2013

This document is ready as a Proposed Standard.  One minor comment and
one nit below.

Major: 0
Minor: 1
Nits: 1

Minor:
- S2.1, the sentence, "A packet that arrives within this time window
  but is too early or late to be played out or thrown away before
  playout due to packet duplication or redundancy shall be regarded as
  discarded." is hard to read and parse.

  Clearly, if a packet arrives early, it will be buffered.  Just as
  clearly, if a packet arrives too late to be played out, it will be
  discarded.  Maybe you should break the offending sentence into two
  separate sentences, one dealing with early arrival and the other
  with late arrival.

Nits
- S1.1, last paragraph: s/in[RFC3611]./in [RFC3611]./

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Qin Wu <[email-masked]>
Date: Tue, 23 Apr 2013 07:19:36 +0000

Hi, Vijay:
Thank for your valuable review. See reply inline below.

-----Original Message-----
From: Vijay K. Gurbani [mailto:[email-masked]] 
Sent: Friday, April 19, 2013 11:13 PM
To: [email-masked]
Cc: General Area Review Team; Romascanu, Dan (Dan); Shida Schubert; Gonzalo Camarillo
Subject: Gen-ART review of draft-ietf-xrblock-rtcp-xr-burst-gap-discard-13

Major: 0
Minor: 1
Nits: 1

Minor:

[Qin]: Agree and will split.

Nits

[Qin]: Good catch, thanks.

Thanks,

- vijay

---

From: Jari Arkko <[email-masked]>
Date: Wed, 24 Apr 2013 10:54:54 +0300

Vijay: thank you for the review, the Gen-ART reviews are very important for me. And Qin: Thanks for the prompt response and a well-written document. I plan to ballot a "No objection" position for this document in the coming IESG telechat, based on this review and my own quick look at the document.

Jari

On Apr 23, 2013, at 10:19 AM, Qin Wu <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Qin Wu <[email-masked]>
Date: Wed, 24 Apr 2013 07:56:50 +0000

Thanks, Jari.

Regards!
-Qin
-----Original Message-----
From: Jari Arkko [mailto:[email-masked]] 
Sent: Wednesday, April 24, 2013 3:55 PM
To: Qin Wu; Vijay K. Gurbani
Cc: [email-masked]; Shida Schubert; General Area Review Team; Gonzalo Camarillo
Subject: Re: [Gen-art] Gen-ART review of draft-ietf-xrblock-rtcp-xr-burst-gap-discard-13

Jari