Subject: [Gen-art] Genart review of draft-sheffer-running-code-04

From: Christer Holmberg <[email-masked]>
Date: Wed, 24 Apr 2013 07:40:37 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>

Document:                         draft-sheffer-running-code-04

Reviewer:                           Christer Holmberg

Review Date:                     23 April 2013

IETF LC End Date:             10 May 2013

IETF Telechat Date           N/A

Summary:  The draft is well written, with a minor issues/question.

Major Issues: None

Minor Issues: I think it would be good to also describe and/or reference the test cases that were performed in order to determine the interoperability. In some cases it may be obvious, but if an Internet-Draft specifies a large protocol, with many features and options, just saying that there exist interoperability between two implementations doesn't really say much.

Editorial nits: None

Best regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 24 Apr 2013 12:45:49 +0000

Hi,

Could you say something like "including references to test case descriptions and interoperability reports, when such exist."?

Regards,

Christer

-----Original Message-----
From: Yaron Sheffer [mailto:[email-masked]] 
Sent: 24. huhtikuuta 2013 15:44
To: Christer Holmberg
Cc: [email-masked]; [email-masked]
Subject: Re: Genart review of draft-sheffer-running-code-04

Hi Christer,

thanks for your review!

The current (rather vague) wording is:

    In addition, this section can contain information about the
    interoperability of any or all of the implementations.

We could add: "including references to interoperability reports, when such exist."

Thanks,
	Yaron

On 2013-04-24 10:40, Christer Holmberg wrote:
> I am the assigned Gen-ART reviewer for this draft. For background on 
> Gen-ART, please see the FAQ at 
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>
>
> Minor Issues: I think it would be good to also describe and/or 
> reference the test cases that were performed in order to determine the 
> interoperability. In some cases it may be obvious, but if an 
> Internet-Draft specifies a large protocol, with many features and 
> options, just saying that there exist interoperability between two 
> implementations doesn’t really say much.
>
> Editorial nits: None
>
> Best regards,
>
> Christer
>

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 24 Apr 2013 15:43:59 +0300

Hi Christer,

thanks for your review!

We could add: "including references to interoperability reports, when 
such exist."

Thanks,
	Yaron

On 2013-04-24 10:40, Christer Holmberg wrote:
> Minor Issues: I think it would be good to also describe and/or reference
> the test cases that were performed in order to determine the

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 24 Apr 2013 15:47:47 +0300

Sure.

Thanks,
	Yaron