Subject: [Gen-art] Genart review of draft-ietf-avtcore-6222bis-03

From: Christer Holmberg <[email-masked]>
Date: Mon, 10 Jun 2013 09:16:44 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>

Document:                         draft-ietf-avtcore-6222bis-03

Reviewer:                           Christer Holmberg

Review Date:                     10 June 2013

IETF LC End Date:             11 June 2013

IETF Telechat Date:         N/A

Summary:  There is a minor issue, described below, that I think should be clarified before the document is published.

Major Issues: None

Minor Issues:

Section 4.1 says:

   "The RTCP CNAME can be either persistent across different RTP sessions

   for an RTP endpoint or unique per session, meaning that an RTP

   endpoint chooses a different RTCP CNAME for each RTP session."

...and:

   "An RTP endpoint that is emitting multiple related RTP streams that

   require synchronization at the other endpoint(s) MUST use the same

   RTCP CNAME for all streams that are to be synchronized.  This

   requires a short-term persistent RTCP CNAME that is common across

   several RTP streams, and potentially across several related RTP

   sessions.  A common example of such use occurs when lip-syncing audio

   and video streams in a multimedia session, where a single participant

   has to use the same RTCP CNAME for its audio RTP session and for its

   video RTP session.  Another example might be to synchronize the

   layers of a layered audio codec, where the same RTCP CNAME has to be

   used for each layer."

...etc.

The text talks about the CNAME being unique within an RTP session, or to span over multiple RTP sessions, but it seems to omit that, *within* an RTP session, you can also use *different* CNAME values, if e.g. there is no synchronization requirement between the RTP streams.

Editorial nits: None

Best regards,

Christer

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 10 Jun 2013 16:24:39 +0000

From: Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Monday, June 10, 2013 12:16 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Genart review of draft-ietf-avtcore-6222bis-03
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: "Ali C. Begen" <[email-masked]<mailto:[email-masked]>>, Colin Perkins <[email-masked]<mailto:[email-masked]>>, Dan Wing <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, Magnus Westerlund <[email-masked]<mailto:[email-masked]>>, Richard Barnes <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Monday, June 10, 2013 12:16 PM

IETF Telechat Date:         N/A

Major Issues: None

Minor Issues:

Section 4.1 says:

   “The RTCP CNAME can be either persistent across different RTP sessions

   endpoint chooses a different RTCP CNAME for each RTP session.”

…and:

   “An RTP endpoint that is emitting multiple related RTP streams that

   used for each layer.”

…etc.

Do you think we should add the following sentence below the second paragraph you quote above?

If the multiple RTP streams in an RTP session are not related, thus do not require synchronization, an RTP endpoint can use different RTCP CNAMEs for these streams.

Editorial nits: None

Best regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 10 Jun 2013 17:39:16 +0000

Hi Ali,

I didn’t copy the whole section 4.1, so I don’t know whether below the second paragraph is the best place (I don’t have the draft in front of me at the moment). But, the text you suggest as such is good, so I trust you’ll find a good place for it :)

Regards,

Christer

Lähettäjä: Ali C. Begen (abegen) [mailto:[email-masked]]
Lähetetty: 10. kesäkuuta 2013 19:25
Vastaanottaja: Christer Holmberg; [email-masked]
Kopio: [email-masked]
Aihe: Re: Genart review of draft-ietf-avtcore-6222bis-03

IETF Telechat Date:         N/A

Major Issues: None

Minor Issues:

Section 4.1 says:

…and:

   used for each layer.”

…etc.

Editorial nits: None

Best regards,

Christer

---

From: Jari Arkko <[email-masked]>
Date: Tue, 25 Jun 2013 13:19:54 +0300

Christer, Ali - thank you for the review and the changes. I plan to ballot a No-Objection for this draft.

Jari