Subject: Re: [Gen-art] Gen-ART Last Call review of draft-ietf-xrblock-rtcp-xr-jb-11

From: Qin Wu <[email-masked]>
Date: Mon, 3 Jun 2013 12:55:05 +0000

Hi, Meral:
Thanks for your valuable review, see my reply inline below.

Regards!
-Qin

From: Meral Shirazipour [mailto:[email-masked]]
Sent: Saturday, June 01, 2013 4:14 AM
To: [email-masked]; [email-masked]
Subject: Gen-ART Last Call review of draft-ietf-xrblock-rtcp-xr-jb-11

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq  .

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-ietf-xrblock-rtcp-xr-jb-11
Reviewer: Meral Shirazipour
Review Date: 2013-05-31
IETF LC End Date: 2013-05-31
IESG Telechat date: NA

Summary:
This draft is almost ready to be published as Standard RFC but I do have some comments.

Nits/editorial comments:
-[Page 3], Section 1.4, Suggestion for clarity:
Old:"These metrics are used to report how the jitter buffer at the receiving end of RTP stream behaves
as a result of jitter in the network and are applicable to a range of RTP applications."

New:"These metrics are used to report how the jitter buffer at the receiving end of RTP stream behaves
as a result of jitter in the network; and they are applicable to a range of RTP applications."

[Qin]: Okay.

-[Page 5], Section 3, paragraph 5, Suggestion for consistency:
"The Jitter Buffer"---->"The jitter buffer"

[Qin]: Okay.

-[Page 5], last sentence, Suggestion for clarity:
"Assume that both are normalized in ticks."----->
"Assume that both are normalized in ticks (there are 10 000 ticks in a millisecond).

[Qin]: Okay.

-[Page 6], point (iii), Suggestion for clarity:
"If r = t" --suggestion--> "If r == t"

[Qin]: Okay.

-[Page 6], point (iv), Possible inconsistance:
"Delay playout of packet by D + (r-t)"
Comment: D is not normalized in ticks. r and t are.

[Qin]:It doesn't matter, adding them together implies there is implicit unit conversion for D (from ms to ticks).

-[Page 7], Section 4.1, Suggestion for consistency:
"JB Metrics Block"---->"Jitter Block (JB) Metrics Block"

[Qin]: Okay, but it should be s/JB Metrics Blocks/Jitter Buffer(JB) Metrics BLock
-[Page 8], 3 lines before last, "the time spend"--typo-->"the time spent"

[Qin]: Okay.

-[Page 9], line 9, missing "." before "In simple":
"It is calculated based on the time spent in the jitter buffer for the earliest arriving packet In simple..."

[Qin]: Okay.
-[Page 16], Section 10.2 Reference [QMB] does not point to latest version.

[Qin]: Okay.
Best Regards,
Meral

---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: Jari Arkko <[email-masked]>
Date: Wed, 26 Jun 2013 07:56:22 -0400

Meral, thank you very much for your detailed review. And Qin, thank you for addressing these comments in -12. I have balloted No-Objection for this draft.

Jari

---

From: Qin Wu <[email-masked]>
Date: Wed, 26 Jun 2013 11:58:15 +0000

Thanks.

-----Original Message-----
From: Jari Arkko [mailto:[email-masked]] 
Sent: Wednesday, June 26, 2013 7:56 PM
To: Qin Wu
Cc: Meral Shirazipour; [email-masked]; [email-masked]
Subject: Re: [Gen-art] Gen-ART Last Call review of draft-ietf-xrblock-rtcp-xr-jb-11

Jari