Subject: [Gen-art] Gen-ART review of draft-ietf-dhc-dhcpv6-solmaxrt-update-03

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 25 Aug 2013 11:29:17 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-ietf-dhc-dhcpv6-solmaxrt-update-03
Reviewer: Dan Romascanu
Review Date: 8/25/13
IETF LC End Date: 9/3/13
IESG Telechat date: (if known)

Summary: Ready with minor issues

Major issues: None

Minor issues:

1. My understanding is that although the default values of SOL_MAX_RT and INF_MAX_RT were the same in RFC 3315, and now they are change to similar values, there is no mandatory behavior defined for servers to set them at the same values using the new override options. If this is the case then the Abstract should say 

OLD: 

... override the client's default value for SOL_MAX_RT
   and INF_MAX_RT with a new value.

NEW: 

... override the client's default value for SOL_MAX_RT
   and INF_MAX_RT with new values.

If I am wrong, and the values of the two parameters are always identical at defalult or after changes, then something needs to be said on this respect in Section 8 (DHCPv6 Server Behavior)

2. This is not a document problem but a WG management issue. I could not find anything in the dhc WG charter that corresponds to this document, so I cannot say whether this document meets the conditions of the 'contract with the IESG'. Actually the charter seems not to have been updated for five years, if not more. I guess that with Ralph as an author all is OK, but an update of the charter seems to be needed. 

Nits/editorial comments:

Section 7: 

OLD:

   a DHCPv6 client MUST silently ignore any SOL_MAX_RT or INF_MAX_RT
   values that are less than 60 or more than 86400.

New:

   A DHCPv6 client MUST silently ignore any SOL_MAX_RT or INF_MAX_RT
   values that are less than 60 or more than 86400.

Regards,

Dan

---

From: Ralph Droms <[email-masked]>
Date: Sun, 25 Aug 2013 08:27:42 -0400

Dan - thanks for your review.

> If I am wrong, and the values of the two parameters are always identical at defalult or after changes, then something needs to be said on this respect in Section 8 (DHCPv6 Server Behavior)

Dan, your understanding that SOL_MAX_RT and INF_MAX_RT are allowed to have independent values is correct.  The document originally addressed SOL_MAX_RT and I missed  the text you cite when I updated the doc to include INF_MAX_RT.  I'll make your suggested changes in the next rev of the doc.

> 2. This is not a document problem but a WG management issue. I could not find anything in the dhc WG charter that corresponds to this document, so I cannot say whether this document meets the condi…

In my opinion, this document falls under the following clause of the dhc WG charter:

   However, the DHC WG can in some cases develop its own options that 
relate to either maintenance of existing specifications or 
   improvements in the operation of the DHCP infrastructure itself.

Regarding the charter more generally, the WG is currently in the process of rechartering.

Tomek and Bernie can add detail or correct me...

>   values that are less than 60 or more than 86400.

Thanks for catching that typo.

> Dan

- Ralph

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sun, 25 Aug 2013 12:57:04 +0000

We are in the process of re-chartering. (Whether this document is included in that new charter will depend on timing as it would be unnecessary to include it if it is already 'done'.) 

The draft proposed rechartering (which has some minor updates since then), is at http://datatracker.ietf.org/doc/charter-ietf-dhc/ and does include SOLMAXRT work.

- Bernie

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]] 
Sent: Sunday, August 25, 2013 8:28 AM
To: Romascanu, Dan (Dan)
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Gen-ART review of draft-ietf-dhc-dhcpv6-solmaxrt-update-03

On Aug 25, 2013, at 7:29 AM, "Romascanu, Dan (Dan)" <[email-masked]> wrote:

> 1. My understanding is that although the default values of SOL_MAX_RT 
> and INF_MAX_RT were the same in RFC 3315, and now they are change to 
> similar values, there is no mandatory behavior defined for servers to 
> set them at the same values using the new override options. If this is 
> the case then the Abstract should say
> 
> OLD: 
> 
> If I am wrong, and the values of the two parameters are always 
> identical at defalult or after changes, then something needs to be 
> said on this respect in Section 8 (DHCPv6 Server Behavior)

   However, the DHC WG can in some cases develop its own options that relate to either maintenance of existing specifications or 
   improvements in the operation of the DHCP infrastructure itself.

- Ralph