Subject: [Gen-art] Genart review of draft-ietf-hip-reload-instance-08

From: Christer Holmberg <[email-masked]>
Date: Thu, 26 Sep 2013 07:25:14 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>

Document:                         draft-ietf-hip-reload-instance-08

Reviewer:                           Christer Holmberg

Review Date:                     26 September 2013

IETF LC End Date:             30 September 2013

IETF Telechat Date:         N/A

Summary:  The document is well written, and ready for publication, with some minor editorial nits that I ask the authors to consider fixing.

Major Issues: None

Minor Issues: None

Nits/editorial comments:

Abstract:
------------

Q_A_1:

I would suggest to modify "is the" to "specifies the".

Section 1:
-------------

Q_1_1:

In the abstract the text says "Host Identity Protocol-Based Overlay Networking Environment (HIP BONE)", and in Section 1 the text says "HIP BONE (Host Identify Protocol-Based Overlay Networking Environment)". I suggest to be consistent.

Q_1_2:

Throughout the document, you talk about "RELOAD HIP BONE". For that reason, I suggest to expand:

"This document addresses all the previous items and provides additional details needed to built RELOAD-based HIP BONEs."

...to:

"This document addresses all the previous items and provides additional details needed to built RELOAD-based HIP BONEs, referred to as RELOAD HIP BONEs."

Section 3:
-------------

Q_3_1:

I suggest to modify:

"The peer protocol to be used is RELOAD, which is specified in [I-D.ietf-p2psip-base]."

...to:

"The peer protocol to be used is RELOAD [I-D.ietf-p2psip-base]."

Q_3_2:

Please expand RELOAD on first occurrence (outside the abstract).

Section 4:
-------------

Q_4_1:

Please expand ORCHID on first occurrence.

Section 5:
-------------

Q_5_1:

I suggest to remove "defined in Section 6.5 of [I-D.ietf-p2psip-base]", as you already state this in Section 3.

---

From: Ari Keränen <[email-masked]>
Date: Thu, 26 Sep 2013 12:43:51 +0300

Thanks for the review and comments Christer! We'll take these into 
account for the next revision.

Cheers,
Ari

On 9/26/13 10:25 AM, Christer Holmberg wrote:
> I am the assigned Gen-ART reviewer for this draft. For background on
> Gen-ART, please see the FAQ at
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>
>
> Summary:  The document is well written, and ready for publication, with
> some minor editorial nits that I ask the authors to consider fixing.
>
> Major Issues: None
>
> Minor Issues: None
>
> Nits/editorial comments:
>
> Abstract:
>
> ------------
>
> Q_A_1:
>
> I would suggest to modify “is the” to “specifies the”.
>
> Section 1:
>
> -------------
>
> Q_1_1:
>
> In the abstract the text says “Host Identity Protocol-Based Overlay
> Networking Environment (HIP BONE)”, and in Section 1 the text says “HIP
> BONE (Host Identify Protocol-Based Overlay Networking Environment)”. I
> suggest to be consistent.
>
> Q_1_2:
>
> Throughout the document, you talk about “RELOAD HIP BONE”. For that
> reason, I suggest to expand:
>
> “This document addresses all the previous items and provides additional
> details needed to built RELOAD-based HIP BONEs.”
>
> …to:
>
> “This document addresses all the previous items and provides additional
> details needed to built RELOAD-based HIP BONEs, referred to as RELOAD
> HIP BONEs.”
>
> Section 3:
>
> -------------
>
> Q_3_1:
>
> I suggest to modify:
>
> “The peer protocol to be used is RELOAD, which is specified in
> [I-D.ietf-p2psip-base].”
>
> …to:
>
> “The peer protocol to be used is RELOAD [I-D.ietf-p2psip-base].”
>
> Q_3_2:
>
> I suggest to remove “defined in Section 6.5 of [I-D.ietf-p2psip-base]”,
> as you already state this in Section 3.
>