Subject: Re: [Gen-art] Gen-ART review of draft-ietf-dhc-dhcpv6-solmaxrt-update-03

From: "Ralph Droms (rdroms)" <[email-masked]>
Date: Fri, 13 Sep 2013 21:51:03 +0000

Dan - thanks for your review.  Responses in line; edits will appear in the -04 rev.

- Ralph

On Aug 25, 2013, at 7:29 AM 8/25/13, "Romascanu, Dan (Dan)" <[email-masked]> wrote:

> 
> 
> I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at
> 
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> 
> Please resolve these comments along with any other Last Call comments you may receive.
> 
> Document: draft-ietf-dhc-dhcpv6-solmaxrt-update-03
> Reviewer: Dan Romascanu
> Review Date: 8/25/13
> IETF LC End Date: 9/3/13
> IESG Telechat date: (if known)
> 
> Summary: Ready with minor issues
> 
> Major issues: None
> 
> Minor issues:
> 
> 1. My understanding is that although the default values of SOL_MAX_RT and INF_MAX_RT were the same in RFC 3315, and now they are change to similar values, there is no mandatory behavior defined for servers to set them at the same values using the new override options. If this is the case then the Abstract should say 
> 
> OLD: 
> 
> ... override the client's default value for SOL_MAX_RT
>   and INF_MAX_RT with a new value.
> 
> NEW: 
> 
> ... override the client's default value for SOL_MAX_RT
>   and INF_MAX_RT with new values.
> 
> If I am wrong, and the values of the two parameters are always identical at defalult or after changes, then something needs to be said on this respect in Section 8 (DHCPv6 Server Behavior)

Good catch; left over text from adding INF_MAX_RT after the draft was initially written.  I will use your suggested text.

> 
> 2. This is not a document problem but a WG management issue. I could not find anything in the dhc WG charter that corresponds to this document, so I cannot say whether this document meets the conditions of the 'contract with the IESG'. Actually the charter seems not to have been updated for five years, if not more. I guess that with Ralph as an author all is OK, but an update of the charter seems to be needed. 

In my opinion, this work falls under this WG work item:

  1. Develop extensions to the DHCPv6 infrastructure as required to meet
     new applications and deployments of DHCP.

Admittedly, there is no explicit entry in the list of current topics that covers this document.

I know either Bernie, Tomek or Ted has pointed out that the dhc WG is rechartering.

> 
> 
> Nits/editorial comments:
> 
> Section 7: 
> 
> OLD:
> 
>   a DHCPv6 client MUST silently ignore any SOL_MAX_RT or INF_MAX_RT
>   values that are less than 60 or more than 86400.
> 
> 
> New:
> 
>   A DHCPv6 client MUST silently ignore any SOL_MAX_RT or INF_MAX_RT
>   values that are less than 60 or more than 86400.

Fixed.

- Ralph

> Regards,
> Dan

---

From: Ted Lemon <[email-masked]>
Date: Fri, 13 Sep 2013 22:51:33 +0000

> I know either Bernie, Tomek or Ted has pointed out that the dhc WG is rechartering.

Has rechartered, at this point.   This work is on the charter.