Subject: [Gen-art] Genart review of draft-ietf-pim-rfc4601-update-survey-report-02.txt

From: Christer Holmberg <[email-masked]>
Date: Wed, 11 Sep 2013 10:26:47 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at < http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd or AD before posting a new version of the draft.

Document:                         draft-ietf-pim-rfc4601-update-survey-report-02.txt

Reviewer:                           Christer Holmberg

Review Date:                     11 September 2013

IETF LC End Date:             3 September, 2013

IESG Telechat date:         12 September, 2013

Summary:           The document is otherwise ready for publication, but contains some editorial issues that I suggest that the authors address.

Major issues: -

Minor issues: -

Nits/editorial comments:

General:

Q_GEN_1:           The RFC referencing is done in an inconsistent way: sometimes [RFC XXXX], sometimes (RFC XXXX), and sometimes RFC XXXX. I suggest to always use [RFC XXXX], OR to use [RFC XXXX] at the first occurrence, and then RFC XXXX.

Q_GEN_2:           The document mixes "PIM-SM" and "PIM Sparse-Mode" terminology. I suggest to use consistent terminology.

Section 2.2:

Q_2-2_1:             s/"five other anonymous operators"/ "five anonymous operators"

Section 2.2.1:

Q_2-2-1_1:         I suggest to replace "In the last fourteen years" with "Since <insert the year you are referencing>".

Section 2.3:

Q_2-3_1:             I suggest to replace "Eight vendors have reported PIM Sparse-Mode implementations" with "Eight vendors responded to the survey", to be consistent with the wording in section 2.2.

Section 6:

Q_6_1: Why is the section number needed? Why simply not call it "Appendix A. Questionnaire"?

Regards,

Christer

---

From: Jari Arkko <[email-masked]>
Date: Thu, 12 Sep 2013 18:35:22 +0800

Thank you for review of this document, Christer. These reviews are important for me.

Authors, have you seen Christer's review, and do you have a comment?

Jari

On Sep 11, 2013, at 6:26 PM, Christer Holmberg <[email-masked]> wrote:

> Q_GEN_2:           The document mixes “PIM-SM” and “PIM Sparse-Mode” terminology. I suggest to use consistent terminology.
>  
>  
>  
> Section 2.2:
>  
> Q_2-2_1:             s/“five other anonymous operators”/ “five anonymous operators”
>  
>  
> Section 2.2.1:
>  
> Q_2-2-1_1:         I suggest to replace “In the last fourteen years” with “Since <insert the year you are referencing>”.
>  
>  
> Section 2.3:
>  
> Q_2-3_1:             I suggest to replace “Eight vendors have reported PIM Sparse-Mode implementations” with “Eight vendors responded to the survey”, to be consistent with the wording in section 2.2.
>  
>  
> Section 6:
>  
> Q_6_1: Why is the section number needed? Why simply not call it “Appendix A. Questionnaire”?
>  
>  
> Regards,
>  
> Christer
>  
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 13 Sep 2013 00:40:42 +0000

Christer,

Sorry for not responding earlier.
Thank you very much for the review and comments. They all make sense. We will fix them and post a new version (per direction from Stig/Adrian as you suggested).

Jeffrey

From: Christer Holmberg [mailto:[email-masked]]
Sent: Wednesday, September 11, 2013 6:27 AM
To: [email-masked]
Cc: [email-masked]
Subject: Genart review of draft-ietf-pim-rfc4601-update-survey-report-02.txt

Major issues: -

Minor issues: -

Nits/editorial comments:

General:

Section 2.2:

Section 2.2.1:

Section 2.3:

Section 6:

Regards,

Christer