Subject: [Gen-art] Gen-ART LC Review of draft-ietf-ipfix-data-link-layer-monitoring-06

From: Ben Campbell <[email-masked]>
Date: Tue, 22 Oct 2013 17:36:25 -0500

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-ipfix-data-link-layer-monitoring-06
Reviewer: Ben Campbell
Review Date: 2013-22-10
IETF LC End Date: 2013-23-10

Summary: Ready for publication as a proposed standard, with  one problem that should be easily fixed.

Major issues:

None

Minor issues:

3.2.18:

Title of the data element suggests a total, but the description sounds like a delta (i.e change since last report.)

-- section 4 and subsections

It looks like this draft updates at least RFC5477. If so, this should be indicated in the header and in the abstract.

Nits/editorial comments:

-- section , 3rd paragraph:

Do you mean to say the existing data models do not contain the elements needed, or that the models do not provide the right foundation for the needed elements? The wording seems to indicate the latter but I think you mean the former.

-- General:
Watch for missing articles.

---

From: Paul Aitken <[email-masked]>
Date: Thu, 31 Oct 2013 16:05:50 +0000

Thanks for the review, Ben.

As you pointed out, the description in 3.2.18 wrongly specified a delta 
rather than a total; I've fixed it.

I also clarified the third paragraph of the Introduction to say that the 
existing models don't yet contain enough elements - which is the point 
of this draft.

Regarding section 4 / RFC 5477, the intention is that IANA's IPFIX 
registry is the ultimate reference. We want to avoid new drafts updating 
old RFCs.
The IPFIX AD is considering how to proceed with that.

I'll publish a -07 with the changes.

Thanks,
P.

---

From: Ben Campbell <[email-masked]>
Date: Thu, 31 Oct 2013 11:12:50 -0500

Thanks for the response. Those changes would address all of my comments.

Thanks!

Ben.

On Oct 31, 2013, at 11:05 AM, Paul Aitken <[email-masked]> wrote:

> As you pointed out, the description in 3.2.18 wrongly specified a delta rather than a total; I've fixed it.
> 
> I also clarified the third paragraph of the Introduction to say that the existing models don't yet contain enough elements - which is the point of this draft.
> 
> Regarding section 4 / RFC 5477, the intention is that IANA's IPFIX registry is the ultimate reference. We want to avoid new drafts updating old RFCs.