Subject: [Gen-art] Gen-ART Last Call review of draft-mcgrew-tls-aes-ccm-ecc-07

From: Meral Shirazipour <[email-masked]>
Date: Thu, 10 Oct 2013 07:26:33 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq  .

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-mcgrew-tls-aes-ccm-ecc-07
Reviewer: Meral Shirazipour
Review Date: 2013-10-10
IETF LC End Date: 2013-10-10
IESG Telechat date: NA

Summary:
This draft is ready to be published as Informational RFC but I do have some editorial comments.

Nits/editorial comments:
-[Page 4], is there a reason to use both "seq_num field" and "sequence_number field" ?
-[Page 7], Section 7, Zigbee Smart Energy 2.0 working group, a reference would be useful since it is not an IETF WG.

Best Regards,
Meral

---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: David McGrew <[email-masked]>
Date: Thu, 10 Oct 2013 09:10:22 -0400

Hi Meral,

many thanks for the review, more inline:

On 10/10/2013 03:26 AM, Meral Shirazipour wrote:
>
> I am the assigned Gen-ART reviewer for this draft. For background on 
> Gen-ART, please see the FAQ at 
> http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq  .
>

looking at RFC 6655 suggests that the latter should be changed to match 
the former.

> -[Page 7], Section 7, Zigbee Smart Energy 2.0 working group, a 
> reference would be useful since it is not an IETF WG.
>

That is a good idea.   I've copied Robert Cragie, who should be able to 
suggest a good reference.

David

---

From: Meral Shirazipour <[email-masked]>
Date: Thu, 10 Oct 2013 15:32:08 +0000

Hi,
  Thank you David.

Best Regards,
Meral

From: David McGrew [mailto:[email-masked]]
Sent: Thursday, October 10, 2013 6:10 AM
To: Meral Shirazipour
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Gen-ART Last Call review of draft-mcgrew-tls-aes-ccm-ecc-07

Hi Meral,

Summary:

Nits/editorial comments:

looking at RFC 6655 suggests that the latter should be changed to match the former.

That is a good idea.   I've copied Robert Cragie, who should be able to suggest a good reference.

David

Best Regards,
Meral

---
Meral Shirazipour
Ericsson
Research
www.ericsson.com<http://www.ericsson.com>

---

From: Robert Cragie <[email-masked]>
Date: Thu, 10 Oct 2013 22:01:35 +0100

The suggested reference is:

[SEP2] ZigBee Alliance, Inc. and HomePlug Powerline Alliance, Inc., 
"Smart Energy Profile 2 9 Application Protocol Standard", ZigBee Public 
Document 13-0200-00, 2013.

Then perhaps reword:

"This draft is motivated by the considerations raised in the Zigbee 
Smart Energy 2.0 working group"

to something like:

"This draft is motivated by the considerations raised in the Zigbee 
Smart Energy 2.0 working group and specified in [SEP2]"

Robert

On 10/10/2013 16:32, Meral Shirazipour wrote:
>
> Hi,
>
>   Thank you David.
>
> Best Regards,
>
> Meral
>
> *From:*David McGrew [mailto:[email-masked]]
> *Sent:* Thursday, October 10, 2013 6:10 AM
> *To:* Meral Shirazipour
> *Cc:* [email-masked]; 
> [email-masked]; [email-masked]
> *Subject:* Re: Gen-ART Last Call review of draft-mcgrew-tls-aes-ccm-ecc-07
>
> Hi Meral,
>
>     I am the assigned Gen-ART reviewer for this draft. For background
>     on Gen-ART, please see the FAQ at
> www.ericsson.com <http://www.ericsson.com>
>

---

From: David McGrew <[email-masked]>
Date: Thu, 10 Oct 2013 18:20:49 -0400

/Hi Robert,

On 10/10/2013 05:01 PM, Robert Cragie wrote:
> "Smart Energy Profile 2 9 Application Protocol Standard", ZigBee 
> Public Document 13-0200-00, 2013.
>
> Then perhaps reword:
>

perfect, thanks!

David

---

From: Robert Cragie <[email-masked]>
Date: Fri, 11 Oct 2013 11:01:46 +0100

Actually I noticed somehow a '9' has crept in.

The suggested reference should be:

[SEP2] ZigBee Alliance, Inc. and HomePlug Powerline Alliance, Inc., 
"Smart Energy Profile 2 Application Protocol Standard", ZigBee Public 
Document 13-0200-00, 2013.

Apologies for the confusion.

Robert

On 10/10/2013 23:20, David McGrew wrote:
>>>     I am the assigned Gen-ART reviewer for this draft. For
>>>     background on Gen-ART, please see the FAQ at

---

From: Meral Shirazipour <[email-masked]>
Date: Sun, 13 Oct 2013 04:28:34 +0000

Hi,

  Thank you, that will be great.

Best,

Meral

From: Robert Cragie [mailto:[email-masked]]
Sent: Thursday, October 10, 2013 2:02 PM
To: Meral Shirazipour
Cc: David McGrew; [email-masked]; [email-masked]
Subject: Re: Gen-ART Last Call review of draft-mcgrew-tls-aes-ccm-ecc-07

[SEP2] ZigBee Alliance, Inc. and HomePlug Powerline Alliance, Inc., "Smart Energy Profile 2 9 Application Protocol Standard", ZigBee Public Document 13-0200-00, 2013.

Then perhaps reword:

"This draft is motivated by the considerations raised in the Zigbee Smart Energy 2.0 working group"

to something like:

"This draft is motivated by the considerations raised in the Zigbee Smart Energy 2.0 working group and specified in [SEP2]"

Robert

   Hi,

     Thank you David.

   Best Regards,

   Meral

   From: David McGrew [mailto:[email-masked]]
   Sent: Thursday, October 10, 2013 6:10 AM
   To: Meral Shirazipour
   Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
   Subject: Re: Gen-ART Last Call review of draft-mcgrew-tls-aes-ccm-ecc-07

   Hi Meral,

      Review Date: 2013-10-10

      IESG Telechat date: NA

      Summary:

      Nits/editorial comments:

   David

   Best Regards,

   Meral

   ---

   Meral Shirazipour

   Ericsson

   Research

---

From: Robert Cragie <[email-masked]>
Date: Sun, 13 Oct 2013 22:40:34 +0100

I did send an e-mail - there is a mistake below.

Please make sure this is used, not the one below.

Thank you

Robert

On 13/10/2013 05:28, Meral Shirazipour wrote:
> *From:*Robert Cragie [mailto:[email-masked]]
> *Sent:* Thursday, October 10, 2013 2:02 PM
> *To:* Meral Shirazipour
> *Cc:* David McGrew; [email-masked]; 
> [email-masked]
>     *Cc:* [email-masked]
>     <mailto:[email-masked]>;
>     [email-masked] <mailto:[email-masked]>;
>     [email-masked] <mailto:[email-masked]>

---

From: Meral Shirazipour <[email-masked]>
Date: Mon, 14 Oct 2013 16:13:36 +0000

Hi Robert,

  Yes I saw that and replied to this older one by mistake.  Thank you for the re-correction.

Best,

Meral

From: Robert Cragie [mailto:[email-masked]]
Sent: Sunday, October 13, 2013 2:41 PM
To: Meral Shirazipour
Cc: David McGrew; [email-masked]; [email-masked]
Subject: Re: Gen-ART Last Call review of draft-mcgrew-tls-aes-ccm-ecc-07

[SEP2] ZigBee Alliance, Inc. and HomePlug Powerline Alliance, Inc., "Smart Energy Profile 2 Application Protocol Standard", ZigBee Public Document 13-0200-00, 2013.

Thank you

Robert

   Hi,

   Best,

   Meral

   From: Robert Cragie [mailto:[email-masked]]
   Sent: Thursday, October 10, 2013 2:02 PM
   To: Meral Shirazipour
   Cc: David McGrew; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
   Subject: Re: Gen-ART Last Call review of draft-mcgrew-tls-aes-ccm-ecc-07

   Then perhaps reword:

   to something like:

   Robert

      Hi,

        Thank you David.

      Best Regards,

      Meral

      Hi Meral,

         Review Date: 2013-10-10

         IESG Telechat date: NA

         Summary:

         Nits/editorial comments:

      David

      Best Regards,

      Meral

      ---

      Meral Shirazipour

      Ericsson

      Research

---

From: Jari Arkko <[email-masked]>
Date: Thu, 24 Oct 2013 14:34:46 +0800

Thanks for your review, Meral.

Jari

On Oct 10, 2013, at 3:26 PM, Meral Shirazipour <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art