Subject: [Gen-art] Gen-ART Last Call review of draft-hethmon-mcmurray-ftpext-ftp-hosts-03

From: Meral Shirazipour <[email-masked]>
Date: Sat, 19 Oct 2013 05:14:59 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq  .

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-hethmon-mcmurray-ftpext-ftp-hosts-03
Reviewer: Meral Shirazipour
Review Date: 2013-10-18
IETF LC End Date: 2013-10-18
IESG Telechat date: 2013-10-24

Summary:
This draft is ready to be published as Standard RFC but I do have some comments.

Nits/editorial comments:
Overall the draft was a bit hard to read but given the long time it has been around I presume it has passed implementers' test when it comes to clarity.
Here are a few comments:
-[Page 1], Asbtract: A sentence is missing between 1st and 2nd sentence: it should say what is the problem with the fact stated in the 1st sentence.
-[Page 5], typo, "accomodate"-->"accommodate"  (two occurrences)
-[Page 11] section 3.2.2. "the the server-PI "----> extra "the"
-[Page 17], Section 3.3 "or otherwise chooses not conform" --> not clear what is not conform
-[Page 18], Section 4, not clear what this sentence means:
"a server implementation
   MUST treat an additional HOST command that was sent before a user has
   been authenticated as though a previous HOST command was not sent.
"

Best Regards,
Meral

---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: Jari Arkko <[email-masked]>
Date: Thu, 24 Oct 2013 01:40:09 +0800

Thank you very much for this detailed review. Authors, do you have comments? While much of the comments are editorial, like Meral I had trouble understanding what the "chooses not conform" on page 17 means. Did you mean "chooses not to use"? Similarly, on page 18, I did not understand this: "a server implementation MUST treat an additional HOST command that was sent before a user has been authenticated as though a previous HOST command was not sent." Can you clarify?

Jari

On Oct 19, 2013, at 1:14 PM, Meral Shirazipour <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Meral Shirazipour <[email-masked]>
Date: Thu, 24 Oct 2013 16:20:35 +0000

Hi,
  Thank you Robert.

Best,
Meral

-----Original Message-----
From: Robert McMurray [mailto:[email-masked]] 
Sent: Thursday, October 24, 2013 9:05 AM
To: Jari Arkko; Meral Shirazipour
Cc: [email-masked]; [email-masked]
Subject: RE: [Gen-art] Gen-ART Last Call review of draft-hethmon-mcmurray-ftpext-ftp-hosts-03

Hello everyone,

I replied to Jari's questions in a separate email, but here are my answers again since they address two of Meral's questions:

The statement on page 17 that reads "chooses not conform" might work just as well (if not better) as " does not conform"; I can make that change if you think that is clearer to readers.

The statement on page 18 means that if an FTP server receives a HOST command, and then it receives another HOST command before a user has been authenticated, the FTP server must treat that situation as if the first HOST command was not received.

Here are my responses to Meral's remaining questions:

Page 1 - The problem is actually defined in the 1st sentence of the abstract, then addressed in the 2nd sentence.

Page 5 - I changed the two occurrences where "accommodate" was misspelled.

Page 11 - I removed the repeated word "the" from the sentence.

Thanks.

On Oct 19, 2013, at 1:14 PM, Meral Shirazipour <[email-masked]> wrote:

> -[Page 17], Section 3.3 "or otherwise chooses not conform" --> not 
> clear what is not conform -[Page 18], Section 4, not clear what this sentence means:
> "a server implementation