Subject: [Gen-art] Gen-ART review of draft-ietf-cdni-requirements-12

From: Christer Holmberg <[email-masked]>
Date: Mon, 18 Nov 2013 13:53:36 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>

Document:                         draft-ietf-cdni-requirements-12

Reviewer:                           Christer Holmberg

Review Date:                     18 November 2013

IETF LC End Date:             26 November 2013

IETF Telechat Date:         12 December 2013

Summary:  The document is well written, with one minor issue that the authors might want to address.

Major Issues: None

Minor Issues:

Q_GEN:

The document defines priority of each requirement as either [HIGH], [MED] or [LOW], which is fine. But, in addition to that, depending on the priority, the requirement text uses either "shall", "should" or "may".

Wouldn't it be more clean to use consistent terminology (e.g. "shall") in the actual requirement text, as the priority is anyway indicated separately?

Editorial nits: None

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Mon, 18 Nov 2013 23:56:53 +0000

Hi Christer. Thank you for the review. It's a good point that the language used to describe the requirement is consistent with the priority level so becomes a bit redundant. The marking of HIGH/MED/LOW makes the priority of the requirement explicitly clear. It's easier to identify and browse the requirements without having to get into the description of the requirement. Other authors can chime in. But I feel that there's value to maintaining the marking instead of using the text to specify the priority level.

Kent

From: Christer Holmberg [mailto:[email-masked]]
Sent: Monday, November 18, 2013 5:54 AM
To: [email-masked]
Cc: [email-masked]
Subject: Gen-ART review of draft-ietf-cdni-requirements-12

Major Issues: None

Minor Issues:

Q_GEN:

Editorial nits: None

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 19 Nov 2013 07:57:38 +0000

Hi Kent,

> Hi Christer. Thank you for the review. It's a good point that the language used to describe the requirement is consistent with the
> priority level so becomes a bit redundant. The marking of HIGH/MED/LOW makes the priority of the requirement explicitly clear.
> It's easier to identify and browse the requirements without having to get into the description of the requirement. Other authors can
> chime in. But I feel that there's value to maintaining the marking instead of using the text to specify the priority level.

I agree, and that is what I tried to say - eventhough my comment may have been a little unclear :)

Regards,

Christer

From: Christer Holmberg [mailto:[email-masked]]
Sent: Monday, November 18, 2013 5:54 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Gen-ART review of draft-ietf-cdni-requirements-12

Major Issues: None

Minor Issues:

Q_GEN:

Editorial nits: None

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Wed, 20 Nov 2013 00:29:44 +0000

OK. Thanks for the clarification. Appreciate your feedback. :)

Kent

From: Christer Holmberg [mailto:[email-masked]]
Sent: Monday, November 18, 2013 11:58 PM
To: Kent Leung (kleung); [email-masked]
Cc: [email-masked]
Subject: RE: Gen-ART review of draft-ietf-cdni-requirements-12

Hi Kent,

Regards,

Christer

Major Issues: None

Minor Issues:

Q_GEN:

Editorial nits: None

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 28 Nov 2013 08:14:00 +0000

Hi Kent,

I took a look at version -13, and the only change seems to be that you have changed [] to {} around the priority level.

But, in the requirement text itself, you are still using shall, should or may. My suggestion was to use consistent terminology within the requirement text itself. I would suggest to always use shall. The priority level then indicates the importance of the requirement.

Regards,

Christer

From: Kent Leung (kleung) [mailto:[email-masked]]
Sent: 20. marraskuuta 2013 2:30
To: Christer Holmberg; [email-masked]
Cc: [email-masked]
Subject: RE: Gen-ART review of draft-ietf-cdni-requirements-12

Kent

To: Kent Leung (kleung); [email-masked]<mailto:[email-masked]>

Hi Kent,

Regards,

Christer

Major Issues: None

Minor Issues:

Q_GEN:

Editorial nits: None