Subject: [Gen-art] Gen-ART LC review of draft-ietf-manet-nhdp-olsrv2-tlv-extension-01.txt

From: Brian E Carpenter <[email-masked]>
Date: Tue, 04 Feb 2014 13:31:05 +1300

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-manet-nhdp-olsrv2-tlv-extension-01.txt
Reviewer: Brian Carpenter
Review Date: 2014-02-04
IETF LC End Date: 2014-02-07
IESG Telechat date:

Summary:  Ready
--------

Comments:
---------

This draft is well-written and clear.

It retro-fits extensibility to two existing specifications.
As an author of RFC 6709 I find this an interesting exercise. Do
the hints in http://tools.ietf.org/html/rfc6709#section-4 help,
especially bullet 2?

Minor Issues:
------------

It is highly unusual for a draft to formally update another draft
(draft-ietf-manet-olsrv2), even though the latter is approved and
in the RFC queue. If we were a rational organisation, that draft
would be updated before publication.

(The writeup actually says "The Optimized Link State Routing Protocol
version 2 (OLSRv2) has been published as Standards Track." but that is
inaccurate.)

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 4 Feb 2014 10:30:23 +0000

Thanks for that review.

To be clear, the following comments are mine, not agreed with the other authors (though I have no reason to believe they would disagree with them).

I take your comment on the rational organisation. But that document is already badly delayed, and delaying it further for something needed only by extensions (we have one planned experimental extension ,not yet accepted by the WG though in that process, that needs this) would I think have been a final straw to break some camel's back. And we would still needed to have updated NHDP, which seemed cleaner from a separate document rather than buried in OLSRv2. While not formally imposing on other protocols using RFC 5444, we'd like to think this is good advice for them.

The authors attempted to follow guidelines similar to those in RFC 6709, but most of our work predated it (I did say badly delayed) so we didn't use it specifically. It's a good list and we'd use it in the future. We got some things right there. (Most importantly, we ensured that to convey information, mere presence of an address was not enough, that would have been very limiting.) We missed some things, this would be one. Security delayed us. We learned some things.

The writeup will be true soon ;) We are engaged in pre-AUTH48 questions and edits with the RFC Editor on the document (OLSRv2). You will be pleased to know that where we have identified a few things that would have resulted in immediate errata, we have instead put them into the edit (and as technical, the RFC Editor has referred back to the sponsoring AD to OK).

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: 04 February 2014 00:31
To: [email-masked]; General Area Review Team
Subject: Gen-ART LC review of draft-ietf-manet-nhdp-olsrv2-tlv-extension-01.txt

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you may receive.

Summary:  Ready
--------

Comments:
---------

It retro-fits extensibility to two existing specifications.
As an author of RFC 6709 I find this an interesting exercise. Do the hints in http://tools.ietf.org/html/rfc6709#section-4 help, especially bullet 2?

Minor Issues:
------------

It is highly unusual for a draft to formally update another draft (draft-ietf-manet-olsrv2), even though the latter is approved and in the RFC queue. If we were a rational organisation, that draft would be updated before publication.

(The writeup actually says "The Optimized Link State Routing Protocol version 2 (OLSRv2) has been published as Standards Track." but that is
inaccurate.)

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Jari Arkko <[email-masked]>
Date: Thu, 20 Feb 2014 17:06:48 +0100

Thanks for your review, Brian.

Jari

On Feb 4, 2014, at 1:31 AM, Brian E Carpenter <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art