Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-isis-fs-lsp-01

From: Meral Shirazipour <[email-masked]>
Date: Tue, 3 Jun 2014 00:45:36 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq.

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-ietf-isis-fs-lsp-01
Reviewer: Meral Shirazipour
Review Date: 2014-06-02
IETF LC End Date:   2014-06-03
IESG Telechat date: 2014-06-12

Summary:
This draft is ready to be published as Standard RFC but I have some editorial comments.

Nits/editorial comments:
-[Page 5], Section 2, typo , "identifes"-->"identifies"
-[Pages 8, 10, 12],  typo: "sub-TLVss"----->"sub-TLVs"
-[page 6] section 2.2, an example would be useful for:
"
o  The eight bit type is encoded as an unsigned 16 bit integer
o  The eight bit length field is replaced by the 16 bit length field
"
-[Page 14], Section 5 the sentence could be more readable with the suggested change:
old:
"
Even when all routers in a given scope support FS PDUs, if not all routers in
   the flooding domain for a given scope support that scope flooding of
   the FS-LSPs may be compromised.
"
suggested:(added ", then")
"
Even when all routers in a given scope support FS PDUs, if not all routers in
   the flooding domain for a given scope support that scope, then flooding of
   the FS-LSPs may be compromised.
"
-Suggestion, when reference to [IS-IS] is made, it would be very useful to point to the right section as well, when possible.

Best Regards,
Meral
---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Tue, 3 Jun 2014 01:09:34 +0000

Meral -

Thanx for your review.
Responses inline.

From: Meral Shirazipour [mailto:[email-masked]]
Sent: Monday, June 02, 2014 5:46 PM
To: [email-masked]; [email-masked]
Subject: Gen-ART Last Call review of draft-ietf-isis-fs-lsp-01

Summary:

Nits/editorial comments:

LES :Corrected.

LES: Corrected.

LES: I have modified the bullet point to read "The eight bit type is encoded as an unsigned 16 bit integer where the 8 MSBs are all 0"

LES: I am not sure what you expect as an example. Because the length field is 16 bits instead of 8, the length field can take on values greater than 255 - a point which which is explicitly made in the next bullet. The  numerical value used in the length field in an Extended TLV is not limited to the values used in Standard TLVs (<= 255) even when the type is a Standard TLV code point.

"

LES: Accepted

LES: There is not a single section which is applicable to the references. In most cases there are multiple sections which apply - so I don't think your suggestion is practical.

   Les

Best Regards,
Meral
---
Meral Shirazipour
Ericsson
Research
www.ericsson.com<http://www.ericsson.com>

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 3 Jun 2014 04:29:18 +0000

Hi Les,
  Thank you for the changes and explanations.

Best Regards,
Meral

From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
Sent: Monday, June 02, 2014 6:10 PM
To: Meral Shirazipour; [email-masked]; [email-masked]
Subject: RE: Gen-ART Last Call review of draft-ietf-isis-fs-lsp-01

Meral -

Thanx for your review.
Responses inline.

From: Meral Shirazipour [mailto:[email-masked]]
Sent: Monday, June 02, 2014 5:46 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Gen-ART Last Call review of draft-ietf-isis-fs-lsp-01

Summary:

Nits/editorial comments:

LES :Corrected.

LES: Corrected.

"

LES: Accepted

   Les

Best Regards,
Meral
---
Meral Shirazipour
Ericsson
Research