Subject: [Gen-art] Gen-ART Last Call review draft-ietf-tcpm-fastopen-09

From: Meral Shirazipour <[email-masked]>
Date: Wed, 23 Jul 2014 16:06:23 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq.

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-ietf-tcpm-fastopen-09
Reviewer: Meral Shirazipour
Review Date: 2014-07-23
IETF LC End Date:   2014-07-23
IESG Telechat date: NA

Summary:
This draft is ready to be published as Experimental RFC, but I have some comments.

Nits/editorial comments:
-Abstract says "thus saving up to one full round trip time (RTT)": by just reading the abstract one would think 1.5 RTT since initial 3WHS is avoided.
Reading the rest of the draft clarifies this though. Suggestion :

"
TFO allows data to be carried in the SYN and SYN-ACK packets
   and consumed by the receiving end during 'an' initial connection
   handshake, 'and' saves up to one full round trip time (RTT) compared
   to the standard TCP, ......
"

-[page 4] "MSL", to spell out at first use "maximum segment lifetime" (or please consider mentioning reference to key TCP RFCs in Terminology section).

-General: Also few other acronyms used without spelling out at first use, please consider those as well.

-[Page 7], 'Fast Open Cookie Option', it would be more familiar to IETF community to call "Kind" field "Type", unless there was a reason for this differentiation.
-[Page 10] please remove extra space (page break) if not needed.

-[Page 12], typo "connection-sharding"--->"connection-sharing"

-[page 14] "as a application"--->"as an application"

-[Page 17], typo "Neverthless"--->"Nevertheless"

-[Page 18], typo "meet the the"---->"meet the"

-[Page 21], typo "in Section Section 4.1.1"---->"in Section 4.1.1"

-[Page 21] please remove extra space (page break) if not needed.

Best Regards,
Meral

---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 29 Jul 2014 17:26:17 +0000

Hi,
  Thanks Yuchung, I agree with your suggestions.

Best Regards,
Meral

From: Yuchung Cheng [mailto:[email-masked]]
Sent: Tuesday, July 29, 2014 10:22 AM
To: Meral Shirazipour
Cc: [email-masked]; [email-masked]
Subject: Re: Gen-ART Last Call review draft-ietf-tcpm-fastopen-09

>    to the standard TCP, ......

Sounds good except it's "the" initial connection.

> -[page 4] "MSL", to spell out at first use "maximum segment lifetime" (or please consider mentioning reference to key TCP RFCs in Terminology section).
ok
> -[Page 7], 'Fast Open Cookie Option', it would be more familiar to IETF community to call "Kind" field "Type", unless there was a reason for this differentiation.

OK

> -[Page 21] please remove extra space (page break) if not needed.
OK except it is the connection-sharding, not connection sharing. The two are opposite. To avoid confusion, I would rephrase to "If experiments with TFO find that it encourages applications to use more parallel connections, cookie-in-FIN may  prove to be a useful alternative"?

I'd upload a new version soon. Thanks for the review.

>
> Best Regards,
>
> Meral
>
>
>
>
>
> ---
>
> Meral Shirazipour
>
> Ericsson
>
> Research
>
> www.ericsson.com<http://www.ericsson.com>

---

From: Yuchung Cheng <[email-masked]>
Date: Tue, 29 Jul 2014 17:22:11 +0000

On Wed, Jul 23, 2014 at 9:06 AM, Meral Shirazipour <
[email-masked]> wrote:
>
> I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at http://wiki.tools.ietf.org/
area/gen/trac/wiki/GenArtfaq.
> -Abstract says "thus saving up to one full round trip time (RTT)": by
just reading the abstract one would think 1.5 RTT since initial 3WHS is
avoided.

>
>
>
> -[page 4] "MSL", to spell out at first use "maximum segment lifetime" (or
please consider mentioning reference to key TCP RFCs in Terminology
section).
ok
> -[Page 7], 'Fast Open Cookie Option', it would be more familiar to IETF
community to call "Kind" field "Type", unless there was a reason for this
differentiation.

OK

> -[Page 21] please remove extra space (page break) if not needed.
OK except it is the connection-sharding, not connection sharing. The two
are opposite. To avoid confusion, I would rephrase to "If experiments with
TFO find that it encourages applications to use more parallel connections,
cookie-in-FIN may  prove to be a useful alternative"?