Subject: [Gen-art] Gen-ART review of draft-ietf-ianaplan-icg-response-06

From: Christer Holmberg <[email-masked]>
Date: Tue, 9 Dec 2014 11:50:06 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>

Document:                      	draft-ietf-ianaplan-icg-response-06.txt

Reviewer:                      	Christer Holmberg

Review Date:                   9 December 2014

IETF LC End Date:	15 December 2014

IETF Telechat Date:       	18 December 2014

Summary:                   	The document is well written, and almost ready. I do have a few editorial comments on the Abstract and Introduction, and a general editorial comment.

Major Issues: None

Minor Issues: None

Editorial nits:

General:
----------

Q_1:

	In Section 2, the IETF reply text sometimes uses "we" to refer to IETF. I think it would be good to say "IETF".

	For example:

		"We consider .ARPA part" -> "IETF considers .ARPA part"
		"...few cases where we may further..." -> "...few cases where IETF may further..."

		Etc.

	This may not be seen needed when reading the draft, but it will be useful if e.g. the IETF reply text is quoted elsewhere.

Abstract:
------------

Q_2:

	I think it would be good if the Abstract also would indicate that the LS was primarily sent to ICANN. Currently the text only says that an LS was sent somewhere, and that IETF was invited to reply.

Q_3:

	The last sentence of the Abstract says: "The IETF community is invited to comment and propose changes to this document."

	It is unclear what "this document" refers to. If it refers to the aggregate proposal mentioned earlier, I think that should be more clear.

Introduction:
---------------

Q_4:

	In the 1st paragraph, I think it would be good to indicate that IETF was invited to reply to the LS.

---

From: Jari Arkko <[email-masked]>
Date: Tue, 9 Dec 2014 13:55:03 +0200

Thank you very much for your review, Christer. 

I think I agree with the suggested edits. Eliot, over to you.

Jari

---

From: Eliot Lear <[email-masked]>
Date: Tue, 09 Dec 2014 13:20:06 +0100

Hi Christer,

Thank you for your review.

> General:

I have done this where it has been possible to do without leaving an
awkward structure.   If the text is taken out of that context, it is
standard practice (at least in America) to use brackets to replace a
pronoun, such as [The IETF] for "we".
> Abstract:

I propose the following abstract to address your concern:

        The U.S. NTIA has solicited a request from ICANN to propose
        how the NTIA should end its oversight of the IANA functions.
        After broad consultations, ICANN has in turn created the IANA
        Stewardship Transition Coordination Group.  That group
        solicited proposals for thre three major IANA functions:
        names, numbers, and protocol parameters.  This document
        contains the IETF response to that solicitation for protocol
        parameters.  It is meant to be included in an aggregate
        response to the NTIA alongside those for names and numbering
        resources that are being developed by their respective
        operational communities.
> 	It is unclear what "this document" refers to. If it refers to the aggregate proposal mentioned earlier, I think that should be more clear.

This sentence will be removed, as the invitation will have expired.

> Introduction:

While we were expected to reply, I do not know that we received an
actual specific invitation.  I am happy to be told otherwise.

Regards,

Eliot

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 9 Dec 2014 12:26:25 +0000

Hi Eliot,

> standard practice (at least in America) to use brackets to replace a pronoun, such as [The IETF] for "we".

Ok. 

>        resources that are being developed by their respective

Looks good.

> This sentence will be removed, as the invitation will have expired.

Ok.

> While we were expected to reply, I do not know that we received an actual specific invitation.  I am happy to be told otherwise.

I based my comment on the text (now suggested to be removed) in the Abstract, saying that the IETF community is invited. I thought that it meant that the LS sender invited the IETF community to comment :)

So, if there was no specific invitation, I agree we should not state that it was.

Thanks!

Regards,

Christer