Subject: [Gen-art] Gen-art Telechat review of draft-ietf-nfsv4-rfc3530bis-dot-x-22

From: Elwyn Davies <[email-masked]>
Date: Wed, 03 Dec 2014 01:29:45 +0000

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document: draft-ietf-nfsv4-rfc3530bis-dot-x-22.txt
Reviewer: Elwyn Davies
Review Date: 2014-12-01
IETF LC End Date: -
IESG Telechat date: 2014-12-04

Summary: Ready for publication on standards track.

The issues identified in last call have been fixed and the new version 
is now fully consistent with
draft-ietf-nfsv4-rfc3530bis-34 (and -35).

Major issues: None

Minor issues: None

Nits/editorial comments:
The extracted code goes through rpcgen cleanly.
However, the demo server created by rpcgen -a does not compile cleanly 
on machines that do not have
RPC GSS-API installed due to the lack of a definition of the 
preprocessor symbol RPCSEC_GSS (value 6).  I have suggested modifying 
the code to provide a fallback for machines that don't use GSS-API.
OLD:
     /// /* RPCSEC_GSS has a value of '6' - See RFC 2203 */
     /// union secinfo4 switch (uint32_t flavor) {
     ///  case RPCSEC_GSS:
     ///          rpcsec_gss_info        flavor_info;
     ///  default:
     ///          void;
     /// };
NEW:
     /// /* RPCSEC_GSS has a value of '6' - See RFC 2203 */
     /// %#ifndef RPCSEC_GSS
     /// /* Workaround in case machine does not have RPC GSS-API 
installed */
     /// %#define RPCSEC_GSS    6        /* RPCSEC_GSS */
     /// %#endif
     /// union secinfo4 switch (uint32_t flavor) {
     ///  case RPCSEC_GSS:
     ///          rpcsec_gss_info        flavor_info;
     ///  default:
     ///          void;
     /// };

---

From: Jari Arkko <[email-masked]>
Date: Thu, 4 Dec 2014 12:57:56 +0200

Thank you Elwyn and others for your big effort also on this draft.

Jari

On 03 Dec 2014, at 03:29, Elwyn Davies <[email-masked]> wrote:

> The issues identified in last call have been fixed and the new version is now fully consistent with
> However, the demo server created by rpcgen -a does not compile cleanly on machines that do not have
> RPC GSS-API installed due to the lack of a definition of the preprocessor symbol RPCSEC_GSS (value 6).  I have suggested modifying the code to provide a fallback for machines that don't use GSS-API.
> OLD:
>    /// /* Workaround in case machine does not have RPC GSS-API installed */
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art