Subject: [Gen-art] Gen-art Telechat review of draft-ietf-nfsv4-rfc3530bis-34

From: Elwyn Davies <[email-masked]>
Date: Wed, 03 Dec 2014 01:15:26 +0000

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document: draft-ietf-nfsv4-rfc3530bis-34.txt
Reviewer: Elwyn Davies
Review Date: 2014-12-02
IETF LC End Date: -
IESG Telechat date: 2014-12-04

Summary: I have discussed extensively with the authors and have prepared 
-35 in conjunction with them which is ready for publication as a 
Proposed Standard.

All the issues identified at last call have been fixed up in this next 
version.

Version 34 had a couple of outstanding issues, particularly 
understanding of how READDIR was intended  to operate in the face of 
modifications or deletions of the target directory between calls. Text 
has been added to s15.26.4 to clarify how servers are intended to 
operate and how clients may have to dela with this problem.

There were also a couple of editorial issues around the anonymous and 
READ bypass stateids plus some further editorial cleanup.

Major issues: None

Minor issues: READDIR behaviour clarified in -35

Nits/editorial comments: Various all fixed in -35

---

From: Jari Arkko <[email-masked]>
Date: Thu, 4 Dec 2014 12:56:26 +0200

Thank you very much for your review, Elwyn.

I can see that the document has improved. That is the most important thing in our reviews. Thank you Tom and others for taking comments from this review and elsewhere into account. Thanks again, all.

Jari

On 03 Dec 2014, at 03:15, Elwyn Davies <[email-masked]> wrote:

> Summary: I have discussed extensively with the authors and have prepared -35 in conjunction with them which is ready for publication as a Proposed Standard.
> 
> All the issues identified at last call have been fixed up in this next version.
> 
> Version 34 had a couple of outstanding issues, particularly understanding of how READDIR was intended  to operate in the face of modifications or deletions of the target directory between calls. Text has been added to s15.26.4 to clarify how servers are intended to operate and how clients may have to dela with this problem.
> 
> There were also a couple of editorial issues around the anonymous and READ bypass stateids plus some further editorial cleanup.
> 
> Major issues: None
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art