Subject: Re: [Gen-art] Fwd: Gen-art LC review: draft-holmerg-dispatch-iotl-03.txt

From: Christer Holmberg <[email-masked]>
Date: Wed, 7 Jan 2015 09:11:39 +0000

Hi Robert,

Are you ok with the suggested changes?

I suggest that we don't change the 3GPP scope. It would delay the draft, and nobody has shown any interest for non-3GPP usage.

Regards,

Christer

-----Original Message-----
From: Gen-art [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 19. joulukuuta 2014 16:10
To: Robert Sparks; General Area Review Team
Subject: Re: [Gen-art] Fwd: Gen-art LC review: draft-holmerg-dispatch-iotl-03.txt

Hi,

>> Nits/editorial comments:
>>
>>> Since you are providing an extension point for other values, someone 
>>> will ask if you need a registry for those values. I suggest 
>>> explicitly saying we are not creating a registry at this time but 
>>> expect to do so if the extension point is ever used to head that conversation off.
>> I could add the following text to the Syntax/General section:
>>
>> 	"This specification does not create an IANA registry for 'iotl' parameter values.
>> 	If new parameters values are defined in the future, such registry needs to be
>> 	created."
>>
>> Or, do you think it should be somewhere else?
> It's fine there. However, I would change the last sentence to "A registry should be considered if new parameter values are defined in the future".

Ok.

	"This specification does not create an IANA registry for 'iotl' parameter values.
 	A registry should be considered if new parameter values are defined in the future"

---------------

>>> The sentence (which occurs in the abstract and introduction) "The 
>>> directionality in traffic legs relates to a SIP request creating a 
>>> dialogue and stand-alone SIP request." does not parse. What is it 
>>> trying to say, and why is it important?
>> The sentence is not needed (and it doesn't belong in the Abstract to begin with), so I suggest to remove it.
> You'll remove it from the introduction as well?

Yes.

Regards,

Christer

_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art

---

From: Robert Sparks <[email-masked]>
Date: Wed, 07 Jan 2015 08:52:33 -0600

Your changes below are fine.

I added Paul and Richard because of their involvement in adding the 3gpp 
text.

I'm not ok with the 3gpp scope as written.
It makes no sense to claim this is a proposed standard for the Internet 
and say "it's not defined for any part of the Internet that's not 3gpp".
I would expect most of the IESG to have the same reaction.

It would be different, and less objectionable, to say "it's not likely 
to be particularly useful anywhere but in a 3GPP network".

I still think you should just remove last paragraph of the introduction, 
and section 2 altogether.

We have lots of extensions that only make sense to the devices that 
implement the extension. Everything else ignores it. That's what the 
extension in this document is doing.

RjS

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 7 Jan 2015 14:58:56 +0000

Hi Robert,

>I added Paul and Richard because of their involvement in adding the 3gpp text.
>
>It makes no sense to claim this is a proposed standard for the Internet and say "it's not defined for any part of the Internet that's not 3gpp".
>It would be different, and less objectionable, to say "it's not likely to be particularly useful anywhere but in a 3GPP network".
>
>I still think you should just remove last paragraph of the introduction, and section 2 altogether.

I assume that we then also have to remove "3rd-Generation Partnership Project (3GPP)" from the title?

Regards,

Christer

On 1/7/15 3:11 AM, Christer Holmberg wrote:
>>>> Since you are providing an extension point for other values, 
>>>> someone will ask if you need a registry for those values. I suggest

---

From: Robert Sparks <[email-masked]>
Date: Wed, 07 Jan 2015 09:03:11 -0600

> I assume that we then also have to remove "3rd-Generation Partnership Project (3GPP)" from the title?
I'm less uptight about that. That helps say "it's not likely to be 
particularly useful anywhere but in a 3GPP network".

Even P-headers, back in the day, were not "undefined outside the private 
network".