Subject: [Gen-art] review of draft-ietf-ccamp-general-constraint-encode-16.txt

From: Francis Dupont <[email-masked]>
Date: Wed, 14 Jan 2015 17:12:31 +0100

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-ccamp-general-constraint-encode-16.txt
Reviewer: Francis Dupont
Review Date: 20150107
IETF LC End Date: 20150117
IESG Telechat date: unknown

Summary: Ready

Major issues: None

Minor issues: None

Nits/editorial comments:
 - you use a strange indentation for sub sections... Perhaps it is from
  the tempate?? Anyway it will be handled/fixed by the RFC Editor.

 - 2 page 6:
  1 -- the device is switched(e.g., ROADM/OXC)
                             ^ add a space here

 - 2.2 page 7: OxFF -> 0xff (letter O -> digit 0)

 - 2.2 page 8: RestrictType -> RestrictionType

 - 2.3 page 11:
  0x01(Inclusive Range)
      ^ add a space here

 - 2.3 page 11: I can't understand the unnumbered in this statement:
  "... Note
   that the Action field can be set to 0x01 (Inclusive Range) only when
   unnumbered link identifier is used."

 - 2.6.1 page 16: I suggest: Num Labels -> Num Labels = N
  in the schema

 - 2.6.2 page 16: I suggest: Num Labels -> Num Labels = 2
  in the schema

 - 2.6.3 page 17: missing parenthesis:
  "positions (Num Labels) and beyond SHOULD be set to zero"
                                    ^ add ) here?

 - 6 page 28: I don't fully understand why RFC 5307 is an
  informative reference and RFC 4203 (same with OSPF in place
  of IS-IS) is a normative one.

 - pages 31 and 32: perhaps another side-effect from the template:
  inusual (for a draft) IP statement & co...

Thanks

[email-masked]

---

From: Leeyoung <[email-masked]>
Date: Thu, 15 Jan 2015 22:41:41 +0000

Hi Francis,

Thanks for your review and good comments. 

Please see inline for my comment. Let me know if the draft can move on or not after your review. 

Regards,
Young

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, January 14, 2015 10:13 AM
To: [email-masked]
Cc: [email-masked]
Subject: review of draft-ietf-ccamp-general-constraint-encode-16.txt

Summary: Ready

Major issues: None

Minor issues: None

Nits/editorial comments:

YOOUNG>> OK. Will fix during the RFC Editor review. 

 - 2 page 6:

YOUNG>> Ok. 

YOUNG>> OK. 

YOUNG>> OK. 

 - 2.3 page 11:
  0x01(Inclusive Range)
      ^ add a space here

YOUNG>> OK. 

YOUNG>> I think the reason for this restriction is it would be hard to retrieve the numbered interfaces from the range format (unless they are contiguously numbered). On the other hand, the unnumbered interfaces (e.g., s/0, s/1, etc.) can be extracted from the range. For example, if the begin range were s/0 and the end range were s/4, the link set would be:= {s/0, s/1, s/2, s/3, s/4}. 

YOUNG>> OK.

YOUNG>> OK. 

YOUNG>> Yes. 

YOUNG>> Yes, both should be, I think, normative references. 

YOUNG>> Sorry, that is not needed. Will be delelted. 

Thanks

---

From: Francis Dupont <[email-masked]>
Date: Mon, 19 Jan 2015 13:16:24 +0100

>  or not after your review.

=> I am not a member of the IESG, I am just in a team reviewing drafts
in last call or before the IESG review (The whole idea of the gen-art
review team is explained in the FAQ). BTW my summary was "Ready" so
if there was no blocking comments during the last call the answer
should be yes (i.e., it can move on).

>  Please resolve these comments along with any other Last Call comments

=> I keep this as it still applies.

>  YOUNG>> I think the reason for this restriction is it would be hard to retr=
>  ieve the numbered interfaces from the range format (unless they are contigu=
>  ously numbered). On the other hand, the unnumbered interfaces (e.g., s/0, s=
>  /1, etc.) can be extracted from the range. For example, if the begin range =
>  were s/0 and the end range were s/4, the link set would be:=3D {s/0, s/1, s=
>  /2, s/3, s/4}.

=> according to the answer my problem is from the unnumbered which
qualifies the link, i.e., it is identifier for unnumbered link,
not link identifier which is unnumbered. So it enters in the dubious
wording class... (still editorial issue so either you fix it at the
occasion of a new version (needed for *another* reason), or you leave
it to the RFC Editor).

Thanks

---

From: Leeyoung <[email-masked]>
Date: Tue, 20 Jan 2015 21:24:34 +0000

Hi Francis,

Thanks for your further comment. The AD wants a revision after this review. So I will fix the last point per your comment:

OLD: Note that the Action field can be set to 0x01 (Inclusive Range) only when unnumbered link identifier is used.
NEW: Note that the Action field can be set to 0x01 (Inclusive Range) only when identifier for unnumbered link is used. 

Regards,
Young

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, January 19, 2015 6:16 AM
To: Leeyoung
Cc: [email-masked]; [email-masked]
Subject: Re: review of draft-ietf-ccamp-general-constraint-encode-16.txt 

Thanks