Subject: [Gen-art] Gen-ART Telechat Call review of draft-ietf-httpauth-basicauth-update-06

From: Meral Shirazipour <[email-masked]>
Date: Thu, 19 Feb 2015 17:34:06 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ  at < http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd or AD before posting a new version of the draft.

Document: draft-ietf-httpauth-basicauth-update-06
Reviewer: Meral Shirazipour
Review Date: 2015-02-19
IETF LC End Date: 2015-02-19
IESG Telechat date: 2015-02-19

Summary: This draft is ready to be published as Standards Track RFC but I have some comments.

Nits/editorial comments:
-[Page 4], "the definition of the '"Digest" authentication scheme"--->remove extra ' before Digest
-[Page 7], not sure about this, since this RFC is a Standards Track, how do we handle its  dependence on draft: [PRECIS] draft-ietf-precis-saslprepbis-13? I.e. will we wait for that draft to be RFC first?
"
For the password, recipients MUST support all characters defined in
   the "OpaqueString" profile defined in in Section 4.2 of [PRECIS].
"

Best Regards,
Meral
---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: Julian Reschke <[email-masked]>
Date: Thu, 19 Feb 2015 18:55:25 +0100

On 2015-02-19 18:34, Meral Shirazipour wrote:
> I am the assigned Gen-ART reviewer for this draft. For background on
> Gen-ART, please see the FAQ  at <
> http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
>

Thanks!

> scheme"--->remove extra ' before Digest

Fixed in <http://trac.tools.ietf.org/wg/httpauth/trac/changeset/123>.

> -[Page 7], not sure about this, since this RFC is a Standards Track, how
> do we handle its  dependence on draft: [PRECIS]
> draft-ietf-precis-saslprepbis-13? I.e. will we wait for that draft to be
> RFC first?
>
> "
>
> ...

Yes. The spec will have to wait in the RFC queue until PRECIS is ready 
as well.

Best regards, Julian

---

From: Meral Shirazipour <[email-masked]>
Date: Thu, 19 Feb 2015 18:34:53 +0000

Hi,
 Thank you.

Best Regards,
Meral

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]] 
Sent: Thursday, February 19, 2015 9:55 AM
To: Meral Shirazipour; [email-masked]; [email-masked]
Subject: Re: Gen-ART Telechat Call review of draft-ietf-httpauth-basicauth-update-06

Thanks!

> -[Page 7], not sure about this, since this RFC is a Standards Track, 
> how do we handle its  dependence on draft: [PRECIS] 
> draft-ietf-precis-saslprepbis-13? I.e. will we wait for that draft to 
> be RFC first?
>
> "
>

Yes. The spec will have to wait in the RFC queue until PRECIS is ready as well.

Best regards, Julian