Subject: [Gen-art] Gen-ART Telechat review of draft-ietf-ccamp-gmpls-general-constraints-ospf-te-09.txt

From: Suresh Krishnan <[email-masked]>
Date: Mon, 2 Mar 2015 04:55:24 -0500

I am the assigned Gen-ART reviewer for this draft. For background on 
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>

Please wait for direction from your document shepherd or AD before 
posting a new version of the draft.

Document: draft-ietf-ccamp-gmpls-general-constraints-ospf-te-09.txt
Reviewer: Suresh Krishnan
Review Date: 2015/03/02
IESG Telechat date: 2015/03/05

Summary: This draft is ready for publication as a Proposed Standard, but 
I do have some comments you may wish to address.

Minor:

* Section 5

Isn't separating static and dynamic info of the same TE link another 
method of scaling? (e.g. encoding the Port Label Restrictions sub-TLV 
into a separate top level link TLV and advertising in a separate LSA)
If so, suggest adding a subsection here to describe it.

* Security Considerations:

I have an uneasy (potentially unjustified) feeling about the lack of any 
specific security considerations for the Connectivity Matrix sub-TLV. It 
looks pretty compute intensive to me. Somebody should probably take a 
look at the DoS possibilities with a multiple complex decomposed 
Connectivity Matrices.

* IANA Considerations:

Looking at the IANA registry, the Sub-TLVs do not have the text sub-TLV 
tag attached to them. Suggest renaming to

OLD:
TBD1   |  Connectivity Matrix sub-TLV  |  [This.I-D]

NEW:
TBD1   |  Connectivity Matrix          |  [This.I-D]

OLD:
TBD2   |  Port Label Restrictions sub-TLV  |  [This.I-D]

NEW:
TBD2   |  Port Label Restrictions          |  [This.I-D]

Thanks
Suresh

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 2 Mar 2015 22:08:32 -0500

Resending as there seems to be some issues with the tools aliases.

-------- Forwarded Message --------
Subject: [Gen-art] Gen-ART Telechat review of 
draft-ietf-ccamp-gmpls-general-constraints-ospf-te-09.txt
Date: Mon, 2 Mar 2015 04:55:24 -0500
From: Suresh Krishnan <[email-masked]>
To: 
[email-masked], 
General Area Review Team <[email-masked]>

Minor:

* Section 5

* IANA Considerations:

OLD:

NEW:

OLD:

NEW:

Thanks
Suresh

_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art

---

From: Leeyoung <[email-masked]>
Date: Tue, 3 Mar 2015 16:03:01 +0000

Hi Suresh,

Thanks for your Gen-Art review. The email you sent finally reached me. I will get back to you with my response soon.

Thanks,
Young

-----Original Message-----
From: Suresh Krishnan [mailto:[email-masked]] 
Sent: Monday, March 02, 2015 3:55 AM
To: [email-masked]; General Area Review Team
Subject: Gen-ART Telechat review of draft-ietf-ccamp-gmpls-general-constraints-ospf-te-09.txt

Minor:

* Section 5

* IANA Considerations:

OLD:

NEW:

OLD:

NEW:

Thanks
Suresh

---

From: Jari Arkko <[email-masked]>
Date: Thu, 5 Mar 2015 13:50:09 +0200

Thanks for your review, Suresh.

Jari

---

From: Leeyoung <[email-masked]>
Date: Fri, 6 Mar 2015 16:57:05 +0000

Hi Suresh,

Please see inline for my comment to your point raised. 

Thanks.
Young

-----Original Message-----
From: Suresh Krishnan [mailto:[email-masked]] 
Sent: Monday, March 02, 2015 3:55 AM
To: [email-masked]; General Area Review Team
Subject: Gen-ART Telechat review of draft-ietf-ccamp-gmpls-general-constraints-ospf-te-09.txt

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>

Please wait for direction from your document shepherd or AD before posting a new version of the draft.

Summary: This draft is ready for publication as a Proposed Standard, but I do have some comments you may wish to address.

Minor:

* Section 5

Isn't separating static and dynamic info of the same TE link another method of scaling? (e.g. encoding the Port Label Restrictions sub-TLV into a separate top level link TLV and advertising in a separate LSA) If so, suggest adding a subsection here to describe it.

YOUNG>> In this draft, the intent of the Port Label Restriction (which is a link TLV) is to introduce  a new constraint that needs to be known in path computation, not to separate dynamic TE info from static TE info. Port Label Restriction is actually quite static (as Section 3.1 (second paragraph). 

I have an uneasy (potentially unjustified) feeling about the lack of any specific security considerations for the Connectivity Matrix sub-TLV. It looks pretty compute intensive to me. Somebody should probably take a look at the DoS possibilities with a multiple complex decomposed Connectivity Matrices.

YOUNG>> I am not a security expert, but the decomposition of the connectivity matrix into multiple matrices is due to the IP MTU limit that would result a split of the info into multiple LSAs. This is a well-known technique in OPTF-TE and has been used for some time. As far as I know, this has not been an issue of security. What do you think?    

* IANA Considerations:

Looking at the IANA registry, the Sub-TLVs do not have the text sub-TLV tag attached to them. Suggest renaming to

OLD:

NEW:

OLD:

NEW:

YOUNG>> Yes, I agree.

Thanks
Suresh