Subject: [Gen-art] Pre-telechat review of draft-ietf-manet-tlv-naming-02

From: Tom Taylor <[email-masked]>
Date: Sun, 10 May 2015 18:37:01 -0400

This was supposed to be done by May 1, but got buried in my Inbox. My 
apologies.

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-manet-tlv-naming-02
Reviewer: Tom Taylor
Review Date:        10 May 2015
IETF LC End Date:    1 May 2015
IESG Telechat date: 14 May 2015

Summary: This document has minor issues that need to be resolved, along 
with a few nits.

Major issues:

Minor issues:

1. If the requested TLV Type does not immediately define all the 
corresponding type extensions for versions of that type, the Expert 
Reviewer or IANA will be faced with the task of choosing an appropriate 
Type value within which to place the extension. No guidance has been 
provided for this purpose. What is the intention?

2. No IANA Considerations have been provided for the following registries:
     TC Message-Type-specific Message TLV Types
     TC Message-Type-specific Address Block TLV Types
     HELLO Message-Type-specific Message TLV Types
     HELLO Message-Type-specific Address Block TLV Types
     SMF_TYPE Message TLV Type Extensions
     SMF_NBR_TYPE Address Block TLV Type Extensions

Nits/editorial comments:

Sec. 1, third from last paragraph: s/consisteng/consistent/

Sec. 3.1, s/reguested/requested/ (both outer bullets, first line of each)

IANA Considerations, following Table 11: the current registry name is 
"ICV[TIMESTAMP] Address TLV Type Extensions" (missing the word "Block"). 
This is inconsistent with the other address block TLV types. I suggest, 
in place of the current text for these two extension registries, text to 
resolve the inconsistency, as follows:

OLD

    The IANA Registry "ICV[TIMESTAMP] Address Block TLV Type Extensions"
    is unchanged.

NEW

    The IANA Registry "ICV[TIMESTAMP] Address TLV Type Extensions" is
    unchanged except to add the word "Block" after "Address" in the
    registry name.

IANA Considerations, Table 13 and preceding text: the current registry 
name is "NBR_ADDR_TYPE ....". This document refers to it as 
"NBR_ADDR_TYPES ...." (i.e., plural). The inconsistency needs to be 
resolved.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 13 May 2015 15:51:11 +0000

Tom

Thanks for those detailed and useful comments. The soon to be submitted next draft will address all of them.

Christopher

-- 
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence
__________________________________________________________________________

T:  +44 (0)1245 242194  |  E: [email-masked]

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

-----Original Message-----
From: Tom Taylor [mailto:[email-masked]] 
Sent: 10 May 2015 23:37
To: Gen Art; Dearlove, Christopher (UK); T. Clausen; Justin Dean; Alvaro Retana; [email-masked]
Subject: Pre-telechat review of draft-ietf-manet-tlv-naming-02

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

This was supposed to be done by May 1, but got buried in my Inbox. My apologies.

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at

Please resolve these comments along with any other Last Call comments you may receive.

Summary: This document has minor issues that need to be resolved, along with a few nits.

Major issues:

Minor issues:

1. If the requested TLV Type does not immediately define all the corresponding type extensions for versions of that type, the Expert Reviewer or IANA will be faced with the task of choosing an appropriate Type value within which to place the extension. No guidance has been provided for this purpose. What is the intention?

Nits/editorial comments:

IANA Considerations, following Table 11: the current registry name is "ICV[TIMESTAMP] Address TLV Type Extensions" (missing the word "Block"). 
This is inconsistent with the other address block TLV types. I suggest, in place of the current text for these two extension registries, text to resolve the inconsistency, as follows:

OLD

NEW

IANA Considerations, Table 13 and preceding text: the current registry name is "NBR_ADDR_TYPE ....". This document refers to it as "NBR_ADDR_TYPES ...." (i.e., plural). The inconsistency needs to be resolved.
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Jari Arkko <[email-masked]>
Date: Thu, 14 May 2015 00:15:40 +0200

Thanks for your review, Tom. New version looks ok to me, do you agree Tom? And thank you Christopher for the changes!

Jari

On 13 May 2015, at 17:51, Dearlove, Christopher (UK) <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Tom Taylor <[email-masked]>
Date: Wed, 13 May 2015 20:05:55 -0400

Cut-and-paste error in second paragraph following Table 11:

    The IANA Registry "TIMESTAMP Address TLV Type Extensions" is renamed
    as "ICV Address Block TLV Type Extensions" but is otherwise
        ^^^
    unchanged.

ICV should be TIMESTAMP.

I still don't see any text relating to:
   SMF_TYPE Message TLV Type Extensions
   SMF_NBR_TYPE Address Block TLV Type Extensions

Tom

---

From: Jari Arkko <[email-masked]>
Date: Thu, 14 May 2015 07:53:37 +0200

Good catch!

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 14 May 2015 08:44:29 +0000

Tom

I considered that the SMF types, which are HELLO message specific, were covered by the comment that there were no changes to the HELLO message specific TLVs. But as I need to fix the cut and paste error, I can add an explicit reference if you like.

-----Original Message-----
From: Tom Taylor [mailto:[email-masked]] 
Sent: 14 May 2015 01:06
To: Jari Arkko; Dearlove, Christopher (UK)
Cc: Gen Art; T. Clausen; Justin Dean; Alvaro Retana; [email-masked]
Subject: Re: [Gen-art] Pre-telechat review of draft-ietf-manet-tlv-naming-02

ICV should be TIMESTAMP.

Tom

On 13/05/2015 6:15 PM, Jari Arkko wrote:
>> BAE Systems Applied Intelligence Limited Registered in England & 
>> Wales No: 01337451 Registered Office: Surrey Research Park, 
>> Guildford, Surrey, GU2 7YP
>>
>>
>>

---

From: Tom Taylor <[email-masked]>
Date: Thu, 14 May 2015 14:48:31 -0400

If you don't, you're liable to have to answer a question from IANA on 
that subject, so you might as well.

Tom

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 15 May 2015 08:33:57 +0000

Already done.

-----Original Message-----
From: Tom Taylor [mailto:[email-masked]] 
Sent: 14 May 2015 19:49
To: Dearlove, Christopher (UK); Jari Arkko
Cc: Gen Art; T. Clausen; Justin Dean; Alvaro Retana; [email-masked]
Subject: Re: [Gen-art] Pre-telechat review of draft-ietf-manet-tlv-naming-02

If you don't, you're liable to have to answer a question from IANA on that subject, so you might as well.

Tom