Subject: Re: [Gen-art] [Roll] Gen-ART LC review for draft-ietf-roll-mpl-parameter-configuration-04

From: Yusuke DOI <[email-masked]>
Date: Thu, 02 Jul 2015 18:26:36 +0900

Dear Peter,

Thank you for review. I submitted -06 (-05 contains some nits) as a revised version.

On 2015-06-26 08:15, Peter Yee wrote:
> Some of the parameters are described with their bit lengths, others are not.
> Lengths are listed haphazardly.  Be consistent in either including them or
> not.  Timer lengths are listed as n-bit integers, but this may be confusing
> given that the document says "Short floating point format is used to
> describe the wide range of timer values".  So, are the timer values floating
> point or integer?  Is the combined implication supposed to be that the
> numbers are formatted as floating point (for greater range), but only take
> on integer values?  Given that the values in this document are all given in
> reference to division by the value of TUNIT, it's possible that values might
> not be integers.  If that happens and only integers are desired, is rounding
> or truncation preferred?  Also note that Appendix A indicates that "short
> unsigned floating point" was dropped.  It's not completely clear if that
> means that "short [signed?] floating point" was adopted in its stead or
> whether actual short integers were preferred.

Short floating point is dropped but some texts have not removed (my mistake). Thank you for pointing out. All values should be in integer.

Thank you again for your efforts on review (and sorry for lot of nits...)

Yusuke

---

From: Jari Arkko <[email-masked]>
Date: Thu, 9 Jul 2015 00:07:53 +0200

Yusuke, Peter, thanks for detailed review and changes.

Jari

On 02 Jul 2015, at 11:26, Yusuke DOI <[email-masked]> wrote:

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll