Subject: [Gen-art] Gen-art telechat review of draft-ietf-6lo-btle-14

From: Elwyn Davies <[email-masked]>
Date: Tue, 07 Jul 2015 10:22:34 +0100

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document: draft-ietf-6lo-btle-14.txt
Reviewer: Elwyn Davies
Review Date: 2015/07/07
IETF LC End Date: 2015/06/09
IESG Telechat date: 2015/07/09

Summary:
Ready for proposed standard.  Thanks for sorting out the points raised 
in my last call review.  The section on subnet usage is very helpful.  
There are a few very minor nits that I spotted on reading the new 
version that can be passed to the RFC Editor if no other changes are needed.

Major issues:
None.

Minor issues:
None.

Nits/editorial comments:
s3, para 2: s/inter- peripheral/inter-peripheral/ [Remove one space]
s3.2.2, last para: "(see Section 3.2.2)" is self-referential!  I think 
you mean 3.2.3.
s3.2.4.2, last para (Item 3): s/if most recently/if the most recently/
s3.2.4, para 5: To avoid the slight confusion which I had in the 
previous version, I suggest a modification to this para to make it clear 
that the link local address can only occur on comms to the 6LBR and not 
through it, thus:
OLD:
    When a 6LN is sending a packet to or through a 6LBR, it MUST fully
    elide the source address if it is a link-local address.  A non-link-
    local source address 6LN has registered with ARO to the 6LBR for the
    indicated prefix MUST be fully elided if the source address is the
    latest address 6LN has registered for the indicated prefix.
NEW:
    When a 6LN is sending a packet to a 6LBR, it MUST fully
    elide the source address if it is a link-local address.  For other 
packets to or
    through a 6LBR with a non-link-local source address that the 6LN has 
registered
    with ARO to the 6LBR for the indicated prefix, the source address 
MUST be fully
    elided if it is the latest address that the 6LN has registered for 
the indicated prefix.
END
s5:  Need to expand UART acronym in new Direct Test Mode text (USB is on 
the well-known list, assuming it is the Universal Serial Bus meaning).
s5, last para: s/service attacks/service attack/

---

From: Jari Arkko <[email-masked]>
Date: Thu, 9 Jul 2015 00:01:23 +0200

Elwyn: Many thanks for your detailed review. And thanks all for the changes for the previous version of the review.

Jari

On 07 Jul 2015, at 11:22, Elwyn Davies <[email-masked]> wrote:

> Ready for proposed standard.  Thanks for sorting out the points raised in my last call review.  The section on subnet usage is very helpful.  There are a few very minor nits that I spotted on reading the new version that can be passed to the RFC Editor if no other changes are needed.
> 
> Major issues:
> None.
> 
> Minor issues:
> None.
> 
> Nits/editorial comments:
> s3.2.2, last para: "(see Section 3.2.2)" is self-referential!  I think you mean 3.2.3.
> s3.2.4, para 5: To avoid the slight confusion which I had in the previous version, I suggest a modification to this para to make it clear that the link local address can only occur on comms to the 6LBR and not through it, thus:
> OLD:
>   elide the source address if it is a link-local address.  For other packets to or
>   through a 6LBR with a non-link-local source address that the 6LN has registered
>   with ARO to the 6LBR for the indicated prefix, the source address MUST be fully
>   elided if it is the latest address that the 6LN has registered for the indicated prefix.
> END
> s5:  Need to expand UART acronym in new Direct Test Mode text (USB is on the well-known list, assuming it is the Universal Serial Bus meaning).
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Savolainen Teemu (Nokia-TECH/Tampere)" <[email-masked]>
Date: Wed, 15 Jul 2015 05:43:34 +0000

Hi Elwyn,

Thank you for your review.

>s3, para 2: s/inter- peripheral/inter-peripheral/ [Remove one space] 

I didn't see space in XML version or latest output from xml2rfc, so don't know why it has been there..

>s3.2.2, last para: "(see Section 3.2.2)" is self-referential!  I think you mean 3.2.3.

Probably so, I didn't find right away discussion that warranted it's addition to -14 version. Changed.

Changed.

OLD:

That is a good clarification. Added as proposed.

>s5:  Need to expand UART acronym in new Direct Test Mode text (USB is on the well-known list, assuming it is the Universal Serial Bus meaning).

I expanded UART and USB at the same time, because it looked nicer to have both there in expanded form..

>s5, last para: s/service attacks/service attack/

Changed.

Best regards,

Teemu

---

From: Elwyn Davies <[email-masked]>
Date: Wed, 15 Jul 2015 11:44:19 +0100

Thanks, Teemu.

I'll keep a look out for version 15.

cheers,
Elwyn