Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-tls-padding-01

From: Meral Shirazipour <[email-masked]>
Date: Sat, 15 Aug 2015 01:00:53 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq.

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-ietf-tls-padding-01
Reviewer: Meral Shirazipour
Review Date: 2015-08-14
IETF LC End Date:  2015-08-24
IESG Telechat date: NA

Summary:
This draft is ready to be published as Standards Track RFC but I have some comments .

Major issues:

Minor issues:
-The draft's "Intended status:" is missing in the title.

Nits/editorial comments:
-[Page 2], Introduction, it would be clearer if the introduction would give more high level information or a reference to the 'implementation bug' being referred to:
"At least  one of these implementation bugs can be ameliorated by making the  ClientHello even larger."
Is this bug the one explained in Section 4?

-[Page 2], "consists of an arbitary"---->"consists of an arbitrary"

Best Regards,
Meral
---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: Adam Langley <[email-masked]>
Date: Mon, 17 Aug 2015 17:31:54 -0700

> -The draft's "Intended status:" is missing in the title.

Fixed (locally).

> -[Page 2], Introduction, it would be clearer if the introduction would give
> more high level information or a reference to the 'implementation bug' being
> referred to:
>

It is. Basically this draft exists entirely because of a bug in F5
products, but the rough sense from ekr (TLS WG chair) was that we
probably didn't want to call them out specifically because they
(eventually) did cooperate and help us work around the issues.

Thus there's some unfortunate ambiguity in the text. If you think
that's nonsense then I sympathise and can take it up with the chairs.

> -[Page 2], "consists of an arbitary"---->"consists of an arbitrary"

Thanks, fixed (locally).

Cheers

AGL

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 24 Aug 2015 14:55:19 +0100

Hi Adam,

Can you post a revision of this with those changes before Thursday?
If so, I'll put this on the Sep 3 IESG telechat for approval.

I didn't see any other changes that need to be made as a result of
the IETF LC, but please correct me if that's wrong.

Thanks,
S.

---

From: Adam Langley <[email-masked]>
Date: Mon, 24 Aug 2015 10:32:01 -0700

> If so, I'll put this on the Sep 3 IESG telechat for approval.

Done. https://datatracker.ietf.org/doc/draft-ietf-tls-padding/

> the IETF LC, but please correct me if that's wrong.

I'm not aware of any. I'm leaving the decision about whether to be
more specific about the aims (e.g. "F5 terminators have a bug $x and
this extension exists to work around it") up to someone else. I'm
happy to write it either way.

Cheers

AGL

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 24 Aug 2015 21:12:20 +0100

> Done. https://datatracker.ietf.org/doc/draft-ietf-tls-padding/

Great thanks, added to Sep 3rd telecat

S