Subject: Re: [Gen-art] Gen-ART Last Call review of draft-ietf-homenet-dncp-08

From: Markus Stenberg <[email-masked]>
Date: Wed, 5 Aug 2015 22:58:25 +0300

On 29.7.2015, at 11.25, Meral Shirazipour <[email-masked]> wrote:
> I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ athttp://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq.

Thank you for the review. This response notes the changes incorporated in -09 version (that relate to this review).

> Nits/editorial comments:
> 
>  
> 
> -Abstract, suggestion:
> 
> “uses Trickle"---->"uses the Trickle algorithm"

Fixed.

>  
> 
> -Abstract, suggestion:
> 
> “DNCP is an abstract protocol, that"---->"DNCP is an abstract protocol, and"

Fixed.

> 
> -[Page 3], Intro, last paragraph the terms "infrequently" and "As the network of nodes, or the rate of data changes grows over a given time interval"
> 
> it would be good to give example values or ranges to better describe what is meant by these terms.

Given abstractness of the protocol, it is not really possible (different applications, orders of magnitude different timers; we see that already in use). However, we added applicability (statement) subsection to the introduction in which we provide some math about what sort of applications DNCP is suitable for which covers this I believe.

> -[Page 3], “specifies transport method"---->"specifies the transport method"

Text changed based on another review, n/a.

> -[Page 10], “higher then"---->"higher than"

Fixed.

> -[Page 28], “Certifcate"---->"Certificate"

Fixed.

> -Please consider adding caption and title to all figures.

As all figures we have are in their own individual sub-sections that are essentially caption/title for the related figure as well, the authors chose not to.

Is there some reason (e.g. a tool?) that would benefit from this?

Cheers,

-Markus

---

From: Meral Shirazipour <[email-masked]>
Date: Wed, 5 Aug 2015 20:53:23 +0000

Hi,
  Thank you for the changes.

Best,
Meral

-----Original Message-----
From: Markus Stenberg [mailto:[email-masked]] 
Sent: Wednesday, August 05, 2015 12:58 PM
To: Meral Shirazipour
Cc: [email-masked]; [email-masked]
Subject: Re: Gen-ART Last Call review of draft-ietf-homenet-dncp-08

Fixed.

Fixed.

Fixed.

Fixed.

Cheers,

-Markus