Subject: Re: [Gen-art] Review: draft-ietf-mpls-lsp-ping-relay-reply-10

From: Lizhong Jin <[email-masked]>
Date: Sun, 27 Sep 2015 09:04:57 +0800

Hi Joel,
Sorry for the late reply, I missed this email.
Thanks for the second round review. You are right, the stack will grows
downward, but only with the relay nodes, not all nodes along the LSP. The
mechanism is described in section 4.2 paragraph 4.
Do you agree if I add the following:
This stack grows downward, with relay node addresses further along the
LSP appearing lower down in the stack. Please refer to section 4.2 for the
relay node discovery mechanism.

Regards
Lizhong

>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Thu, 17 Sep 2015 21:35:34 -0400
> From: "Joel M. Halpern" <[email-masked]>
> To: "A. Jean Mahoney" <[email-masked]>, General Area Review Team
>         <[email-masked]>, "[email-masked]" <[email-masked]>
> Subject: [mpls] [Gen-art] Review:
>         draft-ietf-mpls-lsp-ping-relay-reply-10
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=windows-1252; format=flowed
>
> I am the assigned Gen-ART reviewer for this draft. The General Area
> Review Team (Gen-ART) reviews all IETF documents being processed
> by the IESG for the IETF Chair.  Please treat these comments just
> like any other last call comments.
>
> For more information, please see the FAQ at
>
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
>
> Document: draft-ietf-mpls-lsp-ping-relay-reply-10
>      Relayed Echo Reply mechanism for LSP Ping
> Reviewer: Joel M. Halpern
> Review Date: 17-September-2015
> IETF LC End Date: 25-Sept-2015
> IESG Telechat date: N/A
>
> Summary: This document is ready for publication as a Proposed Standard
>
> Major issues: none
>
> Minor issues:
>      In this document, the address stack grows downward.  While
> reasonable, I think that in the absence of warning of this, readers are
> likely to be confused when they read the detailed procedures.  I think
> the document would be helped by adding the sentence:
>      "This stack grows downward, with addresses further along the LSP
> appearing lower down in the stack."
>     This could appear right after:
>      "-  Stack of Relayed Addresses: a list of relay node addresses."
> in section 3.2.
>
> Nits/editorial comments:
>
>
>
> ------------------------------
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 27 Sep 2015 12:23:57 -0400

Yes, I think adding that would improve readability.

Yours,
Joel

On 9/26/15 9:04 PM, Lizhong Jin wrote:
> downward, but only with the relay nodes, not all nodes along the LSP.
> The mechanism is described in section 4.2 paragraph 4.
> LSP appearing lower down in the stack. Please refer to section 4.2 for
> the relay node discovery mechanism.
>
> Regards
> Lizhong
>
>
>
>     From: "Joel M. Halpern" <[email-masked]
>     <mailto:[email-masked]>>
>     To: "A. Jean Mahoney" <[email-masked]
>     <mailto:[email-masked]>>, General Area Review Team
>              <[email-masked] <mailto:[email-masked]>>,
>     "[email-masked] <mailto:[email-masked]>" <[email-masked]
>     <mailto:[email-masked]>>
>     Message-ID: <[email-masked]
>     <mailto:[email-masked]>>