Subject: Re: [Gen-art] review: draft-housley-sow-author-statistics-00

From: Russ Housley <[email-masked]>
Date: Mon, 21 Sep 2015 12:28:39 -0400

Joel:

I would rather not include the specifications for another phase of work in this document.  We want to reference this document in an RFP, so it is better to keep if focused on the work at hand.  I'll try to come up with some words about possible future work.  Hopefully those words will address both of your comments.

Russ

On Aug 27, 2015, at 5:53 PM, Joel M. Halpern wrote:

> I am the assigned Gen-ART reviewer for this draft. The General Area
> Review Team (Gen-ART) reviews all IETF documents being processed
> by the IESG for the IETF Chair.  Please treat these comments just
> like any other last call comments.
> 
> For more information, please see the FAQ at
> 
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> 
> Document: draft-housley-sow-author-statistics-00
>      Statement of Work for Extensions to the IETF Datatracker for
>                           Author Statistics
> Reviewer: Joel M. Halpern
> Review Date: 27-August-2015
> IETF LC End Date: 23-September-2015
> IESG Telechat date: N/A
> 
> Summary: This document is ready for publication as an Informational RFC
> 
> Major issues: N/A
> 
> Minor issues:
>    There are a few references in this document to the format evolution.  It seems that either this document should provide for additional work as those changes occur, or should indicate that such further work will be dealt with separately at the appropriate time.
> 
> Nits/editorial comments:
>    I wonder if this document could or should identify additional metadata items that the new formats could provide to make these statistics more reliable.

---

From: Russ Housley <[email-masked]>
Date: Mon, 21 Sep 2015 18:50:19 -0400

Joel:

Does this proposed text address your comments?

Russ

= = = = = = = = =

7.  Thoughts on Future Enhancements

   With the planned change in document format, some of the information
   obtained through heuristics might be more directly extracted from the
   XML file.  Once this format is being used by a significant number of
   authors, a future effort might move away from heuristics toward
   extraction from the XML file.  To support this approach, it would be
   desirable for the new XML schema to make the author's continent of
   residence available, even if it not used in the formatting of the
   human-readable document.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 21 Sep 2015 18:57:54 -0400

Yes, that would address my comments very nicely.
Yours,
Joel