Subject: [Gen-art] Gen-Art telechat review: draft-hansen-scram-sha256-04 (was Re: Gen-art (second) LC review: draft-hansen-scram-sha256)

From: Robert Sparks <[email-masked]>
Date: Tue, 01 Sep 2015 13:54:46 -0500

For completeness in the gen-art archives and so that Jari doesn't have 
to go looking:

(boilerplate elided)

Summary: Ready for publication as a Proposed Standard

On 8/4/15 1:43 PM, Robert Sparks wrote:
> (apologies to the genart list who will see this as a duplicate):
>
> I am the assigned Gen-ART reviewer for this draft. For background on
> Gen-ART, please see the FAQ at
>
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
>
> Please resolve these comments along with any other Last Call comments
> you may receive.
>
> Document: draft-hansen-scram-sha256
> Reviewer: Robert Sparks
> Review Date: 04-Aug-2015
> IETF LC End Date: 25-Aug-2015
> IESG Telechat date: not yet on any telechat
>
> Summary: Ready for publication as a Proposed Standard
>
> The change to PS addresses the concern I expressed in the review below.
> miniscule-nit: I still think the extra URI section after the 
> references is not needed.
>
> RjS
>
> On 4/2/15 1:41 PM, Robert Sparks wrote:
>> I am the assigned Gen-ART reviewer for this draft. For background on
>> Gen-ART, please see the FAQ at
>>
>> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
>>
>> Please resolve these comments along with any other Last Call comments
>> you may receive.
>>
>> Document: draft-hansen-scram-sha256
>> Reviewer: Robert Sparks
>> Review Date: 2Apr2015
>> IETF LC End Date: 24Apr2015
>> IESG Telechat date: (if known)
>>
>> Summary: Ready for publication as Informational, with nits that 
>> should be considered.
>>
>> Nits/editorial comments:
>>
>> Nit:
>> It raises flags for me when an Informational document uses "Updates" 
>> on a standards track document.
>> I would argue that this does _not_ update 5802. IANA did the things 
>> that 5802 requested, and this document
>> is requesting something else that happens to change those things. 
>> That makes this more of a "see also" than
>> a "the protocol changed", and I think the Updates should be removed.
>>
>> I don't feel super strongly about the difference in _this particular 
>> case_, hence its classification as a Nit.
>> But for consistency, and avoiding the issue of having an 
>> Informational update a PS, I hope you choose to remove it.
>>
>> Editorial comment:
>> The URLs in the references section seem superfluous since you've 
>> already expanded them in the introduction?
>>
>> _______________________________________________
>> Gen-art mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/gen-art
>

---

From: Jari Arkko <[email-masked]>
Date: Wed, 2 Sep 2015 22:02:46 +0300

thanks for your review again, Robert!

Jari

On 01 Sep 2015, at 21:54, Robert Sparks <[email-masked]> wrote:

> For completeness in the gen-art archives and so that Jari doesn't have to go looking:
> 
> (boilerplate elided)
> 
>> miniscule-nit: I still think the extra URI section after the references is not needed.
>> 
>> RjS
>> 
>>> Summary: Ready for publication as Informational, with nits that should be considered.
>>> 
>>> Nits/editorial comments:
>>> 
>>> Nit:
>>> It raises flags for me when an Informational document uses "Updates" on a standards track document.
>>> I would argue that this does _not_ update 5802. IANA did the things that 5802 requested, and this document
>>> is requesting something else that happens to change those things. That makes this more of a "see also" than
>>> I don't feel super strongly about the difference in _this particular case_, hence its classification as a Nit.
>>> But for consistency, and avoiding the issue of having an Informational update a PS, I hope you choose to remove it.
>>> 
>>> Editorial comment:
>>> The URLs in the references section seem superfluous since you've already expanded them in the introduction?
>>>