Subject: [Gen-art] Gen-ART review of draft-ietf-ccamp-flexible-grid-rsvp-te-ext-03

From: Christer Holmberg <[email-masked]>
Date: Thu, 29 Oct 2015 09:21:26 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>
Document:                                   draft-ietf-ccamp-flexible-grid-rsvp-te-ext-03.txt
Reviewer:                                     Christer Holmberg
Review Date:                               29 October 2015
IETF LC End Date:                       9 November 2015
IETF Telechat Date:                   N/A
Summary:                                     The document is well written, and almost ready for publication. However, I have a few editorial issue that I'd like the authors to address.
Major Issues: None
Minor Issues: None
Editorial Issues:

Q1:

'RSVP-TE' is expanded in the Abstract, but not in the main document. Please expand on first occurrence also in the Introduction (last paragraph).

Same comment applies to 'LSP'.

Q2:

There is no reference for RSVP-TE.

Q3:

Would it be possible to replace the last paragraph of the Introduction with the Abstract text?

Q4:

Does 'GMPLS' need to be expanded on first occurrence?

Q5:

There is no reference to 'GMPLS' in sections 1 and 3.

Q6:

The text in section 7 says:

"This section records the status of known implementations of the
              protocol defined by this specification at the time of posting of
              this Internet-Draft,..."

I am not sure whether we should use "Internet-Draft" terminology in a published RFC, and I am not sure what time "at the time of posting of this Internet-Draft" refers to.

Perhaps you could say something like:

"This section records the status of known implementations of the
              protocol defined by this specification at the time of writing the
specification,..."

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Thu, 29 Oct 2015 10:14:36 +0000

Hi, Christer,

   Thank you for the detailed review. Please see my reply inline:

Cheers,
Xian

From: Christer Holmberg [mailto:[email-masked]]
Sent: 2015年10月29日 17:21
To: [email-masked]
Cc: [email-masked]
Subject: Gen-ART review of draft-ietf-ccamp-flexible-grid-rsvp-te-ext-03

Summary:                                     The document is well written, and almost ready for publication. However, I have a few editorial issue that I’d like the authors to address.
Major Issues: None
Minor Issues: None
Editorial Issues:

Q1:

‘RSVP-TE’ is expanded in the Abstract, but not in the main document. Please expand on first occurrence also in the Introduction (last paragraph).

Same comment applies to ‘LSP’.

[Xian]: Accepted.

Q2:

[Xian]: Accepted. Will add.

Q3:

Would it be possible to replace the last paragraph of the Introduction with the Abstract text?
[Xian]: they are essentially the same, but the last paragraph in introduction covers the draft structure better. Unless you strongly object, I would like to keep it unchanged. OK?

Q4:

Does ‘GMPLS’ need to be expanded on first occurrence?
[Xian]: It is a pretty solid abbreviation for whoever needs to read for the technical content. But I think your suggestion is reasonable, just like we need to expand to RSVP-TE and LSP. Will do.

Q5:

There is no reference to ‘GMPLS’ in sections 1 and 3.
[Xian]: Point taken. Will add.

Q6:

“This section records the status of known implementations of the
              protocol defined by this specification at the time of posting of
              this Internet-Draft,…”

I am not sure whether we should use “Internet-Draft” terminology in a published RFC, and I am not sure what time “at the time of posting of this Internet-Draft” refers to.

“This section records the status of known implementations of the
              protocol defined by this specification at the time of writing the
specification,…”

[Xian]: This section will be removed when it becomes a RFC (see the editor note put at the beginning of this section in the draft). So I do not think your issue applies. I would prefer to leave it, avoiding using specification twice. OK?

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 29 Oct 2015 10:32:04 +0000

Hi Xian,

I am ok with your suggestions. Regarding section 7, I missed the editor note, so no need to change the text :)

Thanks!

Regards,

Christer

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 29 Oct 2015 21:20:21 -0000

Hi y'all,

[snip]

>> [Xian]: It is a pretty solid abbreviation for whoever needs to read for the
technical
>> content. But I think your suggestion is reasonable, just like we need to
expand to
>> RSVP-TE and LSP. Will do.

GMPLS is shown as an acceptable abbreviation to be used w/o expansion at
http://www.rfc-editor.org/materials/abbrev.expansion.txt

[snip]

>>              this Internet-Draft,…”
>>
>> I am not sure whether we should use “Internet-Draft” terminology in a
published RFC, and
>> I am not sure what time “at the time of posting of this Internet-Draft”
refers to. 
> [Xian]: This section will be removed when it becomes a RFC (see the editor
note put at
> the beginning of this section in the draft). So I do not think your issue
applies. I would
> prefer to leave it, avoiding using specification twice. OK?

As co-author of this I-D and of RFC 6982, I agree with Xian on this point.

Cheers,
Adrian
--
Read my latest...
Tales from the Wood - Eighteen new fairy tales
http://www.feedaread.com/books/Tales-from-the-Wood-9781786100924.aspx
http://www.amazon.co.uk/Tales-Wood-Adrian-Farrel/dp/1786100924
Or buy from me direct.