Subject: [Gen-art] Gen-ART review for draft-ietf-ippm-checksum-trailer-03

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 22 Oct 2015 15:54:34 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

For more information, please see the FAQ at

< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-ippm-checksum-trailer-03

Reviewer: Dan Romascanu

Review Date: 10/22/15

IETF LC End Date: N/A

IESG Telechat date: N/A

Summary:

This document is ready for publication. I have a couple of minor issues that need clarification and can be solved easily by minor editing.

Major issues:

Minor issues:

1.       It is not clear to me how backwards compatibility is ensured. How do implementations make distinction between OWAMP or TWAMP packets that use timestamp update and Checksum Complement rather than timestamp update and UDP checksum update? Is a mix of senders/receivers (for OWAMP) or senders/reflectors (for TWAMP) that some support and some do not support Checksum Complement possible?

2.       The last paragraph in section 4 reads: 'The concept described in this document is intended to be used only in unauthenticated or in authenticated mode.' This seems either a mistake, or I did not understand what it means and some clarification is needed.

Nits/editorial comments:

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 22 Oct 2015 18:32:19 -0400

Hi Dan,
I'll wade-in as Document Shepherd and begin to answer your questions,
Al

[ACM]
Yes, the mix is possible, because the receiver stack performs normally
and evaluates checksums. Inserting the time stamp at a lower layer and
keeping the checksum accurate by providing the checksum-complement octets at the
same lower layer is a sender-only process.

[ACM]
In OWAMP and TWAMP, there are three Modes of operation for the Core protocol
(without optional extensions):
Unauthenticated (completely in the clear)
Authenticated
Encrypted

Authenticated mode does not calculate the HMAC over the timestamps and packet padding
fields in the Test Session packets, where checksum complement is used.
So, after lower layer placement of the timestamp and checksum-complement,
the HMAC is still valid.

Encrypted Mode requires the Timestamps of test packets to be encrypted,
so timestamps cannot be inserted at lower layers before transmission,
(unless you are also re-encrypting, then the checksum complement has little value,
as Tal points out).

Section 3.4 explains this, and provides limited *WAMP background
on the modes.

Hope this helps,
Al

From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Thursday, October 22, 2015 11:55 AM
To: General Area Review Team
Cc: [email-masked]
Subject: Gen-ART review for draft-ietf-ippm-checksum-trailer-03

Reviewer: Dan Romascanu

Review Date: 10/22/15

IETF LC End Date: N/A

IESG Telechat date: N/A

Summary:

Major issues:

Minor issues:

Nits/editorial comments:

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 23 Oct 2015 05:49:10 +0000

Hi Al,

Thanks for the explanation, this helped me a lot.

1.       It may be useful to insert a paragraph that provides this explanation

2.       Makes sense - no change needed.

Regards,

Dan

From: MORTON, ALFRED C (AL) [mailto:[email-masked]]
Sent: Friday, October 23, 2015 1:32 AM
To: Romascanu, Dan (Dan); General Area Review Team
Cc: [email-masked]
Subject: RE: Gen-ART review for draft-ietf-ippm-checksum-trailer-03

Hi Dan,

[ACM]

[ACM]

Hope this helps,
Al

Cc: [email-masked]<mailto:[email-masked]>

< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq<https://urldefense.proofpoint.com/v2/url?u=http-3A__wiki.tools.ietf.org_area_gen_trac_wiki_GenArtfaq&d=BQMFAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=nJVpve6nf4_IRNZwgYgb3Wvwua190G7VDeX_tVtAfcY&s=77sOZhtQIK_EQ0NICPaIIQs0bTXgAPQT9SLzjuCjoyE&e=>>.

Reviewer: Dan Romascanu

Review Date: 10/22/15

IETF LC End Date: N/A

IESG Telechat date: N/A

Summary:

Major issues:

Minor issues:

Nits/editorial comments: