Subject: Re: [Gen-art] Gen-ART review of draft-ietf-v6ops-siit-dc-02

From: Tore Anderson <[email-masked]>
Date: Mon, 5 Oct 2015 14:07:48 +0200

Hello Christer, and thank you very much for your feedback.

Comments in-line.

* Christer Holmberg <[email-masked]>

> Q1_1:
> 
> In a few places the 'BR' abbreviation is used, but it is not enhanced until section 2. Please enhance on first occurrence in section 1.

Ack.

> Q1_2:
> 
> In a few places the 'BR' abbreviation is used, but it is not enhanced until section 2. Please enhance on first occurrence in section 1.
> 
> The text says:
> 
> "o  To ensure that that the legacy users' IPv4 addresses remain
>       visible to the nodes and applications."
> 
> ...and:
> 
> "This ensures that there is no loss of information; the end-user's IPv4
> source address remains available to the application, allowing"
> 
> It may be obvious, but would it be possible to somehow make it more clear that the text is not (I assume) talking about the application running on the IPv4 node, but an application running in an IPv6 network?

I qualified these statements as follows:

  [...] the legacy users' IPv4 addresses remain visible to the nodes and
  applications located in the IPv6 network.

  [...] the end-user's IPv4 source address remains available to the
  application located in the IPv6 network,

> Section 6 (IANA Considerations):
> ----------------------------------------
> 
> Q6_1: Do we normally remove the section if there are no requests from
> IANA? Personally I prefer to keep the explicit "This draft makes no
> request of the IANA." sentence.

OK. (I had just copied this formulation from another draft from another
author.)

> Section 2 (Terminology):
> -----------------------------
> 
> Q2_1: Is there really a need to define the edge relay (ER) here?
> 
> It is not used anywhere in the document, and it creates a cross-reference with draft-ietf-v6ops-siit-dc-2xlat - which is the document extending the SIIT mechanism, by defining the ER

The term "ER" is used in sections 4.1, 4.2, 4.3 and Figure 4 at least,
so I think the definition needs to stay in section 2.

The changes I made thanks to your review are shown here:

https://github.com/toreanderson/ietf/commit/782d337d32e13a86210d5801a758320371130ce1

Please have a look and let me know if you're happy with this, or if I
should more adjustments are desired.

Best regards,
Tore Anderson

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 5 Oct 2015 20:59:51 +0000

Hi Tore,

I am ok with your suggestions how to address my issues. And, if people are ok with the cross-reference (Q2_1) I will not slow down the progress of the draft :)

Thanks!

Regards,

Christer

-----Original Message-----
From: Tore Anderson [mailto:[email-masked]] 
Sent: 05 October 2015 15:08
To: Christer Holmberg <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: Gen-ART review of draft-ietf-v6ops-siit-dc-02

Comments in-line.

Ack.

> "This ensures that there is no loss of information; the end-user's 
> IPv4 source address remains available to the application, allowing"
> 

> It is not used anywhere in the document, and it creates a 
> cross-reference with draft-ietf-v6ops-siit-dc-2xlat - which is the 
> document extending the SIIT mechanism, by defining the ER

The term "ER" is used in sections 4.1, 4.2, 4.3 and Figure 4 at least, so I think the definition needs to stay in section 2.

Please have a look and let me know if you're happy with this, or if I should more adjustments are desired.

Best regards,
Tore Anderson

---

From: Jari Arkko <[email-masked]>
Date: Thu, 15 Oct 2015 10:38:49 +0300

Thanks for your review again, Christer!

Jari

On 05 Oct 2015, at 23:59, Christer Holmberg <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art