Subject: [Gen-art] Gen-ART Telechat review of draft-ietf-netconf-call-home-11.txt

From: Suresh Krishnan <[email-masked]>
Date: Wed, 21 Oct 2015 04:10:08 +0000

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>

Please wait for direction from your document shepherd or AD before
posting a new version of the draft.

Document: draft-ietf-netconf-call-home-11.txt
Reviewer: Suresh Krishnan
Review Date: 2015/10/20
IESG Telechat date: 2015/10/22

Summary: The draft is ready for publication as a Proposed Standard but I do 
have a comment that you may wish to address.

Minor
=====

* Section 3.1 S3: The server cannot immediately start the SSH server protocol 
without waiting for SSH connection initiation from the SSH client, right? If 
yes, shouldn't there be an additional condition here?

Thanks
Suresh

---

From: Kent Watsen <[email-masked]>
Date: Wed, 21 Oct 2015 18:37:20 +0000

Hi Suresh,

Thank you for your review.

To answer your question, the server can start the SSH server protocol immediately.  It does not have the wait for the client for anything.  At least, this is how my code works  :)

Thanks again,
Kent

---

From: Jari Arkko <[email-masked]>
Date: Thu, 22 Oct 2015 14:05:25 +0100

Thanks for the explanation, Kent, and for the review, Suresh. Can the explanation be added to the document for other people who might have the same question.

Jari

On 21 Oct 2015, at 19:37, Kent Watsen <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Kent Watsen <[email-masked]>
Date: Thu, 22 Oct 2015 21:35:31 +0000

Hi Jari, Suresh,

Thank you for your suggestion.  How about this, after each of the four uses of “must immediately start” (in C3, C8, S3, and S6), we add the sentence:

    It is unnecessary for the <protocol> [client/server] to wait
    for the remote peer to initiate the <protocol> first.

Would this be helpful?

Thanks,
Kent

---

From: Kent Watsen <[email-masked]>
Date: Thu, 22 Oct 2015 22:03:00 +0000

[+barry]

I apologize to reply to myself, but I would be remiss to not mention that Barry Leiba had a related COMMENT on the "must immediately start” text.   His suggestion is to remove the words “MUST immediately” (i.e. Just have “start”).  As he writes: "What *else* might the client [server] do, which merits a MUST here?”

While I personally do think that it is “MUST immediately”, I think that the wording is still be accurate without it...and thus simply removing these two words provides an alternate way to resolve Suresh’s comment.  Thoughts?

Thanks,
Kent

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 22 Oct 2015 22:21:32 +0000

Hi Kent,

> While I personally do think that it is “MUST immediately”, I think that the wording is still be accurate without it...and thus simply removing these two words provides an alternate way to resolve S…

That works for me as well. Go for it.

Cheers
Suresh