Subject: [Gen-art] Gen-ART telechat review of draft-ietf-bess-mvpn-bidir-ingress-replication-03

From: Brian E Carpenter <[email-masked]>
Date: Fri, 9 Oct 2015 14:35:01 +1300

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair. Please wait for direction from your
document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-bess-mvpn-bidir-ingress-replication-03.txt
Reviewer: Brian Carpenter
Review Date: 2015-10-09
IETF LC End Date: 2015-10-08
IESG Telechat date: 2015-10-15

Summary: Ready
--------

Comments:
---------

Thanks for responding to my Last Call comments.

Minor Issues:
-------------

> These specifications update RFC 6514.

Is that actually true? Or is it just an *extension* of RFC 6514, which
doesn't merit a formal "Updates: 6514"? [In other words, will anything bad
happen if an implementation of RFC 6514 doesn't add this?]

---

From: Jari Arkko <[email-masked]>
Date: Thu, 15 Oct 2015 02:40:09 +0300

Thanks for your review(s), Brian! Much appreciated. Re: the update question. Good question. What say the rest of you?

Jari

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 15 Oct 2015 14:49:10 +0000

Brian, Jari, all,

Some information on whether it should be update or extension:

For the particular use case - supporting MVPN C-Bidir (Customer Bidirectional PIM) with Ingress Replication - the optimized procedures in this new specification should be used on all PEs for the involved VPN. The old procedures can still be used (but not mixed) even for this use case but they involve much more signaling. 

I am not sure if this constitutes "update" or just an extension and I appreciate your input.

Thanks.
Jeffrey

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: Wednesday, October 14, 2015 7:40 PM
> To: Brian E Carpenter <[email-masked]>; draft-ietf-bess-mvpn-
> [email-masked]
> Cc: General Area Review Team <[email-masked]>
> Subject: Re: [Gen-art] Gen-ART telechat review of draft-ietf-bess-mvpn-
> bidir-ingress-replication-03
> 
> Thanks for your review(s), Brian! Much appreciated. Re: the update
> question. Good question. What say the rest of you?
> 
> Jari

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 16 Oct 2015 10:30:57 +1300

If that "should" is a formal SHOULD then I would say yes, it's an update,
but that needs to be mentioned very explicitly ("This is a change to the
requirements of Section X of RFC Y" or something like that.) That way an
implementer is left in no doubt.

Just IMHO, of course.

Regards
   Brian