Subject: Re: [Gen-art] Gen-art] Review: draft-ietf-pce-pcep-domain-sequence

From: Dhruv Dhody <[email-masked]>
Date: Sun, 1 Nov 2015 15:32:52 +0000

Hi All, 

Sorry for delay in replying, let me try to send you proposed text tomorrow as per Julien's suggestion! 

Regards,
Dhruv 

> -----Original Message-----
> From: Julien Meuric [mailto:[email-masked]]
> Sent: 31 October 2015 00:35
> To: Joel Halpern Direct; Dhruv Dhody
> Cc: A. Jean Mahoney; General Area Review Team; draft-ietf-pce-pcep-
> [email-masked]; Dhruv Dhody
> Subject: Re: Gen-art] Review: draft-ietf-pce-pcep-domain-sequence
> 
> Hi Joel, hi Dhruv,
> 
> Focusing on the Area ID issue, I'd support adding some text along with
> Dhruv's proposal, but stricter (not just deferring to "implementation's
> feeling"). I.e., Area IDs are AS-specific and mustn't cross AS borders;
> AS-local Area IDs may be used inside an AS (without restricting to the
> origin AS).
> 
> See you in Yokohama,
> 
> Julien
> 
> 
> Oct. 30, 2015 - [email-masked]:
> >>          Given that Exclude Route Objects are not interleaved with
> >>     include Objects, is there a restriction that Area IDs may only
> be
> >>     excluded from paths within a single AS?
> >>
> >>
> >> [Dhruv]: I guess this would depend on the PCE behavior during
> >> inter-AS path computation i.e. PCEmay feel the area id subobjectis
> >> irreleventand strips from the XRO before sending the request to
> >> another PCE ​ or it might keep it intact. 
> >>
> >>
> >> This would be in s
> >> ​pi​
> >> ritof RFC 4874 where
> >> ​-
> >>
> >>
> >> ​
> >> The number of subobjects to be avoided, specified in the
> >>     signaled XRO, may be constant throughout the whole path setup,
> or the
> >>     subobjects to be avoided may be removed from the XRO as they
> become
> >>     irrelevant in the subsequent hops of the path setup.
> >>
> >> We can always
> >> ​use 
> >> EXRS in IRO specify the intentions much more clearly.
> >>
> >> If you agree, we can work on some text to add.
> >
> > I still can not see how the Excluded Route Object with an Area ID
> will
> > work.  How will a PCE which receives such a request know what AS it
> > applies to?  It works fine if the whole path is within one AS.  But
> if
> > this is a multi-AS request, the AS elements, if present at all, are
> in
> > the IRO.
> > The most obvious approach would be to declare that the PCE shall
> > assume that all Area ID exclusions apply to the origin AS.

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 2 Nov 2015 14:46:57 +0000

Hi All, 

How is this - 

   IGP Area subobjects in the XRO are local to the current AS.  In case
   of multi-AS path computation to exclude an IGP area in a different
   AS, IGP Area subobject should be part of Explicit Exclusion Route
   Subobject (EXRS) in the IRO to specify the AS in which the IGP area
   is to be excluded.

I have attached the working copy diff for easy reference.  

Regards,
Dhruv

> From: Dhruv Dhody
> Sent: 02 November 2015 00:33
> To: 'Julien Meuric'; Joel Halpern Direct; Dhruv Dhody
> [email-masked]
> Subject: RE: Gen-art] Review: draft-ietf-pce-pcep-domain-sequence
> 
> Hi All,
> 
> > Dhruv's proposal, but stricter (not just deferring to
> > "implementation's feeling"). I.e., Area IDs are AS-specific and
> > mustn't cross AS borders; AS-local Area IDs may be used inside an AS
> > (without restricting to the origin AS).
> >
> > See you in Yokohama,
> >
> > Julien
> >
> >

---

From: Julien Meuric <[email-masked]>
Date: Mon, 2 Nov 2015 16:57:19 +0100

Hi,

How about adding a sentence reminding that "A" stands for "Autonomous"? 
E.g., "policies may apply at AS boundaries and Area IDs after AS change 
may be pruned/ignored."

Regard,

Julien

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 3 Nov 2015 04:14:23 +0000

Hi Julien, All,

So now we have - (and thanks for bearing with me, as we get there...)

   IGP Area subobjects in the XRO are local to the current AS.  In case
   of multi-AS path computation to exclude an IGP area in a different
   AS, IGP Area subobject should be part of Explicit Exclusion Route
   Subobject (EXRS) in the IRO to specify the AS in which the IGP area
   is to be excluded.  Further policy may be applied to prune/ignore
   Area subobjects in XRO after "current AS" change during path
   computation.

I have also attached the diff of the working copy to show the GenArt and IANA review changes so far. 

Regards,
Dhruv

> Sent: 03 November 2015 00:57
> To: Dhruv Dhody; Joel Halpern Direct; Dhruv Dhody

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 2 Nov 2015 23:17:57 -0500

Thank you.  This addresses my concern.
Yours,
Joel

---

From: Jari Arkko <[email-masked]>
Date: Thu, 19 Nov 2015 13:18:40 +0200

Thanks, all. Many thanks Joel for your review, and on focusing on key issues.

Jari

On 03 Nov 2015, at 06:17, Joel M. Halpern <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art