Subject: Re: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 2 Nov 2015 14:24:30 -0500

Hi Ralph and Alia -

Ralph - I have replace the sequence number/mac withdraw sub-TLV registration, 
Section with request for the value 0x0001 from the LDP's TLV type name space.
Please review and verify that it addresses your concern.

Alia - I have also addressed your concern by replacing the original text with
Steve Bryant's offered text (which you stated you were OK with). Please review,
verify and accept by removing "DISCUSS" on this draft review.

Thanks,
Himanshu

-----Original Message-----
From: Shah, Himanshu 
Sent: Monday, October 26, 2015 7:05 PM
To: 'Ralph Droms (rdroms)'
Cc: Andrew G. Malis; A. Jean Mahoney; General Area Review Team; [email-masked]; The IESG
Subject: RE: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd

Hi Ralph -

You make a good point on the sub-TLV.
I have talked to my WG chairs and we are going to change the text based on your suggestion.
I will remove the MAC Withdraw sub-TLV registry for sequence number TLV and instead use the Value from the LDP Type values (same as MAC List TLV).

As for combining text of section 3 and 4.1.

Section 3 described the packet fields, including the sequence number text.
The reason for sequence number text is - that it is applicable to both; Sender (section 4.1) and Receiver (section 4.2).

I will explore to remove the overlap..

Thanks,
Himanshu

-----Original Message-----
From: Ralph Droms (rdroms) [mailto:[email-masked]]
Sent: Monday, October 26, 2015 3:13 PM
To: Shah, Himanshu
Cc: Andrew G. Malis; A. Jean Mahoney; General Area Review Team; [email-masked]; The IESG
Subject: Re: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd

Himanshu - I've been tied up in meetings most of the day today and am about to go into more meetings that will last until the end of the day.

I reviewed your revised draft briefly and it mostly looks OK.  I have one substantive comment, which is about an issue I didn't notice until now:

How is the Mac Withdraw sub-TLV registry from which the "Sequence Number" code point is taken differentiated from the LDP Parameters sub-TLV registry from which the "MAC List" and "MAC Flush Parameter" code points are taken?  In other words, how does the receciver know to interpret the code point on the Sequence Number TLV as a code point in the Mac Withdraw sub-TLV registry while the code points on the MAC List TLV and the MAC Flush Paramter TLV are interpreted as code points in the LDP Paramteres sub-TLV?  Shouldn't all the code points on the TLVs in this message come from a single registry?

I also have an editorial comment from my earlier review: the ifrst paragraph of section 3 is mostly redundant with section 4.1 and that text in section 3 should be merged into the text in section 4.1

- Ralph

> On Oct 26, 2015, at 2:09 PM 10/26/15, Shah, Himanshu <[email-masked]> wrote:
> 
> Thanks Andy.
> He did re-send the email without MIME and I was able to read and reply.
>  
> Thanks,
> Himanshu
>  
> From: Andrew G. Malis [mailto:[email-masked]]
> Sent: Monday, October 26, 2015 2:08 PM
> To: Shah, Himanshu
> Cc: Ralph Droms (rdroms); A. Jean Mahoney; General Area Review Team; 
> [email-masked]; The IESG
> Subject: Re: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd
>  
> Himanshu,
>  
> Ralph said:
>  
> Himanshu - I've received your revised draft.  I've been stuck in a variety of meetings Monday and haven't had time to review it.  I should be able to look at it before the end of the day.
> 
> - Ralph
>  
> On Mon, Oct 26, 2015 at 1:04 PM, Shah, Himanshu <[email-masked]> wrote:
> Can you send the email without MIME signature?
>  
> Thanks,
> Himanshu
>  
> From: Ralph Droms (rdroms) [mailto:[email-masked]]
> Sent: Monday, October 26, 2015 1:02 PM
> To: Shah, Himanshu
> Cc: A. Jean Mahoney; General Area Review Team; 
> [email-masked]; The IESG
> Subject: Re: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 3 Nov 2015 13:24:10 +0900

Himanshu,

Section 6.2 isn’t quite right yet. Here’s some suggested text instead:

6.2.  Sequence Number TLV

This document requests IANA to assign a new TLV Type (requested value
0x0001) from the existing LDP "TLV Type Name Space" registry. The
description for the new TLV Type is "Sequence Number TLV”.

Note to IANA (TO BE REMOVED BY THE RFC EDITOR): This registration should
take place at the following location:
http://www.iana.org/assignments/ldp-namespaces/ldp-namespaces.xhtml]. In
an earlier revision of this draft, we created a new sub-TLV registry
with one entry, a new "Sequence Number TLV" with the value 0x0001. This
has been implemented by several vendors. The IESG proposed that rather
than create a new sub-TLV registry, we simply allocate a new TLV Type from
the existing LDP "TLV Type Name Space" registry. In this registry, the
value 0x0001 is available for allocation by standards action, so we
request this code point for the new "Sequence Number" TLV type to avoid
needing to change the existing implementations.

Cheers,
Andy

On Tue, Nov 3, 2015 at 4:24 AM, Shah, Himanshu <[email-masked]> wrote:

> Cc: Andrew G. Malis; A. Jean Mahoney; General Area Review Team;
> I will remove the MAC Withdraw sub-TLV registry for sequence number TLV
> and instead use the Value from the LDP Type values (same as MAC List TLV).
>
> The reason for sequence number text is - that it is applicable to both;
> Sender (section 4.1) and Receiver (section 4.2).
>
> Cc: Andrew G. Malis; A. Jean Mahoney; General Area Review Team;
> Himanshu - I've been tied up in meetings most of the day today and am
> about to go into more meetings that will last until the end of the day.
>
> I reviewed your revised draft briefly and it mostly looks OK.  I have one
> substantive comment, which is about an issue I didn't notice until now:
>
> How is the Mac Withdraw sub-TLV registry from which the "Sequence Number"
> code point is taken differentiated from the LDP Parameters sub-TLV registry
> from which the "MAC List" and "MAC Flush Parameter" code points are taken?
> In other words, how does the receciver know to interpret the code point on
> the Sequence Number TLV as a code point in the Mac Withdraw sub-TLV
> registry while the code points on the MAC List TLV and the MAC Flush
> Paramter TLV are interpreted as code points in the LDP Paramteres sub-TLV?
> Shouldn't all the code points on the TLVs in this message come from a
> single registry?
>
> I also have an editorial comment from my earlier review: the ifrst
> paragraph of section 3 is mostly redundant with section 4.1 and that text
> in section 3 should be merged into the text in section 4.1
>
> - Ralph
>
> > Himanshu - I've received your revised draft.  I've been stuck in a
> variety of meetings Monday and haven't had time to review it.  I should be
> able to look at it before the end of the day.
> >
> > - Ralph
> >

---

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 2 Nov 2015 23:49:18 -0500

Ok, I updated the section. Please review.

Thanks,
Himanshu

From: Andrew G. Malis [mailto:[email-masked]]
Sent: Tuesday, November 03, 2015 1:24 PM
To: Shah, Himanshu
Cc: Ralph Droms (rdroms); A. Jean Mahoney; Alia Atlas <[email-masked]> ([email-masked]); General Area Review Team; [email-masked]; The IESG
Subject: Re: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd

Himanshu,

6.2.  Sequence Number TLV

Cheers,
Andy

On Tue, Nov 3, 2015 at 4:24 AM, Shah, Himanshu <[email-masked]<mailto:[email-masked]>> wrote:
Hi Ralph and Alia -

Thanks,
Himanshu

-----Original Message-----
From: Shah, Himanshu
Sent: Monday, October 26, 2015 7:05 PM
To: 'Ralph Droms (rdroms)'
Cc: Andrew G. Malis; A. Jean Mahoney; General Area Review Team; [email-masked]<mailto:[email-masked]>; The IESG
Subject: RE: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd

Hi Ralph -

Thanks,
Himanshu

-----Original Message-----
From: Ralph Droms (rdroms) [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, October 26, 2015 3:13 PM
To: Shah, Himanshu
Cc: Andrew G. Malis; A. Jean Mahoney; General Area Review Team; [email-masked]<mailto:[email-masked]>; The IESG
Subject: Re: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd

- Ralph

> On Oct 26, 2015, at 2:09 PM 10/26/15, Shah, Himanshu <[email-masked]<mailto:[email-masked]>> wrote:
>
> Thanks Andy.
> From: Andrew G. Malis [mailto:[email-masked]<mailto:[email-masked]>]
> [email-masked]<mailto:[email-masked]>; The IESG
> On Mon, Oct 26, 2015 at 1:04 PM, Shah, Himanshu <[email-masked]<mailto:[email-masked]>> wrote:
> From: Ralph Droms (rdroms) [mailto:[email-masked]<mailto:[email-masked]>]
> [email-masked]<mailto:[email-masked]>; The IESG

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 3 Nov 2015 14:20:34 +0900

Himansu,

Looks great to me, thanks.

Ralph and Alia,

Please review the updates.

Thanks,
Andy

On Tue, Nov 3, 2015 at 1:49 PM, Shah, Himanshu <[email-masked]> wrote:

> *Ok, I updated the section. Please review.*
>
>
>
> *Thanks,*
>
> *Himanshu*
>
>
>
> *From:* Andrew G. Malis [mailto:[email-masked]]
> *Sent:* Tuesday, November 03, 2015 1:24 PM
> *To:* Shah, Himanshu
> *Cc:* Ralph Droms (rdroms); A. Jean Mahoney; Alia Atlas <[email-masked]>
> ([email-masked]); General Area Review Team;
> *Subject:* Re: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd
>
>
>
> Himanshu,
>
>
>

---

From: Alia Atlas <[email-masked]>
Date: Tue, 3 Nov 2015 00:27:13 -0500

Himanshu,

This looks good to me.  Can you please submit the updated draft?

Regards,
Alia

---

From: "Shah, Himanshu" <[email-masked]>
Date: Tue, 3 Nov 2015 00:28:09 -0500

Perfect. I will post the draft.

Thanks,
Himanshu

From: Alia Atlas [mailto:[email-masked]]
Sent: Tuesday, November 03, 2015 2:27 PM
To: Shah, Himanshu
Cc: Ralph Droms (rdroms); Andrew G. Malis; A. Jean Mahoney; General Area Review Team; [email-masked]; The IESG
Subject: Re: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd

Himanshu,

Regards,
Alia

On Mon, Nov 2, 2015 at 2:24 PM, Shah, Himanshu <[email-masked]<mailto:[email-masked]>> wrote:
Hi Ralph and Alia -

Thanks,
Himanshu

-----Original Message-----
From: Shah, Himanshu
Sent: Monday, October 26, 2015 7:05 PM
To: 'Ralph Droms (rdroms)'
Cc: Andrew G. Malis; A. Jean Mahoney; General Area Review Team; [email-masked]<mailto:[email-masked]>; The IESG
Subject: RE: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd

Hi Ralph -

Thanks,
Himanshu

-----Original Message-----
From: Ralph Droms (rdroms) [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, October 26, 2015 3:13 PM
To: Shah, Himanshu
Cc: Andrew G. Malis; A. Jean Mahoney; General Area Review Team; [email-masked]<mailto:[email-masked]>; The IESG
Subject: Re: [Gen-art] Review: draft-ietf-pals-mpls-tp-mac-wd

- Ralph

> He did re-send the email without MIME and I was able to read and reply
>
> Thanks,
> Himanshu
>