Subject: [Gen-art] Gen-art LC/telechat review of draft-ietf-xrblock-rtcp-xr-video-lc-05

From: Elwyn Davies <[email-masked]>
Date: Mon, 14 Dec 2015 13:50:13 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair. Please wait for direction from your
document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-xrblock-rtcp-xr-video-lc-05
Reviewer: Elwyn Davies
Review Date: 2015/12/14
IETF LC End Date: 2015-12-04
IESG Telechat date: (if known) 2015-12-17

Summary: Ready with nits, primarily a number of acronyms needing expansion.

Major issues:
None

Minor issues:
None

Nits/editorial comments:
Abstract: Need to expand RTCP (to RTP Control Protocol) and XR (Extended 
Reports).

s1, para 2: Need to expand QoE.

s1.2: s/RTP Monitoring Architectures [RFC6792]/RTP Monitoring Framework 
[RFC6792]/

s1.3:
OLD
    These metrics are applicable to video applications the video
    component of Audio/Video applications using RTP and applying packet
    loss concealment mechanisms which are incorporated into the receiving
    endpoint to mitigate the impact of network impairments on QoE.
NEW:
    These metrics are applicable to video applications and the video
    component of Audio/Video applications using RTP that apply packet
    loss concealment mechanisms incorporated into the receiving
    endpoint to mitigate the impact of network impairments on QoE.
END

s1.3: Need to expand IPTV.

s3, item b: Need to expand IDR;
                    s/Using inter-frame extrapolation/Using the 
inter-frame extrapolation/

s3, item d: s/so that receiver/so that the receiver/

s3, last para: s/methods slightly different/methods to be slightly 
different/

s4, para 1: Need to expand SSRC.

s4, duration fields:  It would useful to insert a reference to the place 
where the RTP timestamp units are defined.

s7.1: should refer back to s4 for the definition of VLC.

s7.2: should refer back to s5 for the definition of video-loss-concealment.

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 21 Dec 2015 06:31:03 +0000

Hi Elwyn,

Thank you for the review. The nits will be fixed in the next version.

BR,
Rachel

> -----Original Message-----
> From: Elwyn Davies [mailto:[email-masked]]
> Sent: Monday, December 14, 2015 9:50 PM
> To: General area reviewing team; [email-masked]
> Subject: Gen-art LC/telechat review of draft-ietf-xrblock-rtcp-xr-video-lc-05
> 
> I am the assigned Gen-ART reviewer for this draft. The General Area Review
> Team (Gen-ART) reviews all IETF documents being processed by the IESG for
> the IETF Chair. Please wait for direction from your document shepherd or AD
> before posting a new version of the draft.
> 
> s3, last para: s/methods slightly different/methods to be slightly different/
> 
> s4, duration fields:  It would useful to insert a reference to the place where
> the RTP timestamp units are defined.
>