Subject: [Gen-art] Gem-Art review for draft-ietf-httpauth-scram-auth-14

From: "Ralph Droms (rdroms)" <[email-masked]>
Date: Wed, 9 Dec 2015 20:47:40 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-httpauth-scram-auth-14
Reviewer: Ralph Droms
Review Date: 2015-13-9
IETF LC End Date: 2015-12-16
IESG Telechat date: (if known)

Summary: This draft is ready for publication as an Experimental RFC.

Major issues: None.

Minor issues: None.

Nits/editorial comments:

Nicely written, very clear document.

idnits reports some lines too long and an unused reference.

In the third paragraph of the Introduction, I suggest removing the parentheses and editing the second sentence for clarity; specifically, what is "SCRAM data"?

You could probably omit the parentheses in the second paragraph of Setion 3, as well, I'm likely just arguing style.

The last sentence of the last paragraph of sectino 3 was unclear to me: which messages are referred to?

I think, in the phrase "fail the authentication" in the fifth paragraph of section 8, you are using "fail" as a transitive verb, as in "the client considers the authentication of the message to have failed".  If I have that write, I suggest rewriting the containing sentence to improve the clarity.

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 16 Dec 2015 15:47:39 +0000

Hi Ralph,
Thank you for your review. Sorry I missed it earlier.

> Nicely written, very clear document.
Thank you.
> idnits reports some lines too long and an unused reference.
I fixed the reference in my copy. I hope RFC Editor can help with lines 
which are too long.
> In the third paragraph of the Introduction, I suggest removing the parentheses and editing the second sentence for clarity; specifically, what is "SCRAM data"?
I meant SCRAM requests and responses.
> You could probably omit the parentheses in the second paragraph of Setion 3, as well, I'm likely just arguing style.
Barry picked on this as well, so this was rewritten for clarity.
> The last sentence of the last paragraph of sectino 3 was unclear to me: which messages are referred to?
Message is the same as 'decoded "data" attribute' in the previous 
sentence. I clarified that.
> I think, in the phrase "fail the authentication" in the fifth paragraph of section 8, you are using "fail" as a transitive verb, as in "the client considers the authentication of the message to have failed"
... and does whatever is appropriate in this case. Which might be 
closing the connection, retrying or trying another (non SCRAM) mechanism.
> .  If I have that write, I suggest rewriting the containing sentence to improve the clarity.

Best Regards,
Alexey

---

From: "Ralph Droms (rdroms)" <[email-masked]>
Date: Wed, 16 Dec 2015 16:19:31 +0000

> On Dec 16, 2015, at 10:47 AM 12/16/15, Alexey Melnikov <[email-masked]> wrote:
> 
> Hi Ralph,

You're welcome.  Looks like we have agreement on my editorial comments and suggestions.  Will the edits you mention below appear in rev -15?

- Ralph

> I fixed the reference in my copy. I hope RFC Editor can help with lines which are too long.
> Message is the same as 'decoded "data" attribute' in the previous sentence. I clarified that.
> ... and does whatever is appropriate in this case. Which might be closing the connection, retrying or trying another (non SCRAM) mechanism.

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 16 Dec 2015 16:36:23 +0000

Hi Ralph,

> You're welcome.  Looks like we have agreement on my editorial comments and suggestions.  Will the edits you mention below appear in rev -15?
Yes.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 17 Dec 2015 15:15:19 +0200

Alexey, Ralph: Thanks for the review & edits!

Jari

On 16 Dec 2015, at 18:36, Alexey Melnikov <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art