Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-kitten-cammac-04

From: Meral Shirazipour <[email-masked]>
Date: Wed, 2 Dec 2015 23:40:49 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

For more information, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-kitten-cammac-04
Reviewer: Meral Shirazipour
Review Date: 2015-12-02
IETF LC End Date:  2015-12-04 (2nd LC)
IESG Telechat date: 2015-12-17

Summary:
This draft is ready to be published as Standards Track RFC but I have some comments/nits.

Major issues:

Minor issues:

Nits/editorial comments:
[Page 3] 2nd and 3rd paragraph: The word "service" is used to designate both the proxy-service and the second backend "application-service" as per [MS-SFU]. This may confuse the reader at first read.
Suggestion would be to use "proxy-service" and "application-service". [Page 8] after point "2." would also benefit from clearer use of these terms.

[Page 8], last paragraph, it was not clear to me if  "service principal" is the "application service"?

Best Regards,
Meral
---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 2 Dec 2015 21:57:30 -0500 (EST)

Hi Meral,

Thank you for the review.

On Wed, 2 Dec 2015, Meral Shirazipour wrote:

> Nits/editorial comments:
>
> [Page 3] 2nd and 3rd paragraph: The word "service" is used to designate
> both the proxy-service and the second backend "application-service" as
> per [MS-SFU]. This may confuse the reader at first read.
> Suggestion would be to use "proxy-service" and "application-service".
> [Page 8] after point "2." would also benefit from clearer use of these
> terms.

>From the point of view of the Kerberos protocol, there is only one service
here, so I think it is appropriate to use only a single term.

> is the "application service"?

"service principal name" is the identifier used to represent the
application service within the Kerberos protocol, yes.

I am not sure if I should recommend that the authors make any changes to
reduce the potential for confusion.

-Ben Kaduk

---

From: Meral Shirazipour <[email-masked]>
Date: Thu, 3 Dec 2015 04:25:39 +0000

Hi Ben,
  Thank you for considering, I read it from the eyes of someone new to the document, and perhaps ref [MS-SFU] caused the doubts. I agree that for people following the work this is probably obvious:) Since it is a Standards document I think it will clarify a lot if the same term is used across the document; you are probably a better judge on that.

Best,
Meral

> -----Original Message-----
> From: Benjamin Kaduk [mailto:[email-masked]]
> Sent: Wednesday, December 02, 2015 6:57 PM
> To: Meral Shirazipour
> Cc: [email-masked]; [email-masked]; draft-ietf-
> [email-masked]
> Subject: Re: Gen-ART Last Call review of draft-ietf-kitten-cammac-04
> 
> Hi Meral,
> 
> > [Page 3] 2nd and 3rd paragraph: The word "service" is used to
> > designate both the proxy-service and the second backend
> > "application-service" as per [MS-SFU]. This may confuse the reader at first
> read.
> "service principal name" is the identifier used to represent the application
> service within the Kerberos protocol, yes.
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 17 Dec 2015 15:10:58 +0200

Thanks for your review, Meral. FWIW, I often find myself
struggling with “service” used in different contexts, but
I’ll defer to Benjamin on how well any changes would
fit in the Kerberos terminology and environment…

Jari

On 03 Dec 2015, at 06:25, Meral Shirazipour <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art