Subject: [Gen-art] Gen-ART Telechat Call review of draft-ietf-avtcore-multi-media-rtp-session-12

From: Meral Shirazipour <[email-masked]>
Date: Fri, 11 Dec 2015 19:14:57 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair. Please wait for direction from your document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq .

Document:  draft-ietf-avtcore-multi-media-rtp-session-12
Reviewer: Meral Shirazipour
Review Date: 2015-12-11
IETF LC End Date:  2015-12-09 (sorry for missed LC review-mistakenly reviewed some other draft)
IESG Telechat date: 2015-12-17

Summary:
This draft is ready to be published as Standards Track RFC but I have some comments.

Major issues:

Minor issues:

Nits/editorial comments:
-[Page 4], "Equal treatment of media" section.
While reading this paragraph the question comes to mind of if all media flows get 'best effort' only or if all media flows could get e.g. 'Gold treatment', or something in between...
It would be clearer to add a sentence to say how the treatment (QoS) is specified and applied to all flows.

-[Page 7], "This specifications purpose"----->"This specification's purpose"

-[Page 8], "It is important to note that the RTP payload type is never used to distinguish media streams."
It would be clearer to add this would be explained below. "As expalined below, ..."

-[Page 9], "form a independent"--->"form an independent"

-[Page 11], "that FEC stream use"---->"that FEC stream uses"

-[Page 11,
"(e.g., if an original RTP
   session contains audio and video flows, for the associated FEC RTP
   session where to use the "audio/ulpfec" and "video/ulpfec" payload
   formats)
"

This sentence may need revision, word "where" to be revised.

-[Page 11], "with a associated generic"---->"with an associated generic"

-[Page 11], ULP (uneven level protection) to spell out.

-[Page 12], "this requires each media type use" -----> "this requires each media type to use"

-[Page 14], some references are expired. Should they remain cited?
[I-D.ietf-avtcore-multiplex-guidelines],  [I-D.lennox-payload-ulp-ssrc-mux]

Best Regards,
Meral
---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: Jari Arkko <[email-masked]>
Date: Thu, 17 Dec 2015 14:48:25 +0200

Thank you very much for the review!

Authors, have you noted the comments & are taking action (if necessary)?

Jari

On 11 Dec 2015, at 21:14, Meral Shirazipour <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 17 Dec 2015 14:45:27 +0100

Thanks for the Review,

I see no problem of incorporating these editorial comments.

I think I have comments on two things, see inline.

Den 2015-12-11 kl. 20:14, skrev Meral Shirazipour:
> I am the assigned Gen-ART reviewer for this draft. The General Area
> Review Team (Gen-ART) reviews all IETF documents being processed by the
> IESG for the IETF Chair. Please wait for direction from your document
> shepherd or AD before posting a new version of the draft.
>
> For more information, please see the FAQ at
> http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq .
>
> While reading this paragraph the question comes to mind of if all media
> flows get 'best effort' only or if all media flows could get e.g. 'Gold
> treatment', or something in between...

Per default all RTP streams and RTCP gets the same treatment. Flow-based 
QoS mechanisms will result that all RTP streams sent over that transport 
flow ends up being equally treated. RTP sessions are normally defined as 
the RTP streams received on one or more transport flow and the traffic 
sent in the same RTP session content, and thus another set of transport 
flows for outgoing RTP and RTCP.

RFC7657 do discuss RTP and Diffserv, there are some limitations.

> specified and applied to all flows.

The problem is that this is not a single sentence. That is why we 
reference the multiplexing guidelines document that was intended to 
provide guidance on this among other things.

> [I-D.ietf-avtcore-multiplex-guidelines],

Yes, this document should be revived by next IETF meeting.

   [I-D.lennox-payload-ulp-ssrc-mux]

This, is more uncertain if it will be completed, but the possibilites 
still exist. Maybe we rather should add another sentence and reference:

https://datatracker.ietf.org/doc/draft-ietf-payload-flexible-fec-scheme/

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------