Subject: [Gen-art] Gen-ART Review of draft-ietf-bfd-seamless-ip-03

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 29 Mar 2016 11:40:08 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

For more information, please see the FAQ at

< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq >.

Document: draft-ietf-bfd-seamless-ip-03

Reviewer: Dan Romascanu

Review Date: 2016/3/29

IETF LC End Date: 2016/4/12

IESG Telechat date: 2016/5/5

Summary: Ready with minor issues

The document is well written and complete, but requires a good understanding of BFD (RFC 5880, RFC 5881) and of the use-cases (draft-ietf-bfd-seamless-use-case) document. A few minor issues are listed below, it would be good to address them, but none is a show-stopper.

Major issues:

Minor issues:

1.       This document extends the usage of port 3785 adding the function of being the destination port for the S-BFD echo packets. Should not this be regarded as an update of RFC 5881 and mentioned as such on the front page?

2.       In the IANA considerations section - when this I-D is approved and becomes an RFC, should not the Reference (REQUIRED) become this RFC - a more stable reference that the draft-akiya-bfd-seamless-ip?

Nits/editorial comments:

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 29 Mar 2016 14:54:06 +0000

Dan,

Many thanks for this review!

You raise two good questions, here’s my take:
I do not have a strong opinion one way or another — I will leave this one to the AD’s guidance, and I am happy to mark this document as updating RFC 5881 if that’s the preferred direction.
Indeed — fixed in our working copy.

Thanks again,

— Carlos.

> On Mar 29, 2016, at 7:40 AM, Romascanu, Dan (Dan) <[email-masked]> wrote:
> 
> < http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq> >.
> 
> 2.       In the IANA considerations section – when this I-D is approved and becomes an RFC, should not the Reference (REQUIRED) become this RFC – a more stable reference that the draft-akiya-bfd-seamless-ip?
> 
> Nits/editorial comments: