Subject: Re: [Gen-art] Gen-art LC review of draft-ietf-aqm-fq-codel-05

From: Elwyn Davies <[email-masked]>
Date: Mon, 14 Mar 2016 21:19:54 +0000

Hi, Toke.
I had a look through the updated draft and I think it addresses all the issues and editorials that i identified in my LC review.  Adding the comments on the state diagram is probably OK.  I won't push the idea of capitalising quantum etc. any further.
In the light of Brian C's note and his exchange with Dave about labels, I think Dave might add a few words about using the label as a classification mechanism.   
I don't know if you have had any other comments - check with Martin whether he wants you to publish the updated version before the end of last call since it is the day of the IESG meeting.
Thanks,Elwyn 

Sent from Samsung tablet.-------- Original message --------From: Toke Høiland-Jørgensen <[email-masked]> Date: 13/03/2016  12:19  (GMT+00:00) To: Elwyn Davies <[email-masked]> Cc: General area reviewing team <[email-masked]>, 	[email-masked] Subject: Re: Gen-art LC review of draft-ietf-aqm-fq-codel-05 
Hi Elwyn

I have now been through your comments and produced an updated version of
the draft. It is available from here:
https://kau.toke.dk/ietf/draft-ietf-aqm-fq-codel-06.html (or .txt if you
prefer).

Most of your comments I have just incorporated (variants of), with a
single stylistic exception as noted below. I *think* I managed to cover
everything, but I did this in two sittings, so something may have
slipped through the cracks, I suppose. Let me know if that is the case.

I believe Dave has replied to most of your other comments, so I won't go
through them again unless you point out something I missed. For the full
diff (of the source document), see here:
https://github.com/dtaht/bufferbloat-rfcs/commit/0d7f1963cc27d11129bcb5fe2affb90ebc6e67d3

Cheers,

-Toke

Elwyn Davies <[email-masked]> writes:

> General: It would be helpful to capitalize Quantum throughout (or at
> least from s3 onwards) to emphasise that it is a configured value.
> Likewise Interval and Target parameters. Maybe also Flow and Queue as
> they a defined terms.

I think this is the only stylistic change I haven't made. I thought it
made it more difficult to read, not less.

---

From: Dave Taht <[email-masked]>
Date: Mon, 14 Mar 2016 14:49:19 -0700

There are presently some issues in the html version with the "s

And I vastly preferred that we linked to to public, and much longer
version fo Paul's paper on SFQ, rather than the short one behind the
IEEE paywall, as is now here:

s ] McKenney, P., "Stochastic fairness queueing", in Proceedings. IEEE
INFOCOM ’90, DOI http://dx.doi.org/10.1109/INFCOM.1990.91316, 1990.

http://www2.rdrop.com/~paulmck/scalability/paper/sfq.2002.06.04.pdf

How do we go about citing that rather than the infocom one?

Dave Täht
Let's go make home routers and wifi faster! With better software!
https://www.gofundme.com/savewifi

On Mon, Mar 14, 2016 at 2:19 PM, Elwyn Davies <[email-masked]> wrote:
> Hi, Toke.
>
> I had a look through the updated draft and I think it addresses all the
> issues and editorials that i identified in my LC review.  Adding the
> comments on the state diagram is probably OK.  I won't push the idea of
> capitalising quantum etc. any further.
>
> In the light of Brian C's note and his exchange with Dave about labels, I
> think Dave might add a few words about using the label as a classification
> mechanism.
>
> I don't know if you have had any other comments - check with Martin whether
> he wants you to publish the updated version before the end of last call
> since it is the day of the IESG meeting.
>
> Thanks,
> Elwyn
>
>
>
> Sent from Samsung tablet.
> -------- Original message --------
> From: Toke Høiland-Jørgensen <[email-masked]>
> Date: 13/03/2016 12:19 (GMT+00:00)
> To: Elwyn Davies <[email-masked]>
> Cc: General area reviewing team <[email-masked]>,
> [email-masked]
> Subject: Re: Gen-art LC review of draft-ietf-aqm-fq-codel-05
>
> Hi Elwyn
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 17 Mar 2016 09:10:28 +0000

> I don't know if you have had any other comments - check with Martin whether he wants you to publish the updated version before the end of last call since it is the day of the IESG meeting.

Elwyn,

Many thanks for your (once again!) in-depth and useful review. I think we’ve progressed far enough that I’m confident I can ballot no-objection for this draft.

Thanks, all.

Jari