Subject: Re: [Gen-art] Gen-ART Last Call review of draft-ietf-p2psip-sip-17

From: "Thomas C. Schmidt" <[email-masked]>
Date: Thu, 7 Apr 2016 16:50:31 -0300

Dear Meral,

many thanks for your review. Please see comments inline.

On 06.04.2016 21:38, Meral Shirazipour wrote:
> I am the assigned Gen-ART reviewer for this draft. The General Area
> Review Team (Gen-ART) reviews all IETF documents being processed by the
> IESG for the IETF Chair.  Please treat these comments just like any
> other last call comments.
>
> For more information, please see the FAQ at
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
>
> Document:  draft-ietf-p2psip-sip-17
>
> Reviewer: Meral Shirazipour
>
> Review Date: 2016-04-06
>
> IETF LC End Date:  2016-04-06
>
> IESG Telechat date: 2016-04-21
>
> Summary:
>
> This draft is ready to be published as Standards Track RFC but I have
> some comments.
>
> Major issues:
>
> Minor issues:
>
> Nits/editorial comments:
>
> -[Page 1] Abstract: some suggestions for clarity:
>
> -After "(RELOAD)" it would be clearer to add [rfc6940].

This is a matter of style, I suppose: In the old school, we were told 
not to place refs in an abstract ;) Reload is referenced in the first 
sentence of the intro.

> -"Uris"---->"URIs"

Thanks, fixed.

> -"the AppAttach method"---->"the RELOAD AppAttach method"
>

Thanks, fixed.

> I find the first paragraph of the Introduction more suitable for
> abstract text.
>
> The abstract should clarify which protocols are being extended here SIP,
> RELOAD, both.
>

Actually, the first sentence of the abstract reads

  "This document defines a SIP Usage for REsource LOcation And Discovery 
(RELOAD)."

This is exactly what this document does: It extends RELOAD by a new 
Usage (an application-specific extension in the language of RELOAD). It 
does nothing to SIP and does not claim to do so.

> -[Page 4], "ICE" to be spelled out at first use.

Thanks, fixed.
>
> -[Page 7], "PDU" to be spelled out at first use.
>
> -[Page 12], "either SIP scheme"--->"either SIP schemes"
>
Thanks, fixed.

> -[Page 13], "Uris"---->"URIs"
>

Thanks, fixed.

> -[Page 13], "gr URI"--->"  "gr" URI  "
>

Thanks, changed.

> -[Page 18], ietf-p2psip-share ref to be updated to latest
>

Yes, will be automatic.

Thanks again, we will submit a sanitized version asap.

Best,
  Thomas

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °

---

From: Meral Shirazipour <[email-masked]>
Date: Thu, 7 Apr 2016 20:34:03 +0000

Hi,
  Thank you Thomas for considering the changes. 
Only point, at first read it was not clear in abstract that only RELOAD was being extended (from a general reader perspective), although the Intro clarifies this.

Best,
Meral

> -----Original Message-----
> From: Thomas C. Schmidt [mailto:[email-masked]]
> Sent: Thursday, April 07, 2016 12:51 PM
> To: Meral Shirazipour; [email-masked]; [email-masked]
> Subject: Re: Gen-ART Last Call review of draft-ietf-p2psip-sip-17
> 
> Dear Meral,
> 
> > Review Team (Gen-ART) reviews all IETF documents being processed by
> > the IESG for the IETF Chair.  Please treat these comments just like
> > any other last call comments.
> >
> This is a matter of style, I suppose: In the old school, we were told not to
> place refs in an abstract ;) Reload is referenced in the first sentence of the
> intro.
> 
> >
> > -"Uris"---->"URIs"
> >
> 
> Thanks, fixed.
>