Subject: Re: [Gen-art] GenArt LC review: draft-ietf-tsvwg-rtcweb-qos-15

From: Robert Sparks <[email-masked]>
Date: Thu, 21 Apr 2016 15:32:44 -0500

(Trimming the distribution to just gen-art, Spencer, and David)

This document is in a 2nd last call to point out a couple of downrefs, 
and is otherwise unchanged.

I have no problem with the downrefs (see 
https://datatracker.ietf.org/doc/draft-ietf-tsvwg-rtcweb-qos/shepherdwriteup/).

I have nothing else to add to the review below.

RjS

On 3/31/16 11:39 AM, Robert Sparks wrote:
> I am the assigned Gen-ART reviewer for this draft. The General Area
> Review Team (Gen-ART) reviews all IETF documents being processed
> by the IESG for the IETF Chair.  Please treat these comments just
> like any other last call comments.
>
> For more information, please see the FAQ at
>
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
>
> Document: draft-ietf-tsvwg-rtcweb-qos-15
> Reviewer: Robert Sparks
> Review Date: 31Mar2016
> IETF LC End Date: 18Apr2016
> IESG Telechat date: Not yet scheduled for a telechat
>
> Summary: Ready for publication as PS with nits
>
> Nits/editorial comments:
>
> These are very small editorial suggestions:
>
> The introduction says "seldom makes things worse".
> Section 5 says "This is one of the cases ... can make things worse."
> There are no other cases called out, leaving the implementer to guess 
> at what the other pitfalls are.
>
> It would be better to tweak that text to be less vague. I suggest 
> changing the introduction to say "there is one case this draft 
> discusses. Other cases may possibly exist, but are expected to be 
> rare" or similar.
>
> The sentence "These code points are solely defaults." in the 
> introduction is terse, and I suspect it won't translate well. Consider 
> calling out what the consequences of that statement are more simply, 
> even if it takes more words.
>
> (Note that there is a thread between Magnus and Cullen on the tsvwg 
> list that is resolving, but is not yet completely settled.)

---

From: "Black, David" <[email-masked]>
Date: Thu, 21 Apr 2016 20:48:48 +0000

Robert,
[+Gorry as the other tsvwg chair ]

> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-rtcweb-

I'm pleased that the writeup paragraph on those downrefs provided sufficient
explanation.

> > list that is resolving, but is not yet completely settled.)

That thread is now resolved to the point that there is agreed text for both issues
that it covers, with the draft authors on the hook to provide a suitable Web RTC
reference for one of the sentences to be added.

Thanks, --David

> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]]
> Sent: Thursday, April 21, 2016 4:33 PM
> To: General Area Review Team; Spencer Dawkins; Black, David
> Subject: Re: GenArt LC review: draft-ietf-tsvwg-rtcweb-qos-15
>