Subject: Re: [Gen-art] OPS-DIR review of draft-ietf-cdni-footprint-capabilities-semantics-12

From: Jari Arkko <[email-masked]>
Date: Thu, 21 Apr 2016 07:11:52 +0200

Thanks for your review, Jouni!

Jari

On 27 Mar 2016, at 04:47, Jouni <[email-masked]> wrote:

> 
> Hi Kevin,
> 
> Ok. That’s fine then (probably the mailstones needs to be updated to reflect that decision). I just noticed I sent the review to ops-dir instead of gen-art.. ;-) Now replying to the right list.
> 
> - Jouni
> 
> 
>> On 26 Mar 2016, at 19:37, Kevin Ma J <[email-masked]> wrote:
>> 
>> Hi Jouni,
>> 
>> Thank you for the review.  I agree with all your comments and will address them in the next version, once submissions reopen.
>> 
>> With respect to your question:
>> 
>>> o Why this to-be-RFC is under Informational and not Standard Track? The
>>> charter says: "Dec 2016 - Submit specification of the CDNI Footprint &
>>> Capabilities Advertisement interface to IESG as Proposed Standard"
>> 
>> This draft does not specify the actual protocol, only the semantics and requirements for the protocol.  There are two additional drafts to follow, with the actual protocol specification.  Based on discussion with our AD, it was decided that this draft should stay Informational.
>> 
>> thanx!
>> 
>> --  Kevin J. Ma
>> 
>> 
>>> -----Original Message-----
>>> From: Jouni [mailto:[email-masked]]
>>> Sent: Saturday, March 26, 2016 10:27 PM
>>> To: [email-masked]; draft-ietf-cdni-footprint-capabilities-
>>> [email-masked]
>>> Cc: Jouni
>>> Subject: OPS-DIR review of draft-ietf-cdni-footprint-capabilities-
>>> semantics-12
>>> 
>>> I am the assigned Gen-ART reviewer for this draft (draft-ietf-cdni-
>>> footprint-capabilities-semantics-12). The General Area Review Team (Gen-
>>> ART) reviews all IETF documents being processed by the IESG for the IETF
>>> Chair. Please wait for direction from your document shepherd or AD before
>>> posting a new version of the draft. For more information, please see the
>>> FAQ at <​http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
>>> 
>>> This draft is ready for publication as a Informational RFC with some tiny
>>> nits. As I am no expert on CDNI my comments are not much on the substance
>>> of the technical side of this draft. I did not spot any inconsistencies,
>>> though.
>>> 
>>> IDnits:
>>> o The comments that IDnits give will be automatically fixed when a new
>>> revision of this document is provided.
>>> 
>>> Other comments:
>>> o term ‘dCDN’ is never introduced properly like it was done in a case of
>>> ‘uCDN’.
>>> o Line 139 mentions “.., the RFC says..” without giving the RFC number.
>>> This paragraph is under the context of RFC6707 but I would still say in
>>> explicitly.
>>> o Lines 271-272 and 522-523 refer to CDNI charter for reasons why
>>> something is not done. I would not recommend referencing against the
>>> existing charter as the charter is bound to change and then such
>>> references either lose their importance or make it hard to track the
>>> specific charter the text that was in effect that time.
>>> o RTMP is never expanded or referenced.
>>> o Why this to-be-RFC is under Informational and not Standard Track? The
>>> charter says: "Dec 2016 - Submit specification of the CDNI Footprint &
>>> Capabilities Advertisement interface to IESG as Proposed Standard"
>>> 
>>> - Jouni
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Kevin Ma J <[email-masked]>
Date: Sat, 23 Apr 2016 17:13:53 +0000

Hi Jouni,

  Just wanted to let you know that the ADs also felt the draft needed to be Standards Track, so the we have updated the draft.

thanx!

--  Kevin J. Ma

> Sent: Saturday, March 26, 2016 10:48 PM
> To: Kevin Ma J
> Cc: [email-masked] ([email-masked]); draft-ietf-cdni-footprint-
> [email-masked]
> Subject: Re: OPS-DIR review of draft-ietf-cdni-footprint-capabilities-
> semantics-12
> 
> 
> Hi Kevin,
> 
> Ok. That’s fine then (probably the mailstones needs to be updated to
> reflect that decision). I just noticed I sent the review to ops-dir
> instead of gen-art.. ;-) Now replying to the right list.
> 
> - Jouni
> 
> 
> >  Thank you for the review.  I agree with all your comments and will
> address them in the next version, once submissions reopen.
> >
> >  This draft does not specify the actual protocol, only the semantics and
> requirements for the protocol.  There are two additional drafts to follow,
> with the actual protocol specification.  Based on discussion with our AD,
> it was decided that this draft should stay Informational.
> >
> > thanx!
> >
> > --  Kevin J. Ma
> >
> >