Subject: [Gen-art] Gen-ART Telechat Call review of draft-ietf-geojson-03

From: Meral Shirazipour <[email-masked]>
Date: Wed, 1 Jun 2016 22:51:47 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair. Please wait for direction from your document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-geojson-03
Reviewer: Meral Shirazipour
Review Date: 2016-06-01
IETF LC End Date: 2016-05-31
IESG Telechat date: 2016-06-02

Summary: This draft is ready to be published as Standards Track RFC, but I have some comments.

Major issues:

Minor issues:

Nits/editorial comments:
-[Page 3], "any thing"--typo-->"anything"

-[Page 4], KML not spelled out at first use (Keyhole Markup Language?)

-[Page 11],PIDF-LO, please spell out at first use and maybe reference RFC5139.

-[Page 11], it says
"Applications such as PIDF-LO that are sensitive to location
   uncertainty and confidence might treat ...
"
Not clear: if this is not an OK behavior, it should say "should not treat..."? If this is an ok behavior, maybe it should say "MAY treat ..."

-[Page 12], "in the the case"---typo-->"in the case"

-[Page 12], "the OGC's "http://www.opengis.net/def/crs/OGC/1.3/CRS84" [OGCURL]. "
Should the URL  be moved to reference section?

-[Page 13], "or to to have"--typo-->"or to have"

-[Page 16], "the the semantics"--typo-->"the semantics"

-[Page 18], "can not be"---->"cannot be"

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research
www.ericsson.com

---

From: Tim Schaub <[email-masked]>
Date: Thu, 2 Jun 2016 00:07:55 -0700

Thanks for the comments Meral.  I've proposed
https://github.com/geojson/draft-geojson/pull/208 to incorporate them.
Responses below ...

On Wed, Jun 1, 2016 at 3:51 PM, Meral Shirazipour
<[email-masked]> wrote:

...

> -[Page 3], "any thing"--typo-->"anything"

I *think* the original text was meant to emphasize "thing", but it
ends up sounding awkward to me.  I think we should go with "anything"
if others agree.

> -[Page 4], KML not spelled out at first use (Keyhole Markup Language?)

Done.

> -[Page 11],PIDF-LO, please spell out at first use and maybe reference

Done.  But see below ...

> Not clear: if this is not an OK behavior, it should say "should not
> treat..."? If this is an ok behavior, maybe it should say "MAY treat ..."

I agree that this paragraph might add confusion.  I think the section
on Uncertainty and Confidence would be clearer if the whole paragraph
were removed.

> -[Page 12], "in the the case"---typo-->"in the case"

Good catch.  There were three of these.

> Should the URL  be moved to reference section?

Since http://www.opengis.net/def/crs/OGC/1.3/CRS84 is a URN, I don't
think it makes sense to include in the reference section.  It would be
nice if it resolved to something useful so it could serve as a
reference though.

> -[Page 13], "or to to have"--typo-->"or to have"

Changed.

> -[Page 16], "the the semantics"--typo-->"the semantics"

Also changed.

> -[Page 18], "can not be"---->"cannot be"

Done.

Tim

---

From: Tim Schaub <[email-masked]>
Date: Thu, 2 Jun 2016 00:22:33 -0700

Bad response on my part about the OGC URN.

Does anyone know if http://www.opengis.net/def/crs/OGC/1.3/CRS84 is
supposed to resolve to something other than an ogc:ExceptionReport
(I'm seeing Failed resolving http://www.opengis.netcrs/OGC/1.3/CRS84)?

Should we go back to the urn:ogc:def:crs:OGC::CRS84 URN?  Or maybe
remove this sentence altogether?

Tim

---

From: Jari Arkko <[email-masked]>
Date: Thu, 2 Jun 2016 14:59:02 +0300

Meral, Tim — thanks for the reviews and updates.

I don’t have a comment on OGC URN, but I assume that you guys have a token on figuring out what the right answer is here…

Jari

On 02 Jun 2016, at 10:22, Tim Schaub <[email-masked]> wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Meral Shirazipour <[email-masked]>
Date: Thu, 2 Jun 2016 16:31:56 +0000

Hi,
  Thank you.

Best,
Meral

> -----Original Message-----
> From: Tim Schaub [mailto:[email-masked]]
> Sent: Thursday, June 02, 2016 12:08 AM
> To: Meral Shirazipour
> Cc: [email-masked]; [email-masked]
> Subject: Re: Gen-ART Telechat Call review of draft-ietf-geojson-03
> 
> I *think* the original text was meant to emphasize "thing", but it ends up
> sounding awkward to me.  I think we should go with "anything"
> if others agree.
> 
> I agree that this paragraph might add confusion.  I think the section on
> Uncertainty and Confidence would be clearer if the whole paragraph were
> removed.
> 
> Since http://www.opengis.net/def/crs/OGC/1.3/CRS84 is a URN, I don't think it
> makes sense to include in the reference section.  It would be nice if it resolved to
> something useful so it could serve as a reference though.
>