Subject: [Gen-art] Gen-ART LC review for draft-ietf-calext-extensions-03

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 21 Jun 2016 11:48:14 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

For more information, please see the FAQ at

< https://trac.tools.ietf.org/area/gen/trac/wiki/GenArtfaq <https://urldefense.proofpoint.com/v2/url?u=http-3A__wiki.tools.ietf.org_area_gen_trac_wiki_GenArtfaq&d=CwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=azY-8O9zKU_qyQsIatC9huyRk-QxiYF2J3tY-yt8SWE&s=Lejj6aBY4lSWw3Rk7wGB75sQItp6gprPZgz3nBBp4-c&e=%20> >.

Document: draft-ietf-calext-extensions-03

Reviewer: Dan Romascanu

Review Date: 6/21/16

IETF LC End Date: 6/22/16

IESG Telechat date: 7/7/16

Summary: A clear document, almost ready from the Gen-ART point of view. I recommend to clarify the two minor issues below before approval.

Major issues:

Minor issues:

1.       Should not this document be marked as 'Updates RFC 5545'? The document recommends that all properties not defined in 5545 always include a "VALUE" parameter if the type is other than "TEXT" It also modifies some existing properties and defines new properties and elements that bring into the standard extension elements added by vendors into their specification.

2.       I had a hard time understanding some of the details in 5.7 (REFRESH-INTERVAL Property). These may be however due to my lack of familiarity with the style of iCal definitions and notations - so only explanations may be sufficient. First I do not understand what is covered under Property Parameters: what means 'IANA and non-standard property parameters' that can be defined here - and why here? Maybe an example would help. Second in the format definition: dur-value ... consisting of a positive duration of time - should not units be specified here as well? Last, I did not understand VALUE=DURATION:P1W - maybe it's just me missing the notation

Nits/editorial comments:

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 21 Jun 2016 14:00:31 +0100

Hi Dan,

Thank you for your review.

On 21/06/2016 12:48, Romascanu, Dan (Dan) wrote:
>
> I am the assigned Gen-ART reviewer for this draft. The General Area 
> Review Team (Gen-ART) reviews all IETF documents being processed by 
> the IESG for the IETF Chair.  Please treat these comments just like 
> any other last call comments.
>
> <https://trac.tools.ietf.org/area/gen/trac/wiki/GenArtfaq 
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__wiki.tools.ietf.org_area_gen_trac_wiki_GenArtfaq&d=CwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=azY-8O9zKU_qyQsIatC9huyRk-QxiYF2J3tY-yt8SWE&s=Lejj6aBY4lSWw3Rk7wGB75sQItp6gprPZgz3nBBp4-c&e=%20>>.
>
> Summary: A clear document, almost ready from the Gen-ART point of 
> view. I recommend to clarify the two minor issues below before approval.
>
> Major issues:
>
> Minor issues:
>
> 1.Should not this document be marked as ‘Updates RFC 5545’? The 
> document recommends that all properties not defined in 5545 always 
> include a “VALUE” parameter if the type is other than “TEXT” It also 
> modifies some existing properties and defines new properties and 
> elements that bring into the standard extension elements added by 
> vendors into their specification.
>
This is a good question. Cyrus?
>
> 2.I had a hard time understanding some of the details in 5.7 
> (REFRESH-INTERVAL Property). These may be however due to my lack of 
> familiarity with the style of iCal definitions and notations – so only 
> explanations may be sufficient. First I do not understand what is 
> covered under Property Parameters: what means ‘IANA and non-standard 
> property parameters’
>
These are defined in RFC 5545. There is some text and ABNF covering 
these. Basically these property parameters are for extensibility.
>
> that can be defined here – and why here? Maybe an example would help. 
> Second in the format definition: dur-value … consisting of a positive 
> duration of time – should not units be specified here as well? Last, I 
> did not understand VALUE=DURATION:P1W – maybe it’s just me missing the 
> notation
>
I think both of these are defined in RFC 5545.

Best Regards,
Alexey

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 21 Jun 2016 13:08:17 +0000

Hi Alexey - thanks for the quick response. I found answers to issues 2-3 in RFC 5545 indeed.

Issue 1 would still deserve clarification, although I do not consider it a show-stopper.

Regards,

Dan

From: Alexey Melnikov [mailto:[email-masked]]
Sent: Tuesday, June 21, 2016 4:01 PM
To: Romascanu, Dan (Dan); General Area Review Team
Cc: [email-masked]
Subject: Re: [Gen-art] Gen-ART LC review for draft-ietf-calext-extensions-03

Hi Dan,

Reviewer: Dan Romascanu

Review Date: 6/21/16

Major issues:

Minor issues:

2.       I had a hard time understanding some of the details in 5.7 (REFRESH-INTERVAL Property). These may be however due to my lack of familiarity with the style of iCal definitions and notations - so only explanations may be sufficient. First I do not understand what is covered under Property Parameters: what means 'IANA and non-standard property parameters'
These are defined in RFC 5545. There is some text and ABNF covering these. Basically these property parameters are for extensibility.

3.       that can be defined here - and why here? Maybe an example would help. Second in the format definition: dur-value ... consisting of a positive duration of time - should not units be specified here as well? Last, I did not understand VALUE=DURATION:P1W - maybe it's just me missing the notation
I think both of these are defined in RFC 5545.

Best Regards,
Alexey

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 22 Jun 2016 13:12:30 -0400

Hi Dan,
Thank you for your review. Fixes described below have been made to my 
working copy and will be included in the next published draft.

Just addressing your first point, as follow-up with Alexey appears to have 
clarified the rest.

--On June 21, 2016 at 11:48:14 AM +0000 "Romascanu, Dan (Dan)" 
<[email-masked]> wrote:

> 1.       Should not this document be marked as 'Updates RFC 5545'? The
> include a "VALUE" parameter if the type is other than "TEXT" It also
> modifies some existing properties and defines new properties and elements
> that bring into the standard extension elements added by vendors into
> their specification.

Yes you are right, this does need to "Update" 5545. I will fix that.

-- 
Cyrus Daboo