Subject: Re: [Gen-art] Gen-ART Review of draft-ietf-forces-interfelfb-04

From: Jari Arkko <[email-masked]>
Date: Wed, 1 Jun 2016 10:23:47 +0300

Thanks for your review, Russ. Again!

Authors, any comments?

Jari

On 31 May 2016, at 21:54, Russ Housley <[email-masked]> wrote:

> I am the assigned Gen-ART reviewer for this draft. The General Area
> Review Team (Gen-ART) reviews all IETF documents being processed
> by the IESG for the IETF Chair. Please wait for direction from your
> document shepherd or AD before posting a new version of the draft.
> 
> For more information, please see the FAQ at
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> 
> Document: draft-ietf-forces-interfelfb-04
> Reviewer: Russ Housley
> Review Date: 2016-05-31
> IETF LC End Date: 2016-06-22
> IESG Telechat date: unknown
> 
> Summary:  Almost Ready
> 
> 
> Major Concerns:
> 
> In Section 5.2, the document says:
> 
>   o  The Ethernet type is used to identify the frame as inter-FE LFB
>      type.  Ethertype 0xFEFE is to be used (XXX: Note to editor, likely
>      we wont get that value - update when available).
> 
> There is a process for getting an ethertype assigned.  It is handled by
> the IESG.  Please see: http://www.ietf.org/iesg/statement/ethertypes.html
> 
> 
> Minor Concerns:
> 
> In Section 1.2: s/document reiterates the terminology defined/
>                 /document depends on the terminology defined/
> 
> In Section 2: s/The current ForCES model/The ForCES model/
> 
> 
> Nits:
> 
> Many places: s/IPV4/IPv4/
> 
> In Section 2: s/architecture calls out for/architecture calls for/
> 
> In Section 3.1, why are the paragraphs in bullets?  They see to work
> just fine as normal paragraphs.
> 
> In Section 5.2: s/header illustrated in Figure 6)/
>                 /header (illustrated in Figure 6)
> 
>

---

From: Jamal Hadi Salim <[email-masked]>
Date: Wed, 1 Jun 2016 06:40:30 -0400

Hi Russ,
You review is appreciated. Comments/responses below.

> the IESG.  Please see: http://www.ietf.org/iesg/statement/ethertypes.html

Indeed we are following that process. New (unpublished) text refers
to the ethertype as TBA1.

>                  /document depends on the terminology defined/
Fixed.

> In Section 2: s/The current ForCES model/The ForCES model/
Fixed.

> Many places: s/IPV4/IPv4/
Fixed.

> In Section 2: s/architecture calls out for/architecture calls for/
Fixed.

> In Section 3.1, why are the paragraphs in bullets?

They see to work
> just fine as normal paragraphs.
The assumptions are intended to stand out. I am struggling with
how to achieve that without enumerating them as in the doc.
Perhaps getting rid of that section and making it flow into the main
introductory text would be better? i.e something like:
"We make two fundamental assumptions ...:"
Then the two bullets follow.

>                  /header (illustrated in Figure 6)

Fixed.

Thanks again Russ.

cheers,
jamal