Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-clue-datachannel-13

From: Brian E Carpenter <[email-masked]>
Date: Thu, 28 Jul 2016 11:39:14 +1200

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-clue-datachannel-13.txt
Reviewer: Brian Carpenter
Review Date: 2016-07-28
IETF LC End Date: 2016-08-01
IESG Telechat date:

Summary: Ready
--------

Minor issues:
-------------

Mainly for my own education:

3.2.6.  SCTP Multihoming

   SCTP multi-homing is not supported for SCTPoDTLS associations, and
   can therefore not be used for a CLUE data channel.

What is the advantage of SCTP if you don't get the benefit of multihoming?

Nits:
-----

I expected a reference to draft-ietf-clue-protocol where CLUE is first mentioned
in the Introduction.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 28 Jul 2016 14:50:32 +0000

Hi Brian,

Thanks for your review! I am currently on vacation, but I'll get back to you no later than in a couple if weeks.

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Brian E Carpenter<mailto:[email-masked]>
Sent: ‎28/‎07/‎2016 02:39
To: [email-masked]<mailto:[email-masked]>; General Area Review Team<mailto:[email-masked]>
Subject: Gen-ART Last Call review of draft-ietf-clue-datachannel-13

Summary: Ready
--------

Minor issues:
-------------

3.2.6.  SCTP Multihoming

Nits:
-----

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 28 Jul 2016 11:03:02 -0400

> IETF LC End Date: 2016-08-01

CLUE's needs are modest in regards to transporting the clue messaging. 
(E.g., TCP would be sufficient.) We chose data channels because that 
provides the possibility of straightforward interoperation with Webrtc. 
It also makes possible the use of the m-line bundle mechanism.

	Thanks,
	Paul