Subject: Re: [Gen-art] Gen-ART review of draft-pal-eidr-urn-2016-01

From: Pierre-Anthony Lemieux <[email-masked]>
Date: Sat, 2 Jul 2016 13:30:34 -0700

Hi Vijay,

I appreciate the review and comment.

> That is, are the schemes (urn, eidr) part of the case-insensitive string match?

Yes, it looks like

"Lexical equivalence of EIDR-URN is defined by case-insensitive string match."

should say

"Lexical equivalence of URN-EIDR is defined by case-insensitive string match."

This would confirm that the entire URN-EIDR string defined in
"Declaration of syntactic structure" is considered for matching,
including "urn:eidr:".

In fact, it looks like all instances of "EIDR-URN" should be replaced
by "URN-EIDR" [ed.: this was missed in the original publication].

Does this make sense?

Best,

-- Pierre

On Thu, Jun 9, 2016 at 3:01 PM, Vijay K. Gurbani <[email-masked]> wrote:
> I am the assigned Gen-ART reviewer for this draft. For background on
> Gen-ART, please see the FAQ at
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
>
> Please resolve these comments along with any other Last Call comments
> you may receive.
>
> Document: draft-pal-eidr-urn-2016-01
> Reviewer: Vijay K. Gurbani
> Review Date: Jun-09-2016
> IETF LC End Date: Jul-01-2016
> IESG Telechat date: Jun-30-2016
>
> This document is ready as an Informational.
>
> Major: 0
> Minor: 1
> Nits: 0
>
> Minor:
>
> - S2, Rules for Lexical Equivalence.  I think some more guidance should
>  be provided here.  Specifically, are the following two EIDRs the same?
>
>   urn:eidr:10.5240:7791-8534-2C23-9030-8610-5
>   10.5240:7791-8534-2C23-9030-8610-5
>
>  That is, are the schemes (urn, eidr) part of the case-insensitive
>  string match?
>
> Thanks,
>
> - vijay
> --
> Vijay K. Gurbani, Bell Laboratories, Nokia Networks
> 1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
> Email: vkg@{bell-labs.com,acm.org} / [email-masked]
> Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 5 Jul 2016 12:21:50 -0500

Pierre: Thank you for attending to my comment.  More inline.

> "Declaration of syntactic structure" is considered for matching,

I will appreciate if the "including 'urn:eidr:'" part made it into the
draft.  Implementers have varying level understanding as they attempt
to divine RFC text.  So to the extent that we can make our intent
explicit with a few additional strokes of the pen (or the keyboard), we
are all the more better off for it.

Cheers,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Nokia Networks
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: [email-masked] / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: Pierre-Anthony Lemieux <[email-masked]>
Date: Tue, 5 Jul 2016 10:25:55 -0700

Hi Vijay,

> I will appreciate if the "including 'urn:eidr:'" part made it into the draft.

Ok.

BTW, should I plan on creating a new I-D before the scheduled
telechat, or after?

Thanks,

-- Pierre

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 5 Jul 2016 18:35:40 +0100

Hi,

> BTW, should I plan on creating a new I-D before the scheduled
You can post a new version any time. Before the telechat would be 
slightly better.

---

From: Pierre-Anthony Lemieux <[email-masked]>
Date: Tue, 5 Jul 2016 10:37:05 -0700

Hi Alexey,

Will do.

Best,

-- Pierre

On Tue, Jul 5, 2016 at 10:35 AM, Alexey Melnikov
<[email-masked]> wrote:
>>> draft.
> You can post a new version any time. Before the telechat would be slightly
> better.
>
>> Thanks,
>>
>> -- Pierre
>>
>>>>> string
>>>>> match?

---

From: Pierre-Anthony Lemieux <[email-masked]>
Date: Tue, 5 Jul 2016 17:45:12 -0700

Hi Vijay,

A revised I-D that adds a note under "Rules for Lexical Equivalence"
is available at [1].

[1] https://www.ietf.org/id/draft-pal-eidr-urn-2016-02.txt

Best,

-- Pierre

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 6 Jul 2016 08:01:07 -0500

> [1] https://www.ietf.org/id/draft-pal-eidr-urn-2016-02.txt

Awesome!  Thanks.

- vijay

---

From: Jari Arkko <[email-masked]>
Date: Thu, 7 Jul 2016 16:44:39 +0300

Thanks, Vijay and all.

Jari