Subject: Re: [Gen-art] Gen-ART review of draft-ietf-isis-remaining-lifetime-02

From: Christer Holmberg <[email-masked]>
Date: Sat, 6 Aug 2016 17:02:59 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>
Document:                       draft-ietf-isis-remaining-lifetime-02
Reviewer:                         Christer Holmberg
Review Date:                   6 August 2016
IETF LC End Date:            15 August 2016
IETF Telechat Date:        N/A

Summary:
The document is well written, and almost ready for publication as a standards track RFC, but I have a couple of editorial comments that I'd like the authors to address.
Major Issues:    None
Minor Issues:    None
Editorial Issues:
The Abstract says:
"Corruption of the Remainining Lifetime Field in a Link State PDU can go undetected.  In certain scenarios this may cause or exacerbate flooding storms.  It is also a possible denial of service attack vector.  This document defines a backwards compatible solution to this problem."
...and the first sentence of the Problem Statement says:
"Each Link State PDU (LSP) includes a Remaining Lifetime field."
I have no idea what a Link State PDU is, and there is no introduction to what the draft is all about. The text jumps direction into the work.
So, please add a reference to Link State PDU (LSP), and please give a little bit of introduction text what context/environment this is all about. I assume there is some core document which describes the context/environment where the Link State PDU is used?

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 8 Aug 2016 13:39:17 +0000

Christer -

Thanx for your review.

ISO 10589 is the base specification for IS-IS and there is a reference to it in the document.
This is where you will find details about Link State PDUs.

I would be reluctant to include any sort of summary description of an LSP in this document out of fear that it might be seen as differing from the base protocol specification.

I hope this addresses your concerns.

   Les

From: Christer Holmberg [mailto:[email-masked]]
Sent: Saturday, August 06, 2016 10:03 AM
To: [email-masked]; [email-masked]
Subject: RE: Gen-ART review of draft-ietf-isis-remaining-lifetime-02

Summary:

---

From: Antoni Przygienda <[email-masked]>
Date: Mon, 8 Aug 2016 15:27:45 +0000

+1 to what Les thinks …

--- tony

<[email-masked]<mailto:[email-masked]>> spake:

Christer –

Thanx for your review.

   Les

Summary:
The document is well written, and almost ready for publication as a standards track RFC, but I have a couple of editorial comments that I’d like the authors to address.
Major Issues:    None
Minor Issues:    None
Editorial Issues:
The Abstract says:
“Corruption of the Remainining Lifetime Field in a Link State PDU can go undetected.  In certain scenarios this may cause or exacerbate flooding storms.  It is also a possible denial of service attack vector.  This document defines a backwards compatible solution to this problem.”
…and the first sentence of the Problem Statement says:
“Each Link State PDU (LSP) includes a Remaining Lifetime field.”
I have no idea what a Link State PDU is, and there is no introduction to what the draft is all about. The text jumps direction into the work.
So, please add a reference to Link State PDU (LSP), and please give a little bit of introduction text what context/environment this is all about. I assume there is some core document which describes the context/environment where the Link State PDU is used?

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 8 Aug 2016 17:28:07 +0000

Hi,

>I would be reluctant to include any sort of summary description of an LSP in this document out of fear that it might be seen as differing from the base protocol specification.

I think it would be useful to place that reference also in the Abstract, and in the problem statement, before you start talking about the LSP.

You don't have to add an LSP description, simply a reference so that it is easy for me to know where to get more information - without having to look for the reference elsewhere in the document :)

Regards,

Christer

From: Christer Holmberg [mailto:[email-masked]]
Sent: Saturday, August 06, 2016 10:03 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: Gen-ART review of draft-ietf-isis-remaining-lifetime-02

Summary:

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 8 Aug 2016 17:39:01 +0000

Christer -

I will place a reference in the Introduction - something like:

"[ISO10589} defines the format of a Link State PDU (LSP) which includes a Remaining Lifetime field..."

Hope that will suffice.

   Les

From: Christer Holmberg [mailto:[email-masked]]
Sent: Monday, August 08, 2016 10:28 AM
To: Les Ginsberg (ginsberg); [email-masked]; [email-masked]
Subject: RE: Gen-ART review of draft-ietf-isis-remaining-lifetime-02

Hi,

Regards,

Christer

Summary:

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 8 Aug 2016 17:40:08 +0000

That should work :)

Thanks!

Regards,

Christer

From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
Sent: 08 August 2016 20:39
To: Christer Holmberg <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: Gen-ART review of draft-ietf-isis-remaining-lifetime-02

Christer -

Hope that will suffice.

   Les

From: Christer Holmberg [mailto:[email-masked]]
Sent: Monday, August 08, 2016 10:28 AM
To: Les Ginsberg (ginsberg); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: Gen-ART review of draft-ietf-isis-remaining-lifetime-02

Hi,

Regards,

Christer

Summary:

---

From: Jari Arkko <[email-masked]>
Date: Wed, 17 Aug 2016 22:11:25 +0200

Thanks, all.

Jari

On 08 Aug 2016, at 19:40, Christer Holmberg <[email-masked]> wrote:

> I will place a reference in the Introduction – something like:
> 
> “[ISO10589} defines the format of a Link State PDU (LSP) which includes a Remaining Lifetime field…”
> 
> Hope that will suffice.
> 
>    Les
> 
> 
> You don’t have to add an LSP description, simply a reference so that it is easy for me to know where to get more information - without having to look for the reference elsewhere in the document :)
> 
> Regards,
> 
> Christer
> 
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art