Subject: [Gen-art] [Gem-art] Gem-ART review of draft-moriaty-pkcs1-03

From: Lucy yong <[email-masked]>
Date: Thu, 15 Sep 2016 16:21:56 +0000

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>
Document:                       draft-moriaty-pkcs1-03
Reviewer:                         Lucy Yong
Review Date:                   15 September 2016
IETF LC End Date:            2 September 2016

Summary:
The document is well written, and is ready for publication as Informational RFC. IPR considerations are in Appendix D.
Major Issues:    None
Minor Issues:

*         Several places use xxx-PKCS-v1_5, should it be xxx-PKCS1-v1_5? where xxx may be EMSA, RSAES, and RSASSA.
Editorial Issues:

*         Please check the Idnits tool

*         Page 18: s/k - 2hLen -2/k - 2hLen - 2/

*         Page 18: s/"knowing"the/"knowing" the/

*         Page 40: s/ -- such as the salt value in EMSA-PSS --/ such as the salt value in EMSA-PSS/

*         replace Section 7.2.2. title with "Decryption operation"

*         In Section 8.2, s/Note:/Note./   (to be consistent with the rest of doc.)

*         Section 8.2 last paragraph, replace "recommended" with "RECOMMENDED"
Regards,
Lucy

---

From: "Kaliski, Burt" <[email-masked]>
Date: Mon, 19 Sep 2016 21:23:57 +0000

Dear Lucy,

Thank you very much for the careful review.

These are all good catches, especially the need to change several labels from "PKCS" to "PKCS1" to match the corresponding PKCS #1 v2.2 document:  https://www.emc.com/collateral/white-papers/h11300-pkcs-1v2-2-rsa-cryptography-standard-wp.pdf

My co-authors may have additional feedback.

n  Burt

From: Lucy yong [mailto:[email-masked]]
Sent: Thursday, September 15, 2016 12:22 PM
To: [email-masked]; [email-masked]
Subject: [Gem-art] Gem-ART review of draft-moriaty-pkcs1-03

Summary: