Subject: Re: [Gen-art] Review: draft-ietf-pim-join-attributes-for-lisp-05

From: Jari Arkko <[email-masked]>
Date: Thu, 1 Dec 2016 15:32:25 +0200

Lucy,

Many thanks for your review.

Dino, Stig, does this discussion lead you to consider adding some clarifications to the document? I am not going to require those (just posted a no-obj for the document on today’s telechat), but wanted to give you an opportunity to consider that.

Jari

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 1 Dec 2016 11:06:45 -0800

> Dino, Stig, does this discussion lead you to consider adding some clarifications to the document? I am not going to require those (just posted a no-obj for the document on today’s telechat), but wa…

The base LISP multicast architecture is all explained in RFC6831. From the type of commentary from Lucy’s email, it led me to believe she (1) had not read RFC6831 or (2) did not understand the content of RFC6831.

Discussing how LISP multicast works in a PIM document is a misplacement of information and risks contradicting what is in the LISP published RFCs.

Dino

---

From: Lucy yong <[email-masked]>
Date: Thu, 1 Dec 2016 19:31:51 +0000

Hi Dino,

Sorry, I did not have time to study RFC6831 for this review work and may not interpret the draft properly by reading it. I trust you on the protocol design and have no objection on Jari's decision.

Could you make this sentence more readable?

   It determines the downstream destination for unicast head-end replication and identifies the
   receiver ETR that needs to be notified should the root of the
   distribution tree move to another site.

"should be", "moving"?

Thanks,
Lucy
-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Thursday, December 01, 2016 1:07 PM
To: Jari Arkko
Cc: Lucy yong; [email-masked]; General Area Review Team; Stig Venaas
Subject: Re: [Gen-art] Review: draft-ietf-pim-join-attributes-for-lisp-05

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 1 Dec 2016 11:44:34 -0800

> "should be", "moving”?

I do not understand what you are suggesting. Write more words please.

Dino

---

From: Lucy yong <[email-masked]>
Date: Thu, 1 Dec 2016 19:48:26 +0000

OK, forget my suggestion. I have a difficulty to parse this sentence (second part)

Lucy

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Thursday, December 01, 2016 1:45 PM
To: Lucy yong
Cc: Jari Arkko; [email-masked]; General Area Review Team; Stig Venaas
Subject: Re: [Gen-art] Review: draft-ietf-pim-join-attributes-for-lisp-05

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 1 Dec 2016 11:53:00 -0800

>  distribution tree move to another site.

First off, let’s include the entire paragraph:

   Knowledge of the receiver ETR's RLOC address is also essential to the
   control plane of the root ITR.  It determines the downstream
   destination for unicast head-end replication and identifies the
   receiver ETR that needs to be notified should the root of the
   distribution tree move to another site.

How about we change to this:

   Knowledge of the receiver ETR's RLOC address is also essential to the
   control plane of the root ITR.  The RLOC address determines the downstream
   destination for unicast head-end replication and identifies the
   receiver ETR that needs to be notified should the root ITR of the
   distribution tree move to another site. The root ITR can change when the
   source EID is roaming to another LISP site.

Dino

---

From: Jari Arkko <[email-masked]>
Date: Thu, 1 Dec 2016 21:55:39 +0200

That would work for me.

Jari

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 1 Dec 2016 12:01:19 -0800

There is no other text in the email. So can’t be sure what you are saying. I’m guessing you are fine with the proposed text?

My co-authors have to agree though.  ;-)

Dino

> On Dec 1, 2016, at 11:55 AM, Jari Arkko <[email-masked]> wrote:
> 
> That would work for me.
> 
> Jari
>

---

From: Lucy yong <[email-masked]>
Date: Thu, 1 Dec 2016 20:02:04 +0000

Thank you, Dino. Good, I understand it now.

Lucy

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Thursday, December 01, 2016 1:53 PM
To: Lucy yong
Cc: Jari Arkko; [email-masked]; General Area Review Team; Stig Venaas
Subject: Re: [Gen-art] Review: draft-ietf-pim-join-attributes-for-lisp-05

>  It determines the downstream destination for unicast head-end 
> replication and identifies the  receiver ETR that needs to be notified 
> should the root of the  distribution tree move to another site.
> 
> Lucy

Dino

> Cc: Jari Arkko; 
> [email-masked]; General Area 
> Review Team; Stig Venaas
> Subject: Re: [Gen-art] Review: 
> draft-ietf-pim-join-attributes-for-lisp-05
> 
> 
>>  It determines the downstream destination for unicast head-end 
>> replication and identifies the  receiver ETR that needs to be 
>> notified should the root of the  distribution tree move to another site.
>> 
>> "should be", "moving”?
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 1 Dec 2016 22:59:10 +0200

> There is no other text in the email. So can’t be sure what you are saying. I’m guessing you are fine with the proposed text?

yes, the one that you proposed