Subject: Re: [Gen-art] Gen-ART IETF Last Call review of draft-ietf-justfont-toplevel-03

From: "Chris Lilley" <[email-masked]>
Date: Thu, 08 Dec 2016 13:45:28 -0500

On 2016-10-30 18:18:29, Dale R. Worley <[email-masked]> wrote:

7.5. WOFF 1.0

Macintosh Universal Type Identifier code: "org.w3c.woff"

Is this part of a media type registration? (If so, is it required for
all "font" subtypes?)
Chris Lilley: 

I opened an issue on Macintosh type codes:
https://github.com/svgeesus/ietf-justfont/issues/26

There are two Apple-specific systems: the old four-character Macintosh Type Codes mentioned in the Media Types registration template, which were in use up to Mac OS 9 but are no longer used, and the newer Universal Type Identifiers used in OS X.

I raised the issue of which to use (on [email-masked])

and got a swift response from Ned Freed suggesting that the legacy Macintosh Type Codes were of little value, and that adding the current Macintosh  UTI was probably beneficial.

In response, I checked all the  Macintosh Type Codes in the current document; they all say "(no code specified)" which seems optimal.

I also looked at the Apple documentation for UTIs. There are two forms, the 'public' ones defined by Apple and the extensible, java-style reverse DNS ones for other organisations.
https://developer.apple.com/library/content/documentation/FileManagement/Conceptual/understanding_utis/understand_utis_conc/understand_utis_conc.html#//apple_ref/doc/uid/TP40001319-CH202-CHDHIJDE

There is a registry of the public ones, including font-related UTIs like public.truetype-font and so on
https://developer.apple.com/library/content/documentation/Miscellaneous/Reference/UTIRef/Articles/System-DeclaredUniformTypeIdentifiers.html#//apple_ref/doc/uid/TP40009259-SW1

I added these to the current document, so all font subtypes now have this information.

I have thus closed this issue.

--
Chris Lilley
@svgeesus
Technical Director @ W3C
W3C Strategy Team, Core Web Design
W3C Architecture & Technology Team, Core Web & Media

---

From: "Chris Lilley" <[email-masked]>
Date: Thu, 08 Dec 2016 16:56:46 -0500

7.1. Generic SFNT font type

I can see why a comma-separated list is necessary, but that means that
"Values: TTF, CFF, SVG" is not strictly correct. Perhaps something
like the following (and let IANA figure out how to express that in
http://www.iana.org/assignments/media-type-sub-parameters/media-type-sub-parameters.xhtml):

Values: a comma-separated subset of: TTF, CFF, SVG
Chris Lilley:
I adopted your suggested wording (and removed the optional whitespace).
https://github.com/svgeesus/ietf-justfont/commit/8ad639638e51f85b5592724ff621d17e7c864253

Similarly for other parameters which can take a comma-separated list
of defined values.

Parameter definitions seem to need specification of registration
procedures. (See the sub-type-parameter registry mentioned above;
each parameter has a listed registration procedure.)
Chris Lilley: 

I had a look at the xml source of the MIME Media Type Sub-Parameter Registries:
http://www.iana.org/assignments/media-type-sub-parameters/media-type-sub-parameters.xml

and created a small XML file with updates for the two parameters (outlines and layout) defined in this draft.

The file is on GitHub as
https://github.com/svgeesus/ietf-justfont/blob/master/registries.xml

and here is the commit.
https://github.com/svgeesus/ietf-justfont/commit/59a235aaae68a0f7ff37c80bf85f1fbd3b663e31