Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-idr-deprecate-30-31-129-00

From: Meral Shirazipour <[email-masked]>
Date: Fri, 16 Dec 2016 00:35:40 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.
For more information, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-idr-deprecate-30-31-129-00
Reviewer: Meral Shirazipour
Review Date: 2016-12-15
IETF LC End Date:  2016-12-16
IESG Telechat date: NA

Summary:
This draft is ready to be published as Standards Track RFC but I have some comments.

Major issues:

Minor issues:
-[Page 2]:
"This has led to  deployment problems for new technologies such as Large BGP
   Communities [I-D.ietf-idr-large-community]."

Not sure if draft-ietf-idr-large-community explains the issues caused by the use of these attribute values ? If yes it would be good to point to that section.  If not it would be good to add short summary here.

Nits/editorial comments:
-[Page 2], Section 4 please refer to latest version of [I-D.ietf-idr-large-community].

-[Page 2]:
"   The squatting of values 30, 31, 129, 241, 242 and 243 has been
   confirmed by the involved vendors or through source code review."

A bit confusing, somehow it seems 30 is already deprecated as per: https://www.ietf.org/assignments/bgp-parameters/bgp-parameters.xml with reference to [draft-ietf-idr-large-community].
The switch between used of 30 to  use of 32 happened between v04 and v05 of [draft-ietf-idr-large-community]?
Perhaps https://www.ietf.org/assignments/bgp-parameters/bgp-parameters.xml should be updated to point to this draft instead?

Best Regards,
Meral
---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: Job Snijders <[email-masked]>
Date: Sat, 17 Dec 2016 13:10:05 +0100

Dear Meral,

A new version of the draft has been published to address your comments.
Please review the diff here:

    https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-deprecate-30-31-129-01

On Fri, Dec 16, 2016 at 12:35:40AM +0000, Meral Shirazipour wrote:
> "This has led to  deployment problems for new technologies such as
> Large BGP Communities [I-D.ietf-idr-large-community]."
> 
> Not sure if draft-ietf-idr-large-community explains the issues caused
> by the use of these attribute values ? If yes it would be good to
> point to that section.  If not it would be good to add short summary
> here.

A short summary has been added.

> [I-D.ietf-idr-large-community].

I mistakenly linked to -08 (while -11 is the latest version), this will
be corrected before publication.

> -[Page 2]:
> "The squatting of values 30, 31, 129, 241, 242 and 243 has been
> A bit confusing, somehow it seems 30 is already deprecated as per:
> https://www.ietf.org/assignments/bgp-parameters/bgp-parameters.xml
> with reference to [draft-ietf-idr-large-community].
> Perhaps https://www.ietf.org/assignments/bgp-parameters/bgp-parameters.xml
> should be updated to point to this draft instead?

Yes, I expect IANA to remove the reference to Large Communities behind
30 (because Large no longer has anything to do with value 30, and indeed
we want to prevent confusion), and reference this document, if approved
for publication.

Kind regards,

Job

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 27 Dec 2016 18:30:12 +0000

Hi,
  Many thanks for the changes.

Best Regards,
Meral

> -----Original Message-----
> From: Job Snijders [mailto:[email-masked]]
> Sent: Saturday, December 17, 2016 4:10 AM
> To: Meral Shirazipour <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: Re: Gen-ART Last Call review of draft-ietf-idr-deprecate-30-31-129-00
> 
> Dear Meral,
> 
> I mistakenly linked to -08 (while -11 is the latest version), this will be corrected
> before publication.
> 
> > -[Page 2]:
> > Perhaps
> 30 (because Large no longer has anything to do with value 30, and indeed we
> want to prevent confusion), and reference this document, if approved for
> publication.
> 
> Kind regards,
> 
> Job