Subject: [Gen-art] Review of draft-ietf-geojson-text-sequence-03

From: Robert Sparks <[email-masked]>
Date: Mon, 23 Jan 2017 10:53:45 -0800

Reviewer: Robert Sparks
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at
<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-geojson-text-sequence-03
Reviewer: Robert Sparks
Review Date: 2017-01-23
IETF LC End Date: 2017-01-24
IESG Telechat date: 2017-02-02

Summary: Ready for publication as Proposed Standard, but with nits
that should be addressed before proceeding

The last call was issued indicating this draft is being considered for
Proposed Standard (which is appropriate). The draft itself has
"Informational" in its header block. That should be "Standards Track"
instead.

The Abstract contains the words "proposed standard". Please edit that
away. You want the flexibility in the future to change the status of
the RFC this will become without having to issue a new RFC editing the
text. I suggest replacing "A proposed standard" with "This document
defines a format"

In the introduction, you say "possibly infinite". I think you mean
"arbitrarily large".

---

From: Jari Arkko <[email-masked]>
Date: Tue, 24 Jan 2017 14:30:18 +0200

Robert,

Thanks for the review, again!

And thank you so much (for the whole set of people) for the
new review tool and integration to the tracker. It makes
my life much easier.

Just a couple of discussion points relating to how we post
these today wrt. before when we didn’t have the new tool yet.

First, there’s been a change from “Gen-ART review: ….” to
“Review of …” in the e-mail subject lines. Which do people
prefer? I’ve obviously worked from the only-email-model
so far, and ultimately me (or the next chair) will find the
new ways of working. Which might be different from we’ve
used to do. However, a knee jerk reaction from my side
was that I’d like to see Gen-ART as a part of the subject
line, because I often end up searching in e-mail. But
maybe I shouldn’t...

Second, I’ve noticed that there’s been a couple of
reviews that were in the tracker only, and were not
posted via e-mail. Again, wondering if I’m just feeling
anxiety over the change :-) or if there’s a real reason
why we’d like to have also email. After being confused
for one or two documents, I now know to to look at
the tracker as well as e-mail. Maybe I should just
work from the tracker in this case? But I wonder if I’ll end
up searching on e-mail _as well_ anyway, because
somebody may have responded on e-mail side, and
this might not be reflected in the tracker. Or is it?

For the second issue, it might be possible to have
the tool automatically mail reviews… and I think
it does, except unless asked to do so (?)

But I’m obviously just one user among many. I have
my own viewpoint, and arguably e.g., the role of
the authors and other WG participants is an important
one, more important than mine, because it is absolutely
essential that they see whatever is commented.

So I don’t want to drive any process from my
limited viewpoint, but rather bring up an issue
that surprises me and then discuss what’s the
best way to handle that. And since the review
tool is new, this would be a good moment for
us to hash out any minor usage practices.

Thoughts?

Jari

---

From: Robert Sparks <[email-masked]>
Date: Tue, 24 Jan 2017 07:35:55 -0600

> line, because I often end up searching in e-mail. But
We already have a request to either put the review team
acronym on the subject line, or make the subject line
a template that teams can customize.
> this might not be reflected in the tracker. Or is it?
The tracker will point to the review in the archives (if it
sent the message or if the reviewer tells the tracker about
the message). The mailarchive tool's thread view can then
find followups. The tracker is not intrinsically aware of any
followup messages.

> it does, except unless asked to do so (?)
Yes, if you enter the review in the tracker, it will send
the message to the review team list. There's no way to
ask it not to do that. The reviewer can change what _other_
lists are copied, but that's the extent.

Can you point me to an example of a review that appeared
in the tracker but not on the list? That sounds to me like
you've found a bug.
> us to hash out any minor usage practices.
Agreed - my answers above reflect what I expect the
tool to be doing now, and what we already think we
want to change. But if anyone feels a different set of
changes would be better, now would be a good time
to discuss them.

---

From: [email-masked] (Dale R. Worley)
Date: Tue, 24 Jan 2017 10:27:55 -0500

Jari Arkko <[email-masked]> writes:
> prefer?

It may depend on who you are.  I only see reviews via the gen-art
mailing list or followups thereto, so the subject line always has
"[Gen-art]" in it.  But other people get the messages by other paths,
and so they may not see distinctive subject lines.

Also, is there a reason why people would want to see "Gen-ART last-call
review of ..." vs. "Gen-ART telechat review of ..."?  It wouldn't make a
difference to me, but perhaps it is useful input to someone else's
workflow.

I have noted that the current review template includes this information
block:

    Document:
    Reviewer:
    Review Date:
    IETF LC End Date:
    IESG Telechat date: [if known]

The last two dates take some work to find -- would it be possible to
include them in the "review request" screen (e.g.,
https://datatracker.ietf.org/doc/draft-ietf-teas-gmpls-resource-sharing-proc/reviewrequest/8100/)?

Dale

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 25 Jan 2017 08:05:00 +1300

On 25/01/2017 04:27, Dale R. Worley wrote:
...
> difference to me, but perhaps it is useful input to someone else's

IMHO, it makes a difference. The primary audience for the LC review
is the authors - they are on the hook for *all* last call comments.
The primary audience for the telechat review is the General AD, who
needs to decide how to ballot. Back when I was General AD and Gen-ART
was relatively new, I generally didn't have time to even look at the
LC reviews. Having a distinctive subject on the email was very helpful.

  Brian