Subject: [Gen-art] review of draft-ietf-softwire-dslite-multicast-14.txt

From: Francis Dupont <[email-masked]>
Date: Mon, 09 Jan 2017 15:34:05 +0100

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-softwire-dslite-multicast-14.txt
Reviewer: Francis Dupont
Review Date: 20170106
IETF LC End Date: 2017012
IESG Telechat date: unknown

Summary: Ready with Nits

Major issues: None

Minor issues: please consider to publish this as a BCP (vs standard track)?
I don't know if this question is new or already got an answer,
this is why I kept the Ready summary. BTW the IANA section is empty
so there is nothing requiring a standard track document.

Nits/editorial comments: 
 - ToC page 3 and 10 page 16: Acknowledgements -> Acknowledgments 

 - 4.2 page 7: RECOMMENDED inside an explicitly "not normative"
  section 4

 - 6.1 page 11: in "The mB4 may create": may -> MAY?

 - 6.3 page 11: in "decapsulate the IPv6 packet": IPv6 -> IPv4

 - 7.2 page 13 figure 3 and 8.1.1 page 15 figure 4:
   mPreifx64 -> mPrefix64

 - 7.2 page 13 last paragraph: (S6,G6) -> (S6, G6)
  (I am not strict about space or not but in this paragraph there is
   already a (S6, G6))

 - 7.5 page 14: Global scope;) -> Global scope)

 - 8.4 page 16: please use a non-breaking space so (S6, G6) stays
  on the same line in the text version (and hopefully (S4, G4) too).

 - Authors' Addresses page 20: China -> PR China (or any variant
  including CN (ISO IS 3166 2 letter code))

Regards

[email-masked]

---

From: <[email-masked]>
Date: Mon, 9 Jan 2017 15:11:49 +0000

Hi Francis, 

Thank you for the review. 

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Francis Dupont [mailto:[email-masked]]
> Envoyé : lundi 9 janvier 2017 15:34
> À : [email-masked]
> Cc : [email-masked]
> Objet : review of draft-ietf-softwire-dslite-multicast-14.txt
> 

[Med] The intended status is aligned with the status used for the counterpart unicast specifications (DS-Lite, MAP-*). 

>  - ToC page 3 and 10 page 16: Acknowledgements -> Acknowledgments

[Med] It seems that the RFC editor accepts "Acknowledgements", too. 

>  - 4.2 page 7: RECOMMENDED inside an explicitly "not normative"

[Med] Good catch. Changed it to "recommended".

>  - 6.1 page 11: in "The mB4 may create": may -> MAY?
[Med] Yes, fixed. 

>  - 6.3 page 11: in "decapsulate the IPv6 packet": IPv6 -> IPv4
[Med] What about "decapsulate the IPv6 header"?

>  - 7.2 page 13 figure 3 and 8.1.1 page 15 figure 4:
[Med] Thank you for catching those. Fixed. 

>   (I am not strict about space or not but in this paragraph there is

[Med] I guess you meant change (S6, G6) to (S6,G6). Fixed. 

>  - 7.5 page 14: Global scope;) -> Global scope)
[Med] I changed it to:

OLD: 
to "E" Global scope;)

NEW: 

to "E" for Global scope)

>   on the same line in the text version (and hopefully (S4, G4) too).

[Med] Actually, I removed the extra space to be consistent with other usages in the document.

>   including CN (ISO IS 3166 2 letter code))

[Med] Changed it to "P.R. China".